Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 458354 - video_cards_geode is masked in profile hardened/linux/uclibc/x86
Summary: video_cards_geode is masked in profile hardened/linux/uclibc/x86
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 20:19 UTC by Mark Reiche
Modified: 2013-05-28 15:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Reiche 2013-02-19 20:19:13 UTC
I have set VIDEO_CARDS="geode" in my make.conf.

emerge -pv xorg-drivers 
shows that geode (and others) are masked.

however, since it is actually an x86 system, xf86-video-geode emerges without problems

Shouldn't ../../../../arch/x86 be added to hardened/linux/uclibc/x86/parent (like it is done for hardened/linux/x86 ?

Reproducible: Always




emerge --info

Portage 2.1.11.50 (hardened/linux/uclibc/x86, gcc-4.6.3, uclibc-0.9.33.2-r2, 3.5.7-gentoo i686)
=================================================================
System uname: Linux-3.5.7-gentoo-i686-QEMU_Virtual_CPU_version_1.2.2-with-gentoo-2.1
KiB Mem:     2074344 total,    381160 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Tue, 19 Feb 2013 16:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/uclibc:          0.9.33.2-r2
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE"
CBUILD="i686-gentoo-linux-uclibc"
CFLAGS="-O2 -march=geode -pipe -fomit-frame-pointer -mmmx -m3dnow"
CHOST="i686-gentoo-linux-uclibc"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=geode -pipe -fomit-frame-pointer -mmmx -m3dnow"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect compress-build-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="cli cracklib crypt cxx dri fortran hardened iconv ipv6 modules mudflap ncurses nptl openmp pax_kernel pcre pic readline session ssl uclibc unicode x86 xattr zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="gnutls" ELIBC="uclibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en_GB" LIRC_DEVICES="serial" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="snapscan" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Jeroen Roovers gentoo-dev 2013-02-20 15:30:48 UTC
  09 May 2008; Mart Raudsepp <leio@gentoo.org> arch/x86/use.mask,
  base/use.mask, default-linux/x86/use.mask:
  Mask video_cards_geode USE flag on all platforms but x86, as it is a video
  card integrated into the Geode GX/LX CPU chip, which is x86.
Comment 2 Anthony Basile gentoo-dev 2013-05-28 15:21:50 UTC
(In reply to Jeroen Roovers from comment #1)
>   09 May 2008; Mart Raudsepp <leio@gentoo.org> arch/x86/use.mask,
>   base/use.mask, default-linux/x86/use.mask:
>   Mask video_cards_geode USE flag on all platforms but x86, as it is a video
>   card integrated into the Geode GX/LX CPU chip, which is x86.

The hardened/linux/uclibc do not inherit arch, rather they are very shallow:

    /usr/portage/profiles/base
    /usr/portage/profiles/default/linux
    /usr/portage/profiles/hardened/linux/uclibc
    /usr/portage/profiles/hardened/linux/uclibc/<arch>

This was intentional because 1) profile stacking is very hard to control, 2) what profile/arch means is blurred.

Anyhow, this is now unmasked:

+  28 May 2013; Anthony G. Basile <blueness@gentoo.org>
+  hardened/linux/uclibc/x86/use.mask:
+  Unmask video_cards_geode on hardened/linux/uclibc/x86, bug #458354
+