Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458320 - www-plugins/google-talkplugin-3.16.0.0 does not work correctly
Summary: www-plugins/google-talkplugin-3.16.0.0 does not work correctly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal major (vote)
Assignee: Christoph Junghans
URL:
Whiteboard:
Keywords: REGRESSION
Depends on:
Blocks:
 
Reported: 2013-02-19 16:38 UTC by Stefano
Modified: 2014-05-22 11:27 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
strace of google's talk plugin (talk-plugin.log,250.81 KB, text/plain)
2013-03-25 07:32 UTC, Markus Rathgeb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefano 2013-02-19 16:38:07 UTC
After the upgrade, the new plugin does not work, neither with chromium nor firefox.

The errors dumped to the console are:
$ chromium
[3863:3887:0219/173520:ERROR:object_proxy.cc(608)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[3863:3887:0219/173520:ERROR:object_proxy.cc(608)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[3863:3863:0219/173520:ERROR:object_proxy.cc(513)] Failed to call method: org.chromium.Mtpd.EnumerateStorage: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
No bp log location saved, using default.
[000:000] Browser XEmbed support present: 1
[000:000] Browser toolkit is Gtk2.
[000:000] Using Gtk2 toolkit
[000:029] Starting client channel.
[000:029] Read port file, port=39499
[000:030] Initiated connection to GoogleTalkPlugin
[000:101] Socket connection established
[000:101] ScheduleOnlineCheck: Online check in 5000ms
[003:189] Starting client channel.
[003:189] Read port file, port=39499
[003:189] Initiated connection to GoogleTalkPlugin
[003:208] Socket connection established
[003:208] ScheduleOnlineCheck: Online check in 5000ms
[005:114] HandleOnlineCheck: Starting check
[005:114] Warning(clientchannel.cc:701): Not authorized; attempting to restart flute
[006:116] Restarting GoogleTalkPlugin...
[006:117] Warning(pluginutils.cc:243): Failed to get GoogleTalkPlugin path. Trying default.
[006:118] Started GoogleTalkPlugin, path=/opt/google/talkplugin/GoogleTalkPlugin
[006:118] Waiting for GoogleTalkPlugin to start...
[007:119] Attempting to connect to GoogleTalkPlugin...
[007:119] Read port file, port=39499
[007:119] Initiated connection to GoogleTalkPlugin
[007:119] Socket connection established
[007:119] ScheduleOnlineCheck: Online check in 5000ms
[008:221] HandleOnlineCheck: Starting check
[008:221] Warning(clientchannel.cc:701): Not authorized; attempting to restart flute
[009:223] Restarting GoogleTalkPlugin...
[009:223] Warning(pluginutils.cc:243): Failed to get GoogleTalkPlugin path. Trying default.
[009:225] Started GoogleTalkPlugin, path=/opt/google/talkplugin/GoogleTalkPlugin
[009:225] Waiting for GoogleTalkPlugin to start...
[010:225] Attempting to connect to GoogleTalkPlugin...
[010:225] Read port file, port=39499
[010:225] Initiated connection to GoogleTalkPlugin
[010:225] Socket connection established
[010:225] ScheduleOnlineCheck: Online check in 5000ms
[012:130] HandleOnlineCheck: Starting check
[012:130] Warning(clientchannel.cc:672): Not authorized; restart already tried, giving up
[015:236] HandleOnlineCheck: Starting check
[015:236] Warning(clientchannel.cc:672): Not authorized; restart already tried, giving up
[031:841] Starting client channel.
[031:841] Read port file, port=39499
[031:842] Initiated connection to GoogleTalkPlugin
[031:875] Socket connection established
[031:875] ScheduleOnlineCheck: Online check in 5000ms
[036:887] HandleOnlineCheck: Starting check
[036:887] Warning(clientchannel.cc:701): Not authorized; attempting to restart flute
[037:888] Restarting GoogleTalkPlugin...
[037:888] Warning(pluginutils.cc:243): Failed to get GoogleTalkPlugin path. Trying default.
[037:890] Started GoogleTalkPlugin, path=/opt/google/talkplugin/GoogleTalkPlugin
[037:890] Waiting for GoogleTalkPlugin to start...
[038:891] Attempting to connect to GoogleTalkPlugin...
[038:891] Read port file, port=39499
[038:891] Initiated connection to GoogleTalkPlugin
[038:891] Socket connection established
[038:891] ScheduleOnlineCheck: Online check in 5000ms
^[[5~[043:900] HandleOnlineCheck: Starting check
[043:900] Warning(clientchannel.cc:672): Not authorized; restart already tried, giving up

Reproducible: Always




$ emerge --info
Portage 2.1.11.50 (default/linux/x86/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.5.7-gentoo i686)
=================================================================
System uname: Linux-3.5.7-gentoo-i686-Intel-R-_Core-TM-_i7-2760QM_CPU_@_2.40GHz-with-gentoo-2.1
KiB Mem:     8265584 total,   6497232 free
KiB Swap:   16463868 total,  16463868 free
Timestamp of tree: Mon, 18 Feb 2013 21:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -msse4 -mcx16 -mpopcnt -msahf"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer -msse4 -mcx16 -mpopcnt -msahf"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ http://gentoo.mirror.solnet.ch http://gentoo.intergenia.de ftp://ftp.solnet.ch/mirror/Gentoo"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa archive arts async bash-completion berkdb bindist bluetooth branding bzip2 cairo cardbus cdda cdparanoia cdr cli consolekit cracklib crypt css cups curlwrappers cxx dbus declarative dell dga dhcp directfb djbfft dri dts dvb dvd dvdr emboss encode exif fat fbcon fbsplash fftw firefox flac foomaticdb fortran fpx ftp gdbm gif glibc-omitfp gnutls gphoto2 gpm gs gtk gzip handbook hpn hybrid-auth iconv icq idea imagemagick imap ipod iproute2 ipv6 irda jabber java javascript john jpeg jpeg2k kde kipi kpathsea lapack libnotify lilo lm_sensors mad mbox messages mime mmap mmx mmxext mng modules mozilla mp3 mp4 mpeg mplayer msn mudflap mysqli nagios-dns ncurses nls nocd nptl nsplugin ntfs ntlm nvidia octave ogg opengl optimization optimized-qmake oscar pam pango pcapnav pcmcia pcntl pcre pda pdf perl phonon plasma png policykit posix ppds pulseaudio python qt3support qt4 radius rdesktop readline replytolist samba scanner semantic-desktop session sharedmem silc slp sms sockets sox spell sse sse2 sse3 sse4 sse4_1 sse4a ssl ssse3 startup-notification svg svga sysfs sysvipc tcpd threads tiff truetype udev udisks unicode upower usb userlocales v4l v4l2 vcd vorbis wifi winbind wps wxwidgets x264 x86 xcb xcomposite xinerama xml xmlrpc xscreensaver xv xvid xvmc yahoo zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Agostino Sarubbo gentoo-dev 2013-02-19 17:02:15 UTC
this is fine here.
Comment 2 Stefano 2013-02-19 20:16:07 UTC
(In reply to comment #1)
> this is fine here.

Happy to hear that. It's not, over here. Downgrading fixes the issue, so the issue is precisely with the new version.
Comment 3 Christoph Junghans gentoo-dev 2013-02-19 20:46:32 UTC
(In reply to comment #0)
> [3863:3887:0219/173520:ERROR:object_proxy.cc(608)] Failed to get name owner.
> Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name
> 'org.chromium.Mtpd': no such name
Are you using a proxy?
Comment 4 Stefano 2013-02-20 10:16:03 UTC
(In reply to comment #3)

> Are you using a proxy?

Nope, I am NATted, but no proxy in use (unless it's something transparent somewhere).
Comment 5 Christoph Junghans gentoo-dev 2013-02-24 20:02:10 UTC
I did a hangout today and the camera wouldn't work.
$ grep -i Google /var/log/messages
Feb 24 12:18:09 x230 kernel: GoogleTalkPlugi[5351]: segfault at 0 ip 00007fb64d1d7491 sp 00007fff918b3588 error 4 in libc-2.15.so[7fb64d087000+19e000]

Downgrade helped, so google-talkplugin-3.13.2.0 is not a good stabilization cadidate.
Comment 6 Agostino Sarubbo gentoo-dev 2013-02-24 21:27:02 UTC
(In reply to comment #5)
> I did a hangout today and the camera wouldn't work.
> $ grep -i Google /var/log/messages
> Feb 24 12:18:09 x230 kernel: GoogleTalkPlugi[5351]: segfault at 0 ip
> 00007fb64d1d7491 sp 00007fff918b3588 error 4 in
> libc-2.15.so[7fb64d087000+19e000]
> 
> Downgrade helped, so google-talkplugin-3.13.2.0 is not a good stabilization
> cadidate.

I always had error like this: 

Feb 15 22:03:58 localhost kernel: grsec: denied RWX mprotect of /opt/google/talkplugin/libgoogletalkremoting.so by /opt/google/talkplugin/GoogleTalkPlugin[GoogleTalkPlugi:15519] uid/euid:1000/1000 gid/egid:1000/1000, parent /sbin/init[init:1] uid/euid:0/0 gid/egid:0/0


Feb 24 22:22:36 localhost kernel: grsec: denied resource overstep by requesting 49 for RLIMIT_RTPRIO against limit 0 for /opt/google/talkplugin/GoogleTalkPlugin[GoogleTalkPlugi:13478] uid/euid:1000/1000 gid/egid:1000/1000, parent /sbin/init[init:1] uid/euid:0/0 gid/egid:0/0


Feb 23 20:24:40 localhost kernel: grsec: denied resource overstep by requesting 69632 for RLIMIT_MEMLOCK against limit 65536 for /opt/google/talkplugin/GoogleTalkPlugin[GoogleTalkPlugi:2381] uid/euid:1000/1000 gid/egid:1000/1000, parent /sbin/init[init:1] uid/euid:0/0 gid/egid:0/0


But the plugin works, I use it 2 / 3 times per day.
Comment 7 Christoph Junghans gentoo-dev 2013-02-26 03:02:07 UTC
@Stefano: Does google-talkplugin-3.14.17.0 help?
Comment 8 Christoph Junghans gentoo-dev 2013-02-27 01:10:15 UTC
3.14.17.0 doesn't work for me, camera give no picture in gmail/chat settings.
Comment 9 Agostino Sarubbo gentoo-dev 2013-02-27 09:59:28 UTC
(In reply to comment #8)
> 3.14.17.0 doesn't work for me, camera give no picture in gmail/chat settings.

works for me with latest chromium on hardened
Comment 10 Fred Krogh 2013-02-28 00:06:31 UTC
Using google-chrome-26.0.1410.12_beta183726
Google talk fails with 3.14.17.0 and works with 3.10.2.0-r1
Comment 11 Christoph Junghans gentoo-dev 2013-02-28 00:10:27 UTC
(In reply to comment #10)
> Using google-chrome-26.0.1410.12_beta183726
> Google talk fails with 3.14.17.0 and works with 3.10.2.0-r1
Same here, but I am on www-client/google-chrome-25.0.1364.97_p183676.
Comment 12 Fred Krogh 2013-02-28 21:48:35 UTC
Just tried google-talkplugin-3.14.17.0-r1, and it doesn't work here either.
Comment 13 Christoph Junghans gentoo-dev 2013-03-07 20:32:03 UTC
Any news with google-talkplugin-3.15.2.0 ?
Comment 14 Fred Krogh 2013-03-08 17:37:34 UTC
google-talkplugin-3.15.2.0 is also not working here
Comment 15 Christoph Junghans gentoo-dev 2013-03-10 00:28:24 UTC
(In reply to comment #14)
> google-talkplugin-3.15.2.0 is also not working here
Same for me.
Comment 16 Dennis Schridde 2013-03-22 14:07:42 UTC
Maybe this is related?

See also: http://productforums.google.com/forum/#!mydiscussions/chat/Vb0csGNWR0k
Comment 17 Dennis Schridde 2013-03-22 14:11:45 UTC
(In reply to comment #16)
> See also:
> http://productforums.google.com/forum/#!mydiscussions/chat/Vb0csGNWR0k

More specifically: http://productforums.google.com/d/msg/chat/Vb0csGNWR0k/qzEj51iWiy4J

For that user, version 3.13 and newer of the plugin are broken, and he found the problem to be that, when Chrome loads GoogleTalkPlugin, it also makes it use Chrome's libudev.so.0, which then somehow calls into the system's libudev.so.1, which produces a segfault.
Comment 18 Christoph Junghans gentoo-dev 2013-03-23 19:31:24 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > See also:
> > http://productforums.google.com/forum/#!mydiscussions/chat/Vb0csGNWR0k
> 
> More specifically:
> http://productforums.google.com/d/msg/chat/Vb0csGNWR0k/qzEj51iWiy4J
> 
> For that user, version 3.13 and newer of the plugin are broken, and he found
> the problem to be that, when Chrome loads GoogleTalkPlugin, it also makes it
> use Chrome's libudev.so.0, which then somehow calls into the system's
> libudev.so.1, which produces a segfault.
Seems more like a chrome problem to me, cc'ing chromium herd.

Btw, google-talkplugin-3.16.0.0 is in gx86, but doesn't fix anything for me.
Comment 19 Mike Gilbert gentoo-dev 2013-03-23 22:04:10 UTC
Yeah, I suspect having libudev.so.0 and libudev.so.1 loaded in the same process is not a great idea.

libudev.so.0 is pulled in by chrome.
libudev.so.1 is pulled in by some dependency of gtk.

If the libudev.so.0 -> libudev.so.1 symlink trick resolves this issue, I guess I can revert back to that.

Can someone try this:

rm /opt/google/chrome/libudev.so.0
ln -s /usr/lib/libudev.so.1 /opt/google/chrome/libudev.so.0
Comment 20 Mike Gilbert gentoo-dev 2013-03-23 22:06:12 UTC
Sorry, that should be:

ln -s /lib/libudev.so.1 /opt/google/chrome/libudev.so.0
Comment 21 Markus Rathgeb 2013-03-24 16:24:00 UTC
Did not work for me.
Comment 22 Markus Rathgeb 2013-03-24 16:34:10 UTC
When you start "/opt/google/talkplugin/GoogleTalkPlugin" from command line before google-chrome is started, you will the, that this will raise a SEGFAULT, if the plugin should be used.
Comment 23 Dennis Schridde 2013-03-24 17:13:41 UTC
(In reply to comment #22)
> When you start "/opt/google/talkplugin/GoogleTalkPlugin" from command line
> before google-chrome is started, you will the, that this will raise a
> SEGFAULT, if the plugin should be used.

I could only reproduce a segfault when I set LD_LIBRARY_PATH=/opt/google/chrome - so that GoogleTalkPlugin finds libudev.so.0 (otherwise it will complain but work happily without a segfault).
Comment 24 Christoph Junghans gentoo-dev 2013-03-24 17:29:22 UTC
(In reply to comment #19)
> Yeah, I suspect having libudev.so.0 and libudev.so.1 loaded in the same
> process is not a great idea.
> 
> libudev.so.0 is pulled in by chrome.
> libudev.so.1 is pulled in by some dependency of gtk.
> 
> If the libudev.so.0 -> libudev.so.1 symlink trick resolves this issue, I
> guess I can revert back to that.
> 
> Can someone try this:
> 
> rm /opt/google/chrome/libudev.so.0
> ln -s /usr/lib/libudev.so.1 /opt/google/chrome/libudev.so.0
Works for me.
Comment 25 Agostino Sarubbo gentoo-dev 2013-03-24 19:49:03 UTC
3.16.0.0 works for me with chromium
Comment 26 Dennis Schridde 2013-03-24 20:57:59 UTC
(In reply to comment #25)
> 3.16.0.0 works for me with chromium
Without the symlink hack?
Comment 27 Agostino Sarubbo gentoo-dev 2013-03-24 21:02:00 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > 3.16.0.0 works for me with chromium
> Without the symlink hack?

I never need of that. It always worked for me, see comment 6 and 9
Comment 28 Christoph Junghans gentoo-dev 2013-03-24 21:46:35 UTC
(In reply to comment #26)
> (In reply to comment #25)
> > 3.16.0.0 works for me with chromium
> Without the symlink hack?
chromium should be fine as it is linked against libudev.so.1, google-chrome has the libudev.so.0 problem.
Comment 29 Agostino Sarubbo gentoo-dev 2013-03-24 21:48:50 UTC
(In reply to comment #28)
> chromium should be fine as it is linked against libudev.so.1, google-chrome
> has the libudev.so.0 problem.

Yeah, but we are mixing 2 bugs, the first report says that does not work against chromium.
Comment 30 Christoph Junghans gentoo-dev 2013-03-24 21:57:24 UTC
(In reply to comment #29)
> (In reply to comment #28)
> > chromium should be fine as it is linked against libudev.so.1, google-chrome
> > has the libudev.so.0 problem.
> 
> Yeah, but we are mixing 2 bugs, the first report says that does not work
> against chromium.
@Stefano: does your issue under chromium persist with www-plugins/google-talkplugin-3.16.0.0 ?
Comment 31 Mike Gilbert gentoo-dev 2013-03-24 22:54:44 UTC
+  24 Mar 2013; Mike Gilbert <floppym@gentoo.org>
+  google-chrome-25.0.1364.172_p187217.ebuild,
+  google-chrome-26.0.1410.40_beta189199.ebuild,
+  google-chrome-27.0.1448.0_alpha189523.ebuild:
+  Revert back to the symlink trick for libudev; having libudev.so.0 and
+  libudev.so.1 loaded in the same process causes problems. Bug 458320.
Comment 32 Christoph Junghans gentoo-dev 2013-03-24 23:41:28 UTC
(In reply to comment #31)
> +  24 Mar 2013; Mike Gilbert <floppym@gentoo.org>
> +  google-chrome-25.0.1364.172_p187217.ebuild,
> +  google-chrome-26.0.1410.40_beta189199.ebuild,
> +  google-chrome-27.0.1448.0_alpha189523.ebuild:
> +  Revert back to the symlink trick for libudev; having libudev.so.0 and
> +  libudev.so.1 loaded in the same process causes problems. Bug 458320.
Thanks, that works for me.

@Stefano: any news from your side?
Comment 33 Markus Rathgeb 2013-03-25 07:31:36 UTC
I reinstalled (updated) google-chrome and the google-talkplugin.

emerge --keep-going -va google-chrome google-talkplugin

[ebuild     U  ] www-client/google-chrome-26.0.1410.40_beta189199:beta [26.0.1410.33_beta187744:beta] USE="plugins" LINGUAS="de -am -ar -bg -bn -ca -cs -da -el -en_GB -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 39,281 kB
[ebuild     U  ] www-plugins/google-talkplugin-3.16.0.0 [3.15.2.0] USE="libnotify -system-libCg" LINGUAS="de en -ar -bg -bn -ca -cs -da -el -es -et -fa -fi -fil -fr -gu -hi -hr -hu -id -is -it -ja -kn -ko -lt -lv -ml -mr -ms -nl -no -or -pl -ro -ru -sk -sl -sr -sv -ta -te -th -tl -tr -uk -ur -vi" VIDEO_CARDS="-fglrx -radeon" 10,917 kB


Then I started the TalkPlugin from the command line.

strace -f -o /tmp/talk-plugin.log /opt/google/talkplugin/GoogleTalkPlugin

If I start google-chrome the GoogleTalkPlugin raises a Segmentation fault.

Log file attached.
Comment 34 Markus Rathgeb 2013-03-25 07:32:14 UTC
Created attachment 343176 [details]
strace of google's talk plugin
Comment 35 Christoph Junghans gentoo-dev 2013-03-25 14:02:36 UTC
(In reply to comment #33)
> I reinstalled (updated) google-chrome and the google-talkplugin.
> 
> emerge --keep-going -va google-chrome google-talkplugin
Try to re-emerge google-chrome as libudev.so.0 is part of it.
Comment 36 Christoph Junghans gentoo-dev 2013-04-05 00:24:26 UTC
@Markus: does version 3.17.0.0 improve things?
Comment 37 Markus Rathgeb 2013-04-06 10:59:29 UTC
Installed versions:
www-client/google-chrome-27.0.1453.15_beta191758
www-plugins/google-talkplugin-3.17.0.0


Before I started google-chrome, I started the plugin with the gdb:

maggu2810@thor ~ $ gdb /opt/google/talkplugin/GoogleTalkPlugin
GNU gdb (Gentoo 7.5.1 p2) 7.5.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /opt/google/talkplugin/GoogleTalkPlugin...(no debugging symbols found)...done.
(gdb) run
Starting program: /opt/google/talkplugin/GoogleTalkPlugin 
warning: Could not load shared library symbols for linux-gate.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/libthread_db.so.1".
[New Thread 0xb3896b40 (LWP 9500)]
[New Thread 0xb3095b40 (LWP 9501)]
[New Thread 0xb2dffb40 (LWP 9502)]
[New Thread 0xb29a5b40 (LWP 9517)]
[Thread 0xb29a5b40 (LWP 9517) exited]
[New Thread 0xb29a5b40 (LWP 9518)]
[New Thread 0xb21a4b40 (LWP 9519)]
[New Thread 0xb19a3b40 (LWP 9520)]

Now I started google-chrome.

The plugin crashed, so back to the gdb session:

Program received signal SIGSEGV, Segmentation fault.
__strcmp_ia32 () at ../sysdeps/i386/i686/multiarch/../strcmp.S:38
38      ../sysdeps/i386/i686/multiarch/../strcmp.S: No such file or directory.
(gdb) bt
#0  __strcmp_ia32 () at ../sysdeps/i386/i686/multiarch/../strcmp.S:38
#1  0xb2f5d3de in udev_monitor_receive_device () from /usr/lib/libudev.so.0
#2  0x08152fb8 in ?? ()
#3  0x08061451 in ?? ()
#4  0x0805fdde in ?? ()
#5  0x0805e37d in ?? ()
#6  0x0805e3d8 in ?? ()
#7  0x080685d9 in ?? ()
#8  0x08084ef8 in ?? ()
#9  0x08053d6b in ?? ()
#10 0xb71e2d35 in __libc_start_main (main=0x1, argc=134560256, ubp_av=0x0, init=0x8053a21, fini=0x8053c92, rtld_fini=0x1, stack_end=0xbfffe364) at libc-start.c:258
#11 0xb7ffefc0 in _DYNAMIC () from /lib/ld-linux.so.2
#12 0x00000001 in ?? ()
#13 0x08053a00 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)
(gdb) info registers
eax            0x0      0
ecx            0x0      0
edx            0x91d6148        152920392
ebx            0xb2f5fff4       -1292501004
esp            0xbfffb65c       0xbfffb65c
ebp            0xbfffd718       0xbfffd718
esi            0x91d69b8        152922552
edi            0x91d6148        152920392
eip            0xb7246bd8       0xb7246bd8 <__strcmp_ia32+8>
eflags         0x10282  [ SF IF RF ]
cs             0x73     115
ss             0x7b     123
ds             0x7b     123
es             0x7b     123
fs             0x0      0
gs             0x33     51

Perhaps a NULL pointer on a strcmp?
Comment 38 Markus Rathgeb 2013-04-06 12:31:51 UTC
With a preloaded library, I get the following result:
#0  __strcmp_ia32 () at ../sysdeps/i386/i686/strcmp.S:38
#1  0xb7fd96ad in strcmp (s1=0x0, s2=0x91d6168 "video4linux") at strcmp-pl.c:21
#2  0xb2f5a3de in udev_monitor_receive_device () from /usr/lib/libudev.so.0

So, I tried to catch a NULL argument, but then a call to free hits a SEGFAULT.
Comment 39 Markus Rathgeb 2013-04-06 12:36:50 UTC
Sorry, now I realized that "/usr/lib/libudev.so.0" but libudev.so.1 should be used on my system.
I removed the old udev libraries and now it seems to be working.
Comment 40 Christoph Junghans gentoo-dev 2013-04-08 17:19:32 UTC
(In reply to comment #39)
> Sorry, now I realized that "/usr/lib/libudev.so.0" but libudev.so.1 should
> be used on my system.
> I removed the old udev libraries and now it seems to be working.
Great.
Comment 41 Samuli Suominen gentoo-dev 2014-05-22 11:27:44 UTC
*** Bug 511020 has been marked as a duplicate of this bug. ***