Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 458312 - x11-drivers/xf86-video-intel-2.21.2 random crash black screen and logout
Summary: x11-drivers/xf86-video-intel-2.21.2 random crash black screen and logout
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-19 16:20 UTC by Paul Littlefield
Modified: 2014-01-06 17:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
tarball of Xorg logs (Xorg_logs.tar.xz,14.65 KB, application/x-xz)
2013-02-25 10:30 UTC, Paul Littlefield
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Littlefield 2013-02-19 16:20:58 UTC
Hi Folks

First post, so be gentle.

After upgrading to the latest x11-drivers/xf86-video-intel-2.21.2 on either Xorg 1.12 or 1.13, I get a random logout back to the lightdm screen.

This happens as either root or standard user.

I have to revert back to x11-drivers/xf86-video-intel-2.20.19-r1.

Thanks

Paully



Portage 2.1.11.50 (default/linux/amd64/13.0/desktop, gcc-4.7.2, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-_i3_CPU_U_380_@_1.33GHz-with-gentoo-2.1
KiB Mem:     3841992 total,   2257548 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Mon, 18 Feb 2013 19:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.7.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo wirelay java-overlay amielke-overlay steam-overlay local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="/media/WD320GB/littlefield.uk.com/distfiles/ /media/WD500GB/littlefield.uk.com/distfiles/ /mnt/usbdrive/littlefield.uk.com/distfiles/ http://mirror.bytemark.co.uk/gentoo/ ftp://mirror.bytemark.co.uk/gentoo/ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/"
LANG="en_GB"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/wirelay /var/lib/layman/java-overlay /var/lib/layman/amielke-overlay /var/lib/layman/steam-overlay /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk gtk3 iconv ipv6 jack jbig jpeg lcms ldap mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio qt3support readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype type1 udev udisks unicode upower usb vaapi vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-02-19 16:27:56 UTC
Please attach Xorg.0.log from the crash (will be renamed to Xorg.0.log.old when the server restarts).

Also check if it happens both with uxa and sna.
Comment 2 Paul Littlefield 2013-02-19 16:36:30 UTC
OK, will do at the end of my working day :)
Comment 3 Paul Littlefield 2013-02-19 17:36:51 UTC
OK, this is right now before the changeover test.

I have sna USE flag enabled and it has been running fine all day, in fact has been fine for weeks.

thinkpad ~ # eix -I intel
[U] x11-drivers/xf86-video-intel
     Available versions:  ~*2.9.1 2.19.0 (~)2.20.2 2.20.13 (~)2.20.19-r1 (~)2.21.0 (~)2.21.2 {{debug dri glamor (+)sna +udev uxa xvmc}}
     Installed versions:  2.20.19-r1(10:11:36 19/02/13)(dri sna udev -glamor -uxa -xvmc)
     Homepage:            http://xorg.freedesktop.org/
     Description:         X.Org driver for Intel cards

I will now upgrade to 2.21.2 with 'sna' enabled and see if it borks...
Comment 4 Paul Littlefield 2013-02-24 20:19:20 UTC
My apologies for the delay... work and kids got in the way :)

OK, here are the results...

x11-drivers/xf86-video-intel-2.20.19-r1 +sna = OK :)
x11-drivers/xf86-video-intel-2.21.2 +sna = bork to login screen :(
x11-drivers/xf86-video-intel-2.21.3 +sna = bork to login screen :(
x11-drivers/xf86-video-intel-2.21.3 -sna +uxa = OK :)

I have looked in the .log file and nothing obvious is mentioned :(

So, for some reason, USE="sna" is fine in 2.20.19-r1 (and has been for weeks!) but not in the later releases.

I cannot really tell what performance benefit or hit I am getting with SNA so I am not really sure if I am missing anything.

I just compiled it in because I thought it was better, and has been really smooth for weeks.

I am now using 2.21.3 and will for this week to se how it behaves in "real use".

:)

I hope that this helps.

Regards

Paully
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-02-24 20:52:30 UTC
We still need to see Xorg.0.log from the crash. SNA is the future and UXA will go away sooner or later, so using UXA is only for isolating the issue and not a sustainable solution.

If you have the time, a full backtrace as described in http://wiki.x.org/wiki/Development/Documentation/ServerDebugging would be good.
Comment 6 Paul Littlefield 2013-02-25 09:46:19 UTC
OK, where do I upload the .log file? As an attachment or some online location?
Comment 7 Paul Littlefield 2013-02-25 09:48:44 UTC
Also, is it worth mentioning I am using the following?

Oh yes, and the problem still happened when using stable X server.



Portage 2.1.11.50 (default/linux/amd64/13.0/desktop, gcc-4.7.2, glibc-2.15-r3, 3.7.9-gentoo x86_64)

Gentoo Base System release 2.1

This is a pre-release version of the X server from The X.Org Foundation.
latest version in the X.Org Foundation git repository.

X.Org X Server 1.13.2.901 (1.13.3 RC 1)

xfce-base/xfdesktop-4.10.0

x11-drivers/xf86-video-intel-2.21.3

Paully
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-02-25 10:13:19 UTC
The Xorg.0.log is best attached to this bug. Compress it if it is too large for an attachment. You can post the backtrace in a comment.
Comment 9 Paul Littlefield 2013-02-25 10:30:10 UTC
Created attachment 340060 [details]
tarball of Xorg logs
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-02-25 10:34:40 UTC
[   436.163] (EE) Backtrace:
[   436.175] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x58a2a6]
[   436.176] (EE) 1: /usr/bin/X (0x400000+0x18dfb9) [0x58dfb9]
[   436.176] (EE) 2: /lib64/libpthread.so.0 (0x7fe7e31a3000+0x10ae0) [0x7fe7e31b3ae0]
[   436.176] (EE) 3: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fe7e0bc7000+0x98d58) [0x7fe7e0
c5fd58]
[   436.176] (EE) 4: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fe7e0bc7000+0x9d6dc) [0x7fe7e0c646dc]
[   436.176] (EE) 5: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fe7e0bc7000+0x66e16) [0x7fe7e0c2de16]
[   436.176] (EE) 6: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fe7e0bc7000+0x6762d) [0x7fe7e0c2e62d]
[   436.176] (EE) 7: /usr/lib64/xorg/modules/drivers/intel_drv.so (0x7fe7e0bc7000+0x729f9) [0x7fe7e0c399f9]
[   436.176] (EE) 8: /usr/bin/X (0x400000+0x10eb8b) [0x50eb8b]
[   436.176] (EE) 9: /usr/bin/X (0x400000+0x3b2d1) [0x43b2d1]
[   436.176] (EE) 10: /usr/bin/X (0x400000+0x29eda) [0x429eda]
[   436.176] (EE) 11: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7fe7e1e346c5]
[   436.176] (EE) 12: /usr/bin/X (0x400000+0x2a21d) [0x42a21d]
[   436.176] (EE) 
[   436.176] (EE) Bus error at address 0x7fe7dc657000
[   436.176] 
Fatal server error:
[   436.176] Caught signal 7 (Bus error). Server aborting

This crash is firmly in xf86-video-intel code so best report this upstream at https://bugs.freedesktop.org/ with the backtrace as per comment 5 and link the upstream report to this bug.
Comment 11 Paul Littlefield 2013-02-25 10:44:46 UTC
OK, I will try my best. I have briefly skimmed the BackTrace howto.

In a nutshell, do I need to recompile the Xorg ebuild with a flag and try it all again?

Eeek.
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-02-25 10:51:59 UTC
Yes, emerge xorg-server, xf86-video-intel with CFLAGS="-g" and FEATURES="splitdebug" and reproduce the crash with gdb attached (best via ssh session).
Comment 13 Paul Littlefield 2013-02-25 11:13:21 UTC
OK, will give it a go later tonight. Oh, I also have display compositing turned on in XFCE windows manager... not for the pointless effects nonsense, but for the REALLY smooth fonts it gives. Worth mentioning as well?
Comment 14 Martin Gysel (bearsh) 2013-04-03 19:33:16 UTC
It seems I have a very similar or the same issue :(

@paul did your open a upstream bug?
Comment 15 David Heidelberg (okias) 2014-01-02 20:10:21 UTC
Can you retest with 2.21.15 ?
Comment 16 Martin Gysel (bearsh) 2014-01-02 20:16:10 UTC
(In reply to David Heidelberger (okias) from comment #15)
> Can you retest with 2.21.15 ?

for me the issue seems to be gone long ago, just forgot the mention it here. I'm on ~arch, so using 2.99.x atm
Comment 17 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-01-06 17:28:58 UTC
Marking as fixed per comment #16. Reporter: if you still see this bug, please reopen.