Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458186 - =dev-util/ddd-3.3.12-r3 with ncurses[tinfo] - configure: error: Cannot find termcap compatible library.
Summary: =dev-util/ddd-3.3.12-r3 with ncurses[tinfo] - configure: error: Cannot find t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Maciej Mrozowski
URL:
Whiteboard:
Keywords: PATCH
: 621976 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-02-18 21:43 UTC by Scott McClung
Modified: 2017-06-19 00:51 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info '=dev-util/ddd-3.3.12-r3' (emerge-info,6.09 KB, text/plain)
2013-02-18 21:44 UTC, Scott McClung
Details
Build log for ddd-3.3.12-r3 (dev-util:ddd-3.3.12-r3:20130218-214148.log,13.37 KB, text/plain)
2013-02-18 21:49 UTC, Scott McClung
Details
ddd-3.3.12-tinfo.patch (ddd-3.3.12-tinfo.patch,330 bytes, patch)
2014-03-03 14:26 UTC, Jeroen Roovers
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Scott McClung 2013-02-18 21:43:37 UTC
=dev-util/ddd-3.3.12-r3 fails to compile with ncurses with the ncurses tinfo USE flag enabled.  Recently enabled tinfo flag for an unstable nvidia-cuda-toolkit, and the recent stabilize for dev-util/ddd uncovered this bug.   Removing nvidia-cuda-toolkit and reversing this change allows ddd to compile properly.


Reproducible: Always

Steps to Reproduce:
1. enable tinfo USE flag in /etc/portage/package.use/use:

sys-libs/ncurses tinfo

2. Emerge new ddd:

emerge =dev-util/ddd-3.3.12-r3

Actual Results:  
The build fails to find tgetent  in -lncurses and fails:

checking for tgetent in -lncurses... no
configure: error: Cannot find termcap compatible library.


Expected Results:  
Should compile if tinfo is enabled or not.

I believe this may need to be associated with the tracker at https://bugs.gentoo.org/show_bug.cgi?id=457530.

Attaching emerge --info and the build log.
Comment 1 Scott McClung 2013-02-18 21:44:29 UTC
Created attachment 339304 [details]
emerge --info '=dev-util/ddd-3.3.12-r3'
Comment 2 Scott McClung 2013-02-18 21:49:02 UTC
Created attachment 339306 [details]
Build log for ddd-3.3.12-r3
Comment 3 Jörn Valentin 2013-03-07 18:27:57 UTC
setting 
LDFLAGS="-Wl,-O1"
in make.conf to remove "-Wl,--as-needed" from LDFLAGS allows the package to build
Comment 4 Jeroen Roovers gentoo-dev 2014-03-03 14:26:55 UTC
Created attachment 371644 [details, diff]
ddd-3.3.12-tinfo.patch

cvs diff ddd-3.3.12-r3.ebuild 
Index: ddd-3.3.12-r3.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.12-r3.ebuild,v
retrieving revision 1.8
diff -u -B -r1.8 ddd-3.3.12-r3.ebuild
--- ddd-3.3.12-r3.ebuild        21 Feb 2013 16:12:26 -0000      1.8
+++ ddd-3.3.12-r3.ebuild        3 Mar 2014 14:26:37 -0000
@@ -42,6 +42,7 @@
        "${FILESDIR}/${P}-gcc44.patch"
        "${FILESDIR}/${P}-gdb-disassembler-bug.patch"
        "${FILESDIR}/${PN}-3.3.12-man.patch"
+       "${FILESDIR}/${PN}-3.3.12-tinfo.patch"
 )
 
 DOCS=(
@@ -54,7 +55,6 @@
 src_configure() {
        local myeconfargs=(
                --disable-static
-               --with-termlib=ncurses
                $(use_with readline)
        )
        autotools-utils_src_configure
Comment 5 Maciej Mrozowski gentoo-dev 2014-04-08 00:49:09 UTC
Fixed in -4. Thanks for the patch jer.
Comment 6 Maciej Mrozowski gentoo-dev 2017-06-19 00:51:35 UTC
*** Bug 621976 has been marked as a duplicate of this bug. ***