Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458128 - sci-electronics/ngspice-25 fails to build with ncurses[tinfo]
Summary: sci-electronics/ngspice-25 fails to build with ncurses[tinfo]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: The Soldering-Iron Brotherhood
URL:
Whiteboard:
Keywords:
: 520344 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-02-18 15:53 UTC by Jean-Francois Ostiguy
Modified: 2014-12-14 16:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,15.55 KB, text/plain)
2013-02-18 15:54 UTC, Jean-Francois Ostiguy
Details
config.log for ngspice-25 (config.log,157.57 KB, text/plain)
2013-02-22 16:41 UTC, Jean-Francois Ostiguy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Francois Ostiguy 2013-02-18 15:53:06 UTC
Checking for readline:
checking readline/readline.h usability... yes
checking readline/readline.h presence... yes
checking for readline/readline.h... yes
checking readline/history.h usability... yes
checking readline/history.h presence... yes
checking for readline/history.h... yes
checking for library containing tputs... no
configure: error: Found neither ncurses or termcap

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sci-electronics/ngspice-25/work/ngspice-25/config.log
 * ERROR: sci-electronics/ngspice-25 failed (configure phase):

=============================================================================





Reproducible: Always




emerge --info
Portage 2.1.11.52 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.2, glibc-2.16.0, 3.7.4-gentoo x86_64)
=================================================================
System uname: Linux-3.7.4-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.2
KiB Mem:     8099568 total,    734284 free
KiB Swap:   25173848 total,  24918528 free
Timestamp of tree: Mon, 18 Feb 2013 14:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            3.4.6-r2, 4.3.6-r1, 4.4.7, 4.5.4, 4.6.3, 4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo kde-sunset sunrise x-portage
ACCEPT_KEYWORDS="amd64 x86 ~amd64 ~x86"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="rsync://mirror.mcs.anl.gov/gentoo/ rsync://gentoo.chem.wisc.edu/gentoo/ rsync://rsync.gtlib.gatech.edu/gentoo rsync://distro.ibiblio.org/pub/linux/distributions/gentoo/ rsync://mirrors.rit.edu/gentoo/ ftp://mirror.iawnet.sandia.gov/pub/gentoo/ rsync://gentoo.cs.uni.edu/gentoo-distfiles"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude ChangeLog --delete-excluded"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde-sunset /var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus declarative dri dts dvd dvdr dvdread emboss encode exif fam fftw firefox flac fontconfig fortran gcj gdbm geant4 gif glut gpm gtk iconv icu ipv6 java jpeg kde kerberos kipi kpathsea lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib mysql ncurses nls nptl nptlonly nsplugin odbc ogg opengl openmp pam pango pcre pdf phonon php plasma png policykit postgres ppds pulse python qt3support qt4 readline sdl semantic-desktop session spell sql sqlite sse sse2 ssl startup-notification svg tcpd threads tiff truetype truetype-fonts type1 type1-fonts udev udisks unicode upower usb vhosts vorbis webkit wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" NETBEANS_MODULES="apisupport java websvccommon php profiler" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON
Comment 1 Jean-Francois Ostiguy 2013-02-18 15:54:00 UTC
Created attachment 339256 [details]
build.log
Comment 2 Denis Dupeyron gentoo-dev 2013-02-20 00:33:46 UTC
Thanks Jean-Francois. It's now fixed.

Denis.
Comment 3 Jean-Francois Ostiguy 2013-02-21 15:43:03 UTC
(In reply to comment #2)
> Thanks Jean-Francois. It's now fixed.
> 
> Denis.

Denis -

May be not. I am getting the same problem after resyncing this morning.
I also tried re-emerging ncurses (sys-libs/ncurses-5.9-r2:5). No luck.
Comment 4 Denis Dupeyron gentoo-dev 2013-02-22 15:50:16 UTC
OK, i'm reopening this but it's weird.

could you try with ngspice-24 and see if you have the same problem? Also, could you please attach the config.log after failure?

Thanks,
Denis.
Comment 5 Jean-Francois Ostiguy 2013-02-22 16:41:14 UTC
Created attachment 339720 [details]
config.log for ngspice-25

config.log for ngspice-25 is attached.

ngspice-24 configure also fails with the error

 checking for library containing tputs... no
configure: error: Found neither ncurses or termcap
Comment 6 Jean-Francois Ostiguy 2013-02-26 16:53:55 UTC
I looked into my issue a bit further. 

It may be related to recebt changes: 
See bug https://bugs.gentoo.org/show_bug.cgi?id=457530. 

When I look into configure.log I see

configure:17740: x86_64-pc-linux-gnu-gcc -o conftest -O2 -Wall -Wextra -Wmissing-prototypes -Wstrict-prototypes -Wnested-externs -Wold-style-definition -Wredundant-decls -Wconversion -march=native -O2 -pipe  -Wl,-O1 -Wl,--as-needed conftest.c -lm  >&5
conftest.c:140:1: warning: function declaration isn't a prototype [-Wstrict-prototypes]
conftest.c:142:1: warning: function declaration isn't a prototype [-Wstrict-prototypes]
conftest.c: In function 'main':
conftest.c:142:1: warning: old-style function definition [-Wold-style-definition]
/var/tmp/portage/sci-electronics/ngspice-25/temp/ccI6dnYL.o: In function `main':
conftest.c:(.text.startup+0x7): undefined reference to `tputs'
collect2: error: ld returned 1 exit status
configure:17740: $? = 1

Notice that on line 17740 the arguments should include -lncurses ... but it is not there. This explains why the tputs test fails for libncurses (it should not).

It turns out I also have installed on my system a package installed called sys-libs/libtermcap-compat. This package installs /usr/lib64/libtermcap.so.2.0.8 but apparently nothing under /usr/lib ( I think there should be a linker script there). This explains why the tputs test also fails for libtermcap.   

Finally, something else is weird. I had dev-util/nvidia-cuda-toolkit-5.0.35-r3
installed. I had to unmerge it in order get ncurses to emerge and install properly. Before that, ncurses would emerge but no file would get written under /usr/lib64. 

Bottom line: the situation with ncurses/termcap seems to be a bit of a mess at the moment.
Comment 7 Jean-Francois Ostiguy 2013-02-26 17:36:52 UTC
Two corrections to my previous comment.

The sys-libs/libtermcap-compat installs under /usr/lib64 which is obviously equivalent to /usr/lib on my multilib system. The issue is that only 
/usr/lib/libtermcap.so.2  and /usr/lib/libtermcap.so.2.0.8
are installed.

If I do  

  ln -s libtermcap.so.2 libtermcap

then the termcap configure test succeeds and ngspice-25 is successfully configured and compiled.

Now, as far as ncurses is concerned, the actual lib binairies are installed under /lib64. What gets installed under /usr/lib[64] is a linker script. Before unmerging the cuda package, emerging ncurses would never produce anything under /lib64 (not /usr/lib64 as implied by my previous comment). 

After unmerging the cuda package, reemerging ncurses resulted in a correct ncurses intallation. 

The fix for the ngspice ebuild would be to somehow get configure to work properly with ncurses i.e. get the -lncurses argument to be included in the configure library test.
Comment 8 Diego Elio Pettenò (RETIRED) gentoo-dev 2014-10-21 18:22:45 UTC
*** Bug 520344 has been marked as a duplicate of this bug. ***
Comment 9 Thomas Beierlein gentoo-dev 2014-12-14 16:53:22 UTC
Hopefully fixed. Please reopen if problem still exists.

+  14 Dec 2014; Thomas Beierlein <tomjbe@gentoo.org> ngspice-24.ebuild,
+  ngspice-25.ebuild, ngspice-26.ebuild:
+  Builds also with ncurses[tinfo] (bug #458128)
+