Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 458108 - virtual/ssh-askpass package that manages the /usr/lib/ssh-askpass link
Summary: virtual/ssh-askpass package that manages the /usr/lib/ssh-askpass link
Status: RESOLVED DUPLICATE of bug 457910
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-18 12:39 UTC by C.J. Wijtmans
Modified: 2013-02-21 15:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
virtual/ssh-askpass/ssh-askpass-0.ebuild (ssh-askpass-0.ebuild,682 bytes, text/plain)
2013-02-21 12:12 UTC, C.J. Wijtmans
Details
net-mics/eselect-ssh-askpass/eselect-ssh-askpass-0.ebuild (eselect-ssh-askpass-0.ebuild,727 bytes, text/plain)
2013-02-21 12:13 UTC, C.J. Wijtmans
Details
net-mics/eselect-ssh-askpass/files/ssh-askpass.eselect-0 (ssh-askpass.eselect-0,437 bytes, text/plain)
2013-02-21 12:13 UTC, C.J. Wijtmans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description C.J. Wijtmans 2013-02-18 12:39:36 UTC
We need a virtual/ssh-askpass package that manages the /usr/lib/misc/ssh-askpass  link. Packages that use ssh-askpass should then depend on virtual/ssh-askpass. The default ssh-askpass should be x11-ssh-askpass.

Some ssh-askpass packages are

ksshaskpass
x11-ssh-askpass
gtk2-ssh-askpass

etc.
Comment 2 C.J. Wijtmans 2013-02-18 13:01:23 UTC
related: https://bugs.gentoo.org/show_bug.cgi?id=457910
Comment 3 C.J. Wijtmans 2013-02-18 14:57:47 UTC
should probably be '/usr/lib/ssh-askpass' instead of '/usr/lib/misc/ssh-askpass'
Comment 4 Jeroen Roovers gentoo-dev 2013-02-19 09:29:18 UTC

*** This bug has been marked as a duplicate of bug 457910 ***
Comment 5 C.J. Wijtmans 2013-02-21 12:12:05 UTC
Created attachment 339554 [details]
virtual/ssh-askpass/ssh-askpass-0.ebuild
Comment 6 C.J. Wijtmans 2013-02-21 12:13:05 UTC
Created attachment 339556 [details]
net-mics/eselect-ssh-askpass/eselect-ssh-askpass-0.ebuild
Comment 7 C.J. Wijtmans 2013-02-21 12:13:45 UTC
Created attachment 339558 [details]
net-mics/eselect-ssh-askpass/files/ssh-askpass.eselect-0
Comment 8 C.J. Wijtmans 2013-02-21 12:29:46 UTC
okay i cant get eselect to work, i am confused as to how this is suposed to work
Comment 9 Jeroen Roovers gentoo-dev 2013-02-21 15:10:29 UTC
(In reply to comment #8)
> okay i cant get eselect to work, i am confused as to how this is suposed to
> work

Yes, you want to create two new packages to set RDEPEND in yet another package, even when neither of those block any others so you wouldn't need eselect, and even when setting

|| ( cat/alt1 cat/alt2 ) in the original package would suffice.

*** This bug has been marked as a duplicate of bug 457910 ***