Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457940 - net-misc/networkmanager should prioritise ethernet over wifi
Summary: net-misc/networkmanager should prioritise ethernet over wifi
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
: 471220 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-17 08:20 UTC by Matthew Stapleton
Modified: 2013-10-10 19:13 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Stapleton 2013-02-17 08:20:08 UTC
Network Manager doesn't use route metrics to prioritise certain connections such as ethernet over other connections such as wifi.  All connections use metric 0 for the default route which means sometimes low bandwidth connections can take priority over high bandwidth connections.  Ubuntu applies a metric value even to ethernet connections.

Reproducible: Always
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-18 15:59:18 UTC
This is a fairly significant feature request which would have to be implemented not by gentoo, but by networkmanager developers so that all distros can benefit from it. Please ask them directly at

https://bugzilla.gnome.org/enter_bug.cgi?product=NetworkManager

and explain what sort of behavior you would like to see (do you want a GUI for setting the route metric for a connection? or do you always want to give wireless a higher metric? under what conditions, with what exceptions?) and a specific use case where it would make a difference (e.g.: you have a machine connected to wifi, you plug in an ethernet cable, networkmanager creates an ethernet connection, but your traffic keeps going over wifi and not ethernet, leading to measurably worse performance: here are the logs showing that).

Then please add a comment here with the URL for the bugzilla.gnome.org bug you opened.
Comment 2 Matthew Stapleton 2013-02-27 23:58:11 UTC
I was thinking this: http://ubuntuforums.org/showthread.php?t=1499325 would be a good start, although I just checked the Debian and Fedora live cds and they don't appear to have this either, so I'll see if I can get the patch that Ubuntu uses.
Comment 3 Matthew Stapleton 2013-02-28 00:43:13 UTC
Actually it looks like Debian 6.0.3 uses different metrics as well, but only when both lan and wireless are connected.  My first test was on a virtual machine with a single network interface.
Comment 4 Matthew Stapleton 2013-02-28 03:02:39 UTC
Fedora Live DVD doesn't appear to use different metrics when both lan and wireless are connected.
Comment 5 Pavel Šimerda (pavlix) 2013-03-02 14:28:05 UTC
(In reply to comment #4)
> Fedora Live DVD doesn't appear to use different metrics when both lan and
> wireless are connected.

Afaik this is a bug. This sort of bug reports and/or feature requests is more suitable for the NM upstream bugzilla.
Comment 6 Pacho Ramos gentoo-dev 2013-06-16 12:07:14 UTC
*** Bug 471220 has been marked as a duplicate of this bug. ***
Comment 7 Pacho Ramos gentoo-dev 2013-10-10 19:13:03 UTC
I cannot reproduce this with >=0.9.6.4, upstream points to a problem with drivers instead. I think you should reply there (the bug is tagged as NEEDINFO now)