Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457934 - Add 'app-arch/unzip natspec' to profiles/targets/desktop/kde/package.use
Summary: Add 'app-arch/unzip natspec' to profiles/targets/desktop/kde/package.use
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL: https://bugs.kde.org/show_bug.cgi?id=...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-17 05:47 UTC by Wyatt Epp
Modified: 2013-04-23 10:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wyatt Epp 2013-02-17 05:47:13 UTC
While it doesn't necessarily decode filenames _correctly_, it's major step up from the current behaviour where KDE (really, Qt) applications are incabable of even _touching_ files with broken filename encodings.

Reproducible: Always




Background: Qt upstream considers files with invalid encodings in filenames to be "filesystem corruption" but has removed the "transition code" that dealt with it in the past.  This results in cases where applications will simply silently ignore files with names that are improperly encoded...at best. (Or it will give you warnings about the file not existing, like when you try to rename it.)

Upstream has stated that this is nearly impossible to fix in Qt4 and has further steadfastly refused to fix this in Qt5.  

I'm not sure if unzip upstream is still alive and working to improve filename encodings.
I haven't seen this issue with GTK et al.; as far as I can tell, it's unique to Qt.
Comment 1 Michael Palimaka (kensington) gentoo-dev 2013-02-26 08:48:55 UTC
I will add this to the agenda for the next KDE team meeting.

Do you have any links to Qt upstream stuff? Maybe it will be of some interest to Qt team.
Comment 2 Wyatt Epp 2013-02-26 10:13:50 UTC
(In reply to comment #1)
> I will add this to the agenda for the next KDE team meeting.
> 
> Do you have any links to Qt upstream stuff? Maybe it will be of some
> interest to Qt team.

Yeah, this is first covered in a post on kde-core-devel outlining the limitations involved in Qt4:
http://lists.kde.org/?l=kde-core-devel&m=122025063320264&w=2 

Also, the comment thread on Thiago's blog is...enlightening (and painfully shortsighted).  (i.e. Someone from usability needs to smack him.)  This is relevant because he's the one writing it.
http://www.macieira.org/blog/2011/09/qurl-in-qt-5-encoding/
Comment 3 Davide Pesavento gentoo-dev 2013-02-27 23:06:52 UTC
Is there anything we (qt) can do here?
Comment 4 Michael Palimaka (kensington) gentoo-dev 2013-02-28 14:07:24 UTC
(In reply to comment #3)
> Is there anything we (qt) can do here?

I'm not sure, I CCed because it appears to technically be a Qt bug, but primarily in case someone had further insight into the issue.

No problem to unCC if it's not worth tracking from a Qt point of view.
Comment 5 Davide Pesavento gentoo-dev 2013-03-01 05:43:12 UTC
(In reply to comment #4)

Well, apparently this is not something Qt upstream can/is willing to fix, therefore can be considered CANTFIX from our point of view.
Comment 6 Andreas K. Hüttel gentoo-dev 2013-03-22 22:53:52 UTC
Done as per meeting decision.