Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457810 - sys-fs/aufs3-3_p20130207 with USE="inotify" and sys-kernel/hardened-sources-3.7.5 doesn't compile - aufs3-standalone/fs/aufs/branch.h:84:2: error: unknown type name ‘fsnotify_ops_no_const’
Summary: sys-fs/aufs3-3_p20130207 with USE="inotify" and sys-kernel/hardened-sources-3...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Justin Lecher
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-16 09:55 UTC by Florian Steinel
Modified: 2013-06-24 21:21 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,4.92 KB, text/plain)
2013-02-16 10:29 UTC, Florian Steinel
Details
pax-2 patch for >linux-3.7.0 (pax-2_kernel-3.7.patch,2.22 KB, patch)
2013-02-21 15:11 UTC, Kolan Sh.
Details | Diff
Using pax-2.patch or pax-2_kernel-3.7.patch depending on kernel version. (aufs3-3_p20130207-r1.ebuild,5.05 KB, application/octet-stream)
2013-02-21 15:13 UTC, Kolan Sh.
Details
pax-2_kernel-3.7.patch (pax-2_kernel-3.7.patch,2.22 KB, patch)
2013-02-21 15:14 UTC, Kolan Sh.
Details | Diff
aufs3-3_p20130207-r1.ebuild (aufs3-3_p20130207-r1.ebuild,5.05 KB, application/octet-stream)
2013-02-21 15:15 UTC, Kolan Sh.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Steinel 2013-02-16 09:55:21 UTC
sys-fs/aufs3-3_p20130207: compile error:
 * aufs3-3_p20130207.tar.xz SHA256 SHA512 WHIRLPOOL size ;-) ...         [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.7.5-hardened/build
 * Found sources for kernel version:
 *     3.7.5-hardened
 * Checking for suitable kernel configuration options...                 [ ok ]
>>> Unpacking aufs3-3_p20130207.tar.xz to /var/tmp/portage/sys-fs/aufs3-3_p20130207/temp
>>> Unpacking source...
>>> Unpacking aufs3-3_p20130207.tar.xz to /var/tmp/portage/sys-fs/aufs3-3_p20130207/work
>>> Source unpacked in /var/tmp/portage/sys-fs/aufs3-3_p20130207/work
>>> Preparing source in /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone ...
 * Using for module creation branch origin/aufs3.7
 * Applying pax-2.patch ...                                              [ ok ]
 * Using for utils building branch origin/aufs3.0
Branch local-gentoo set up to track remote branch aufs3.0 from origin.
Switched to a new branch 'local-gentoo'
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone ...
make -j2 CC=x86_64-pc-linux-gnu-gcc LD=x86_64-pc-linux-gnu-ld 'LDFLAGS=-O1 --as-needed' ARCH=x86 CONFIG_AUFS_FS=m KDIR=/lib/modules/3.7.5-hardened/build
-I/var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/include -DCONFIG_AUFS_FS_MODULE -UCONFIG_AUFS -DCONFIG_AUFS_BRANCH_MAX_127 -DCONFIG_AUFS_HNOTIFY -DCONFIG_AUFS_HFSNOTIFY -DCONFIG_AUFS_SBILIST -DCONFIG_AUFS_RDU
make -C /lib/modules/3.7.5-hardened/build M=/var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs EXTRA_CFLAGS="-I/var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/include -DCONFIG_AUFS_FS_MODULE -UCONFIG_AUFS -DCONFIG_AUFS_BRANCH_MAX_127 -DCONFIG_AUFS_HNOTIFY -DCONFIG_AUFS_HFSNOTIFY -DCONFIG_AUFS_SBILIST -DCONFIG_AUFS_RDU" modules
make[1]: Entering directory `/usr/src/linux-3.7.5-hardened'
  CC [M]  /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/module.o
  CC [M]  /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/sbinfo.o
In file included from /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/aufs.h:38:0,
                 from /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/module.c:25:
/var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/branch.h:84:2: error: unknown type name ‘fsnotify_ops_no_const’
In file included from /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/aufs.h:38:0,
                 from /var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/sbinfo.c:23:
/var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/branch.h:84:2: error: unknown type name ‘fsnotify_ops_no_const’
make[2]: *** [/var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/module.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [/var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs/sbinfo.o] Error 1
make[1]: *** [_module_/var/tmp/portage/sys-fs/aufs3-3_p20130207/work/aufs3-3_p20130207/aufs3-standalone/fs/aufs] Error 2
make[1]: Leaving directory `/usr/src/linux-3.7.5-hardened'
make: *** [fs/aufs/aufs.ko] Error 2


Reproducible: Always
Comment 1 Florian Steinel 2013-02-16 10:26:58 UTC
Portage 2.1.11.50 (hardened/linux/amd64/no-multilib/selinux, gcc-4.6.3, glibc-2.15-r3, 3.7.5-hardened x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.7.5-hardened-x86_64-Intel-R-_Core-TM-_i5-2400_CPU_@_3.10GHz-with-gentoo-2.1
KiB Mem:     1018328 total,    575060 free
KiB Swap:     112636 total,    112636 free
Timestamp of tree: Fri, 15 Feb 2013 17:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox selinux sesandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS=""
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync/gentoo-portage"
USE="amd64 berkdb bzip2 caps cli cracklib crypt cxx dri gdbm gnutls gpm hardened iconv ipv6 justify logrotate mmx modules mudflap ncurses nls nptl open_perms openmp pam pax_kernel pcre readline selinux session sse sse2 ssl tcpd unicode urandom utf8 vmware_guest_linux xattr zlib" ABI_X86="64" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="gnutls" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US de de_DE" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vmware vesa vga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-fs/aufs3-3_p20130207 was built with the following:
USE="inotify kernel-patch pax_kernel -debug -doc -fuse -hfs -nfs -ramfs"
Comment 2 Florian Steinel 2013-02-16 10:29:06 UTC
Created attachment 339036 [details]
build.log
Comment 3 Justin Lecher gentoo-dev 2013-02-17 09:10:21 UTC
Could you guys help here? I don't use any hardened envs.
Comment 4 Kolan Sh. 2013-02-21 15:11:59 UTC
Created attachment 339594 [details, diff]
pax-2 patch for >linux-3.7.0
Comment 5 Kolan Sh. 2013-02-21 15:13:20 UTC
Created attachment 339596 [details]
Using pax-2.patch or pax-2_kernel-3.7.patch depending on kernel version.

Using pax-2.patch or pax-2_kernel-3.7.patch depending on kernel version.
Comment 6 Kolan Sh. 2013-02-21 15:14:41 UTC
Created attachment 339598 [details, diff]
pax-2_kernel-3.7.patch
Comment 7 Kolan Sh. 2013-02-21 15:15:10 UTC
Created attachment 339600 [details]
aufs3-3_p20130207-r1.ebuild

Using pax-2.patch or pax-2_kernel-3.7.patch depending on kernel version.
Comment 8 Nils Stöckmann 2013-05-27 18:26:29 UTC
I realize the problematic part of pax-2.patch is no longer present in the currently availible ebuilds.

As of the day before yesterday Justin removed the multitude of patches in the files directory, leaving a new pax-3.patch.

The new pax-3.patch does no longer contain the problematic part of pax-2.patch:


$ diff pax-2.patch pax-2_kernel-3.7.patch 
75,85d74
< --- a/fs/aufs/branch.h	2012-10-09 15:41:32.652989534 -0400
< +++ b/fs/aufs/branch.h	2012-10-09 15:41:58.562989820 -0400
< @@ -81,7 +81,7 @@
<  
<  #ifdef CONFIG_AUFS_HFSNOTIFY
<  	struct fsnotify_group	*br_hfsn_group;
< -	struct fsnotify_ops	br_hfsn_ops;
< +	fsnotify_ops_no_const	br_hfsn_ops;
<  #endif
<  
<  #ifdef CONFIG_SYSFS


So, maybe the problem is fixed in current versions, at least it looks good for now.

I need to do some "real world" work, can't test if it works at the moment, but now you know some progress happened and can take a test yourself.
Comment 9 Anthony Basile gentoo-dev 2013-06-24 21:21:13 UTC
(In reply to Nils Stöckmann from comment #8)

> 
> So, maybe the problem is fixed in current versions, at least it looks good
> for now.
> 
> I need to do some "real world" work, can't test if it works at the moment,
> but now you know some progress happened and can take a test yourself.



I just marked 2.6.32-r170, 3.2.46-r1, 3.9.5 stable..  Please test and if this is still an issue reopen.