Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457726 - app-portage/layman-2.0.0 - buggy quiet mode
Summary: app-portage/layman-2.0.0 - buggy quiet mode
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Third-Party Tools (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords:
: 564670 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-15 16:56 UTC by consus
Modified: 2015-11-02 15:52 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fix buggy quiet mode (cli.py.patch,4.76 KB, patch)
2013-05-14 22:53 UTC, Dmitry Selyutin
Details | Diff
Adds quietness level to output.notice() function. (layman-add-quiet.patch,3.46 KB, patch)
2014-03-20 16:19 UTC, Devan Franchini (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description consus 2013-02-15 16:56:10 UTC
layman prints newlines while in quiet mode.

Example:

1. quiet

~~~~
# /usr/bin/layman --sync=ALL -q



~~~~

2. normal

~~~~
# /usr/bin/layman --sync=ALL

 * Fetching remote list,...
 * Remote list already up to date: http://www.gentoo.org/proj/en/overlays/repositories.xml
 * Last-modified: Tue, 12 Feb 2013 23:00:02 GMT
 * Fetch Ok

 * Syncing selected overlays,...
 * Running Git... # ( cd /var/lib/layman/barnowl  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/lobotomy  && /usr/bin/git pull )
Already up-to-date.
 * Running Git... # ( cd /var/lib/layman/udev  && /usr/bin/git pull )
Already up-to-date.
 * 
 * Succeeded:
 * ------
 * Successfully synchronized overlay "barnowl".
 * Successfully synchronized overlay "lobotomy".
 * Successfully synchronized overlay "udev".
 * 

~~~~
Comment 1 Dmitry Selyutin 2013-05-14 22:53:04 UTC
Created attachment 348354 [details, diff]
Fix buggy quiet mode

Don't print blank lines if "quiet" flag is enabled.
Comment 2 Devan Franchini (RETIRED) gentoo-dev 2014-03-20 16:19:37 UTC
Created attachment 373116 [details, diff]
Adds quietness level to output.notice() function.

This patch fixes the lack of quietness checking in the output.notice() function which will resolve the ignored output when the -q flag is enabled.
Comment 3 Devan Franchini (RETIRED) gentoo-dev 2014-07-09 23:14:02 UTC
Is resolved in the latest 9999 and will be resolved in the next release.
Comment 4 Brian Dolbec gentoo-dev 2015-11-02 15:52:12 UTC
*** Bug 564670 has been marked as a duplicate of this bug. ***