Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457624 - gnome-extra/gnome-system-monitor-3.6.1 has incorrect dependency on dev-cpp/glibmm
Summary: gnome-extra/gnome-system-monitor-3.6.1 has incorrect dependency on dev-cpp/gl...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2013-02-14 21:51 UTC by Aaron Griffith
Modified: 2013-09-13 23:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
my emerge --info (emerge.info,16.47 KB, text/plain)
2013-02-14 21:52 UTC, Aaron Griffith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Griffith 2013-02-14 21:51:47 UTC
Compiling gnome-extra/gnome-system-monitor-3.6.1 failed on my machine with errors related to not finding certain symbols in the GIO bindings provided by glibmm. I wish I could be more specific about the exact symbols, but I didn't really expect my eventual fix to work and I lost the log output.

I fixed this by updating glibmm to the latest version available to me (2.34.1), and that fixed these errors. The ebuild for gnome-system-monitor-3.6.1 lists ">=dev-cpp/glibmm-2.27:2" as a dependency, so the true dependency must be somewhere between 2.27 and 2.34.1.

Reproducible: Always

Steps to Reproduce:
1. Attempt to emerge gnome-extra/gnome-system-monitor-3.6.1 with glibmm-2.27

Actual Results:  
Compilation fails (pretty quickly) about unknown symbols in the GIO namespace.

Expected Results:  
Compilation succeeds.
Comment 1 Aaron Griffith 2013-02-14 21:52:35 UTC
Created attachment 338904 [details]
my emerge --info
Comment 2 Pacho Ramos gentoo-dev 2013-08-29 12:45:54 UTC
Do you have the error? It would let us search for unknown symbol and try to find the version including that
Comment 3 Aaron Griffith 2013-08-29 15:03:02 UTC
If I ever did, I lost it months ago, and unfortunately I'm not really in a position to either downgrade my installed glibmm (and risk losing my desktop) or install a new gnome system from scratch. I know this is pretty stereotypical bad bug reporter behavior, so I apologize in advance.

For whatever it's worth (probably not much), ubuntu lists glibmm 2.33.13 and glib 2.28.0 as dependencies for this package+version combo.
Comment 4 Gilles Dartiguelongue gentoo-dev 2013-09-13 23:02:04 UTC
+  14 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org>
+  gnome-system-monitor-3.6.1.ebuild, gnome-system-monitor-3.8.2.1.ebuild,
+  gnome-system-monitor-3.8.2.1-r1.ebuild:
+  Raise glibmm dependency per bug #457624.
+

I couldn't downgrade my system to a configuration that would fail like it did for you and in the absence of a build.log it is hard to figure out what exactly was missing.

Anyway, since glibmm-2.34 appears to have fixed the issue for you and since it keyword level matches gnome-system-monitor just fine, I raised the glibmm dependency to that version.

Thanks for reporting and please provide a build.log next time. :)