Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457570 - app-shells/zsh fails to compile with ncurses[tinfo]
Summary: app-shells/zsh fails to compile with ncurses[tinfo]
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Tim Harder
URL:
Whiteboard:
Keywords:
: 461636 (view as bug list)
Depends on:
Blocks: tinfo
  Show dependency tree
 
Reported: 2013-02-14 18:43 UTC by Frederik Klama
Modified: 2014-01-08 02:12 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to support tinfo with explicit USE flag (zsh-5.0.4-tinfo.patch,1.56 KB, patch)
2013-12-24 03:27 UTC, Marcus Spading
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frederik Klama 2013-02-14 18:43:12 UTC
Probably related to Bug 457530

zsh will not compile since configure can not find the function tgetent and assumes there is no curses library.
I 'fixed' this by setting 'LDCONFIG=""' in 'make.conf'.
Comment 1 Tim Harder gentoo-dev 2013-03-13 16:43:19 UTC

*** This bug has been marked as a duplicate of bug 461636 ***
Comment 2 Tim Harder gentoo-dev 2013-03-13 16:45:08 UTC
*** Bug 461636 has been marked as a duplicate of this bug. ***
Comment 3 David Mohr 2013-06-13 16:44:37 UTC
I hacked the ebuild to include -ltinfo if USE=tinfo is present (I believe that it has to be globally enabled, and not just for ncurses). If someone is interested: http://digamma.cs.unm.edu/~dmohr/zsh-5.0.2-r1.ebuild
Comment 4 Nicolas Martyanoff 2013-11-03 20:23:26 UTC
This bug is still here with app-shells/zsh-5.0.2-r3.

Is there something missing for the bug to be fixed ?
Comment 5 Tim Harder gentoo-dev 2013-12-20 04:43:45 UTC
(In reply to Nicolas Martyanoff from comment #4)
> This bug is still here with app-shells/zsh-5.0.2-r3.
> 
> Is there something missing for the bug to be fixed ?

A patch against the build system that will be accepted upstream.
Comment 6 Marcus Spading 2013-12-24 03:25:52 UTC
(In reply to Tim Harder from comment #5)
> A patch against the build system that will be accepted upstream.

Actually I'm not sure this true. It builds fine if you don't explicitly set
'--with-term-lib="ncursesw ncurses"' (line 79 in the 5.0.4 ebuld). Without
it the build system picks up the right library and adds the necessary flags.

So the solution is to either delete this line or add a patch similar to the one I attached.
Comment 7 Marcus Spading 2013-12-24 03:27:01 UTC
Created attachment 366058 [details, diff]
patch to support tinfo with explicit USE flag
Comment 8 JTRiley 2014-01-07 16:44:07 UTC
(In reply to Marcus Spading from comment #6)
> (In reply to Tim Harder from comment #5)
> > A patch against the build system that will be accepted upstream.
> 
> Actually I'm not sure this true. It builds fine if you don't explicitly set
> '--with-term-lib="ncursesw ncurses"' (line 79 in the 5.0.4 ebuld). Without
> it the build system picks up the right library and adds the necessary flags.
> 
> So the solution is to either delete this line or add a patch similar to the
> one I attached.

Agreed. The ebuild is failing to pass the correct value for --with-term-lib in all situations. IMHO its better to let the build system pick up the proper values unless there's a use case that requires explicitly setting them.
Comment 9 Tim Harder gentoo-dev 2014-01-08 02:12:39 UTC
Fixed in 5.0.5 by dropping the explicit setting.