Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457552 - media-sound/mumble should not include TTS settings when USE="-speech"
Summary: media-sound/mumble should not include TTS settings when USE="-speech"
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL: http://sourceforge.net/p/mumble/bugs/...
Whiteboard: tracking upstream
Keywords: UPSTREAM
Depends on:
Blocks:
 
Reported: 2013-02-14 15:35 UTC by Michael Mol
Modified: 2019-04-20 19:22 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Screenshot of the settings window with the offending settings shown. (mumbletts.png,61.30 KB, image/png)
2013-02-14 15:35 UTC, Michael Mol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Mol 2013-02-14 15:35:09 UTC
Created attachment 338882 [details]
Screenshot of the settings window with the offending settings shown.

When mumble is emerged with USE="-speech", TTS settings are still shown under Configure->Settings->Notifications. This can be *very* confusing when one is trying to get TTS to work by tweaking settings there. (I didn't notice the 'speech' USE flag for a couple days.)

The ideal solution would be to have TTS settings visible, but grayed out. This would indicate that TTS is possible, but disabled or unavailable somehow. That would be far better than tweaking the settings and still hearing absolutely nothing...
Comment 1 Timo Gurr (RETIRED) gentoo-dev 2013-02-14 16:03:37 UTC
Thanks for your report. This is probably something you might want to report upstream. We already pass no-speechd if USE="-speech" is requested, so there's nothing we can do about this packaging wise. Feel free to link the upstream bug here so we can keep track of the upstream progress.
Comment 2 Michael Mol 2013-02-14 16:05:07 UTC
I was honestly hoping the gentoo maintainer for the package would marshal communications with upstream, if necessary. :)

Point me at the appropriate upstream bugtracker, and I'll be on my way.
Comment 3 Timo Gurr (RETIRED) gentoo-dev 2013-02-14 16:07:56 UTC
Thanks for taking care of the issue. The upstream bugtracker can be found at sourceforge:
http://sourceforge.net/p/mumble/_list/tickets
Comment 4 Michael Mol 2013-02-17 00:37:19 UTC
https://sourceforge.net/p/mumble/bugs/961/