Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457430 - kde-base/kde...-4.10.0: KDE (un-)lock dialog stays on screen after unlocking
Summary: kde-base/kde...-4.10.0: KDE (un-)lock dialog stays on screen after unlocking
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-14 07:39 UTC by Joe Breuer
Modified: 2013-11-04 12:59 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Screenshot showing the problem (LockRemains.jpg,204.99 KB, image/jpeg)
2013-02-14 07:43 UTC, Joe Breuer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Breuer 2013-02-14 07:39:25 UTC
When unlocking the KDE screen locker, the unlock/password entry dialog will sometimes remain on-screen.

Reproducible: Sometimes

Steps to Reproduce:
1. Lock or suspend the computer
2. Wake the computer / wake the screensaver by e.g. tapping left Ctrl
3. Wait for the "enter password to unlock" dialog
3. Enter password to unlock

Actual Results:  
Screen unlocks (i.e. I can interact with the programs shown), SOMETIMES (about 30% of the time for me) the unlock dialog stays on-screen, on top of the normal desktop contents. I'll try to attach a screenshot.

This dialog is "sticky" on all virtual desktops.

xwininfo and xkill do not see the dialog window; i.e. they react as if I picked the window underneath the dialog.

The 'kscreenlocker' process is not running while the "hung" dialog is on screen.


Expected Results:  
Screen unlocks, the password entry dialog goes away.

I'm seeing this with (subjectively) increasing frequency for about 10-12 weeks now. So, I'd guess (at least) KDE 4.9.3 (installed December 2012) and 4.9.5 (current) are be affected.

In case this is related: I'm running nvidia-drivers 304.64, on a GeForce GTX 580.

I do not have a fancy screensaver configured, just black screen + DPMS.


I've classified this as "major" since there's no way I've found to get rid of the dialog covering up a part of the screen without logging out.
[This obviously has the potential for serious penalty depending on what programs are open etc.; i.e. a long-running compile (without screen/tmux) would be SOL.]


# emerge --info
Portage 2.1.11.50 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_970_@_3.20GHz-with-gentoo-2.1
KiB Mem:    12300556 total,   6751476 free
KiB Swap:   16777212 total,  16777212 free
Timestamp of tree: Mon, 11 Feb 2013 07:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo LOCAL jmbreuer
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -mtune=corei7 -O2 -pipe -momit-leaf-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /usr/share/X11/xkb"
CXXFLAGS="-march=corei7 -mtune=corei7 -O2 -pipe -momit-leaf-frame-pointer"
DISTDIR="/storage/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y --jobs=64 --load-average=16"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg collision-protect config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://de-mirror.org/distro/gentoo/ http://gentoo.mneisen.org/ http://gentoo.wheel.sk/ http://gentoo.mirror.pw.edu.pl/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="--jobs=64 --load-average=18"
PKGDIR="/storage/portage/packages/x64cd"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/jmbreuer"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr chardet cjk cli consolekit cracklib crypt css cups curl cxx dbus declarative dga dri dts dv dvd dvdr embedded emboss encode exif fam fame fastcgi ffmpeg firefox flac flash fluidsynth fontconfig foomaticdb fortran gcj gd gdbm gif gimp glitz glut gnutls gphoto2 gpm gstreamer gtk iconv icu ieee1394 imap imlib innodb iphone ipod ipv6 java jce jpeg kde kerberos kipi kpathsea lame lastfm lcms ldap leim libgda libnotify libsamplerate lm_sensors lzo mad mbox mikmod mjpeg mmx mmxext mng modplug modules mono mp3 mp4 mpeg mtp mudflap mule multilib ncurses network network-cron nis nls nptl nsplugin nspluginwrapper nvidia offensive ogg openexr opengl openmp pam pango pcap pcre pda pdf phonon plasma plotutils png policykit ppds qt3support qt4 rdesktop readline rtc samba sasl scanner sdk sdl semantic-desktop session shout slang slp smp sndfile socks5 sound sox spell sqlite sse sse2 ssl ssse3 startup-notification subversion svg tcpd theora threads tiff tk truetype trusted udev udisks unicode upower usb vdpau vim-syntax vnc vorbis webdav wma wmf wxwidgets x264 xanim xcb xcomposite xiph xml xscreensaver xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse wacom evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="net" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Joe Breuer 2013-02-14 07:43:12 UTC
Created attachment 338838 [details]
Screenshot showing the problem
Comment 2 Joe Breuer 2013-02-14 12:13:16 UTC
As this is not totally clear from the original report:

I ALWAYS unlock by (quickly) typing the password immediately followed by <Return>.

I never enter the password and then click on the "Unlock" button in the dialog.
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2013-02-17 22:42:33 UTC
Have observed this too.
Comment 4 Myk Taylor 2013-05-25 03:07:51 UTC
I have seen this too, but not recently (e.g. since updating to kde-4.10.1)
Comment 5 Johannes Huber gentoo-dev 2013-09-20 13:31:18 UTC
Is this reproducible with current stable (4.10.5) or testing version (4.11.1)?
Comment 6 Johannes Huber gentoo-dev 2013-11-04 12:59:58 UTC
(In reply to Johannes Huber from comment #5)
> Is this reproducible with current stable (4.10.5) or testing version
> (4.11.1)?

No answer since over a month, closing then.