Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 457166 - media-fonts/terminus-font unusable in kde-base/konsole-4.9.5 because Qt-4.8.4 renders terminus bitmap-font incorrectly by selecting some non ASCII characters from a different font
Summary: media-fonts/terminus-font unusable in kde-base/konsole-4.9.5 because Qt-4.8.4...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-13 23:23 UTC by Matthias Maier
Modified: 2013-11-24 02:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
screenshot depicting the font problem (qt-font-problem.jpg,49.36 KB, image/jpeg)
2013-02-13 23:24 UTC, Matthias Maier
Details
emerge --info (emerge.info,5.48 KB, text/plain)
2013-02-13 23:26 UTC, Matthias Maier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Maier gentoo-dev 2013-02-13 23:23:33 UTC
QT-4.8.4 (and previous versions) renders bitmap-fonts, e.g. terminus, incorrectly by selecting some non ASCII characters from a different font.

See attached screenshot, where on the left terminus 24pt is rendered with Qt and on the right with gtk. Some non ASCII characters are clearly 

With smaller font sizes (~12pt) the replacement characters have significantly different width and height which messes up the ouptput e.g. in konsole completely (where a fixed size font is assumed to actually be a fixed size font...)

Reproducible: Always
Comment 1 Matthias Maier gentoo-dev 2013-02-13 23:24:58 UTC
Created attachment 338810 [details]
screenshot depicting the font problem
Comment 2 Matthias Maier gentoo-dev 2013-02-13 23:26:06 UTC
Created attachment 338812 [details]
emerge --info
Comment 3 Rafał Mużyło 2013-02-13 23:40:12 UTC
Just a guess, but most likely the fonts, you're testing (i.e. terminus) simply don't have the required characters.
This would mean it's a matter of font matching and that's and extremely tricky business - gtk+ does it with pango, qt has its own method. The results don't need to match - probably they rarely do.
Comment 4 Matthias Maier gentoo-dev 2013-03-05 10:10:22 UTC
(In reply to comment #3)

Sorry for the long delay..

> Just a guess, but most likely the fonts, you're testing (i.e. terminus)
> simply don't have the required characters.
> This would mean it's a matter of font matching and that's and extremely
> tricky business - gtk+ does it with pango, qt has its own method. The
> results don't need to match - probably they rarely do.

It seems that some native UTF-8 characters are missing, but there are corresponding characters in ISO-8859-x sets provided by terminus. Pango seems to pick up those, qt doesn't do that and chooses a different font.

So the question remains, why pango does a considerably better job there.
Comment 5 Johannes Huber gentoo-dev 2013-05-01 17:51:10 UTC
Re-Assigning to Qt, i guess kde cant to anything here.
Comment 6 Davide Pesavento gentoo-dev 2013-05-01 18:36:08 UTC
is this related https://bugreports.qt-project.org/browse/QTBUG-22599 ?
Comment 7 Maciej Mrozowski gentoo-dev 2013-05-06 00:12:33 UTC
@Matthias, please check whether setting LANG variable (as in Qt bug provided by pesa) fixes the problem for you (it did for me anyway).
Comment 8 Matthias Maier gentoo-dev 2013-05-06 22:18:29 UTC
Setting LANG=en_GB.UTF-8 or LANG=de_DE.UTF-8, as well as, LC_ALL=en_GB.UTF-8 or LC_ALL=de_DE.UTF-8 does not change character selection for me at all.

I tried so by setting up the locale globally (via /etc/env.d && env-update && fresh graphical login) and disabled all user specific locale settings.
Comment 9 Davide Pesavento gentoo-dev 2013-08-15 08:59:16 UTC
can you try with Qt 4.8.5 please?
Comment 10 Johannes Huber gentoo-dev 2013-11-23 19:09:45 UTC
(In reply to Davide Pesavento from comment #9)
> can you try with Qt 4.8.5 please?

@Pesa as the reporter does not respond, feel free to close it. I cant reproduce it.