Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456980 - app-office/libreoffice-4.0.0.3 - inserting movie or sound in impress fails with "The format of the selected file is not supported"
Summary: app-office/libreoffice-4.0.0.3 - inserting movie or sound in impress fails wi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
: 482018 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-12 18:37 UTC by Vladimir
Modified: 2014-03-06 00:34 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
A sample presentation for testing (04-Sun-Activity.odp,740.86 KB, application/octet-stream)
2013-03-19 15:22 UTC, Vladimir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2013-02-12 18:37:13 UTC
I am trying to add a small video file to my LO-4.0.0.3 Impress presentation, but it fails every time with this error message: "The format of the selected file is not supported".

  I tried to install media-plugins/gst-plugins-libav instead of the ffmpeg that I had before that, but it did not help.

There is some short discussion of this problem here: http://forums.gentoo.org/viewtopic-t-870175-start-75-postdays-0-postorder-asc-highlight-libreoffice+libav.html

Reproducible: Always
Comment 1 Vladimir 2013-03-08 07:20:29 UTC
The same problem after upgrading to LibreOffice-4.0.1.2
Comment 2 Vladimir 2013-03-19 15:22:30 UTC
Created attachment 342650 [details]
A sample presentation for testing

This is a sample presentation which contains a small video on the slide. It is displayed correctly in both LO-3.5 and LO-3.6, but not in LO-4 branch. I upload it here for testing purposes.
Comment 3 Vladimir 2013-04-09 13:43:07 UTC
The problem is still there after today's upgrade to libreoffice-4.0.2.2
Is there any progress on resolving this issue?

  Thanks!
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2013-04-26 18:59:13 UTC
Could you try to install gst-plugins-libav and add the video again?
Comment 5 Tomáš Chvátal (RETIRED) gentoo-dev 2013-04-26 19:00:44 UTC
The problem is that we moved fromg gst:0.10 to gst:1.0 and by default you have to install the providers yourself.
Comment 6 Vladimir 2013-04-27 03:46:33 UTC
(In reply to comment #4)
> Could you try to install gst-plugins-libav and add the video again?
I had this packages installed from the beginning (i.e. before I created this bugreport), and I am still not able to play any media files in LO.

(In reply to comment #5)
> The problem is that we moved fromg gst:0.10 to gst:1.0 and by default you
> have to install the providers yourself.
So how can I make it work again?

Thanks!
Comment 7 larmoe 2013-05-15 21:48:58 UTC
Same problem. LO Impress won't recognize any video file format. Since the issue apparently is the migration from gst 0.10 to gst 1.0, how do we solve the problem?
Comment 8 Evgenii Frolov 2013-07-19 08:52:53 UTC
Same problem!Is there any solution?
Comment 9 Stephan Heinrich 2013-08-04 18:02:07 UTC
same problem:
Presentations containing videos were running fine using LO 3.6, but the same presentations do not play any video using LO 4.0.4.2
I forced my system to switch from ffmpeg to libav by masking media-video/ffmpeg (because I was not able to find gst-plugins-ffmpeg:1.0 which seems to be responsible for playing mp4 videos), but still was not able to play videos or even insert new videos in a fresh presentation (tried randomly some formats: mov, avi, mpeg, mp4, mts). I always get "Das Format der ausgewählten Datei wird nicht unterstützt." (~ unsupported file format)

Updating to LO 4.1.0.4, gstreamer-1.0.5-r1, libav-0.8.7, gst-plugins-libav-1.1.0_pre20130128:1.0 did not help, same problems.

Using icedtea-bin-6 or oracle-jdk-bin-1.7 as user-vm (oracle-jdk-bin-1.7 is my system-vm) did not make any difference.
Comment 10 WOLfgang Schricker 2013-09-13 21:38:40 UTC
(In reply to Stephan Heinrich from comment #9)

Same problem also. Consideration should be given, mask >=app-office/libreoffice-4.0..0.0. Impress (multimedia includet) is a half libreoffice for same people.
Comment 11 Tomáš Chvátal (RETIRED) gentoo-dev 2013-09-15 10:35:21 UTC
*** Bug 482018 has been marked as a duplicate of this bug. ***
Comment 12 Tomáš Chvátal (RETIRED) gentoo-dev 2013-09-15 11:26:01 UTC
Could anyone try it on Archlinux?

It is the only distro that supports gst-1.0 build  nowdays, rest still use gst0.10.
Comment 13 Tomáš Chvátal (RETIRED) gentoo-dev 2013-09-15 11:33:37 UTC
Also other option is to revert back to use the gst-0.10 see the configure phase in ebuild which hard-disable it and just enable it yourself for testing.
Comment 14 Tomáš Chvátal (RETIRED) gentoo-dev 2013-09-18 11:29:57 UTC
Fixed retroactively in 4.0.5.2 and newer. So just recompile or wait for the next version bump. Yay :-)
Comment 15 Vladimir 2014-02-25 19:01:17 UTC
Hello!
I upgraded from 4.1.0.2 (a long ago installed one) to 4.2.0.4 this weekend, but it still does not work.

When I try to insert a movie, or to open it in the LO's built-in media player, or when I pull a slide containing a movie to the screen (make it visible), the Impress window silently disappears not leaving even a 'segfault' message in the console I started it from.
Comment 16 Vladimir 2014-02-27 11:01:18 UTC
I have also just discovered this message in the /var/log/messages :

kernel: soffice.bin[4752]: segfault at 7f967187af10 ip 00007f967187af10 sp 00007fff0d939d08 error 15 in libuno_cppuhelpergcc3.so.3[7f967187a000+a000]

Could somebody please explain its meaning, or even better - how to solve the problem? Thanks!
Comment 17 Vladimir 2014-02-27 11:25:33 UTC
(In reply to Vladimir from comment #16)
> I have also just discovered this message in the /var/log/messages :
> 
I was a little bit hurry with my conclusions. After that I tried several different files and discovered the following.

MPG files may be played back in the built-in media player, but return this message if I try to insert the movie into the presentation:

typefind:sink[5217]: segfault at 0 ip 00007f13421cd348 sp 00007f133cb17500 error 4 in libgstlibav.so[7f13421b0000+34000]

The MOV files cannot be even played back in the built-in media player. However, trying to insert the MOV or WEBM files produces another error message:

kernel: soffice.bin[5519]: segfault at 500000060 ip 00007fd943f70eca sp 00007fff148af0d0 error 4 in libavmediagst.so[7fd943f69000+e000]
Comment 18 Vladimir 2014-02-27 11:55:00 UTC
This looks like a similar bug in Freedesktop Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=70776
Comment 19 Vladimir 2014-03-06 00:34:50 UTC
This is just to report that everything works fine in LO-4.2.1.1 after installing the 'media-libs/gst-plugins-bad-1.2.3' and 'media-libs/gst-plugins-good-1.2.3' packages.