Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456934 - Since the 2012-09-09-make.conf-and-make.profile-move the overlay instructions are out of date
Summary: Since the 2012-09-09-make.conf-and-make.profile-move the overlay instructions...
Status: RESOLVED DUPLICATE of bug 445192
Alias: None
Product: [OLD] Docs on www.gentoo.org
Classification: Unclassified
Component: Other documents (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Overlays Project
URL: http://www.gentoo.org/proj/en/overlay...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-12 13:23 UTC by Sean A.O. Harney
Modified: 2013-04-06 11:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sean A.O. Harney 2013-02-12 13:23:00 UTC
Just a small problem with the Overlays userguide in this section: Code Listing 2.2: Telling Portage about layman-fetched repositories
(for layman 1.1)
# echo "source /usr/portage/local/layman/make.conf" >> /etc/make.conf

(for layman 1.2)
# echo "source /usr/local/portage/layman/make.conf" >> /etc/make.conf

(for layman 1.3 and later)
# echo "source /var/lib/layman/make.conf" >> /etc/make.conf

So the fix in the documentation should be ">> /etc/portage/make.conf"
as per this recent Gentoo news:

2012-09-09-make.conf-and-make.profile-move
  Title                     make.conf and make.profile move
  Author                    Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
  Posted                    2012-09-09
  Revision                  1

Starting next week, new stages will have make.conf and make.profile
moved from /etc to /etc/portage. This is a change in the installation
defaults, that will only affect new installs so it doesn't affect
current systems.

Current users don't need to do anything. But if you want to follow the
preferred location, you may want to take the chance to move the files
in your system(s) to the new location.


Thanks for my favorite Linux distro. Keep up the good work, guys!

Reproducible: Always

Steps to Reproduce:
1. View the documentation
2. Notice the old make.conf location

Actual Results:  
Load the documentation page in a web browser.

Expected Results:  
I saw the slightly outdated documentation, which might confuse a Gentoo newbie.

Use the current, new path for make.conf, rather than the old one!
Comment 1 Pavlos Ratis (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2013-04-06 11:27:15 UTC
Duplicate. However the paths are updated to /etc/portage/make.conf .

*** This bug has been marked as a duplicate of bug 445192 ***