Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456906 - sys-block/open-iscsi iscsiadm fails with sh: /sbin/iscsid: No such file or directory
Summary: sys-block/open-iscsi iscsiadm fails with sh: /sbin/iscsid: No such file or di...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Christian Ruppert (idl0r)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-12 10:04 UTC by Martin Pluskal
Modified: 2013-10-14 09:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Pluskal 2013-02-12 10:04:13 UTC
It seems that since path to iscsid has changed from /sbin/iscsid to /usr/sbin/iscsid, iscsiadm fails to work

Reproducible: Always

Steps to Reproduce:
1. Issue iscsiadm -m discovery -t st -p 10.100.98.70 (/etc/init.d/iscsid has not been started).
Actual Results:  
iscsiadm -m discovery -t st -p 10.100.98.70                                                                                                                                                     
sh: /sbin/iscsid: No such file or directory                                                                                                                                                                                                  
iscsiadm: can not connect to iSCSI daemon (111)!                                                                                                                                                                                             
sh: /sbin/iscsid: No such file or directory                                                                                                                                                                                                  
iscsiadm: can not connect to iSCSI daemon (111)!    

Expected Results:  
Targets would be listed without errors. 

Observed with sys-block/open-iscsi-2.0.872-r1
Comment 1 Christian Ruppert (idl0r) archtester Gentoo Infrastructure gentoo-dev Security 2013-10-11 20:10:40 UTC
Should be fixed in sys-block/open-iscsi-2.0.873, pleas test.
Comment 2 Martin Pluskal 2013-10-14 09:24:36 UTC
Works fine with sys-block/open-iscsi-2.0.873.