Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456818 - x11-libs/cairo-1.12.14: version bump
Summary: x11-libs/cairo-1.12.14: version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Ben de Groot (RETIRED)
URL: http://www.cairographics.org/
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 17:56 UTC by Serge Gavrilov
Modified: 2013-04-11 05:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serge Gavrilov 2013-02-11 17:56:50 UTC
Cairo 1.12.14 is released

Reproducible: Always
Comment 1 Robert Cabrera 2013-02-14 10:01:48 UTC
I can confirm that x11-libs/cairo-1.12.14 has been released. I tried to build it by changing the ebuild for version 1.12.12 in my overlay but the emerge fails because of an error with the cairo-1.10.2-qt-surface.patch. It does emerge however, without it on my ~amd64 laptop.

Since I'm a truck driver and not a programmer, I don't know what this patch does
and don't want to chance an issue with my system. So I reverted to x11-libs/cairo-1.12.12.

I hope this helps.
Comment 2 Rafał Mużyło 2013-03-18 09:08:59 UTC
Well, regarding cairo-1.10.2-qt-surface.patch, it's been more or less obsoleted by the upstream changes - AFAICT, the code affected by the patch was '#if 0'-ed.
Comment 3 Serge Gavrilov 2013-03-30 19:50:18 UTC
Please update, since cairo 1.12.14 fixes ugly bug https://bugs.freedesktop.org/show_bug.cgi?id=60248, which breaks printing.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2013-04-11 05:20:39 UTC
+*cairo-1.12.14 (11 Apr 2013)
+
+  11 Apr 2013; Lars Wendler <polynomial-c@gentoo.org>
+  +files/cairo-libpng16.patch, +cairo-1.12.14.ebuild:
+  Non-maintainer commit: Version bump (bug #456818). Added libpng16 patch (bug
+  #465044). Committed with kind permission from yngwin.
+