Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456672 - media-plugins/kipi-plugins-3.0.0 fails to build, possibly because of missing HUpnp dependency
Summary: media-plugins/kipi-plugins-3.0.0 fails to build, possibly because of missing ...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Andreas K. Hüttel
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-10 16:44 UTC by Christoph Lange
Modified: 2013-02-12 00:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
output of "cave resolve" (like "emerge") (1360513463-install-media-plugins_kipi-plugins-3.0.0:4::gentoo.out.gz,109.80 KB, application/octet-stream)
2013-02-10 16:46 UTC, Christoph Lange
Details
output of "cave info =media-plugins/kipi-plugins-3.0.0" (cave-info-kipi-plugins.out,12.29 KB, text/plain)
2013-02-10 16:48 UTC, Christoph Lange
Details
This is my complete buil.log attached. (build.log.txt.gz,98.55 KB, application/octet-stream)
2013-02-11 14:08 UTC, Martux
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Lange 2013-02-10 16:44:41 UTC
Building media-plugins/kipi-plugins-3.0.0 fails at 97% just after finishing the target HUpnpAv.  This may be due to the dependency HUpnp missing.  Configure reports

-- Could NOT find required package HUpnpCore: <http://herqq.org>
-- Could NOT find required package HUpnpAv: <http://herqq.org>

and there is no such package in portage.

Reproducible: Always

Steps to Reproduce:
1. merge media-plugins/kipi-plugins-3.0.0
Actual Results:  
fails to build


see attached output of "cave resolve" and "cave info"
Comment 1 Christoph Lange 2013-02-10 16:46:16 UTC
Created attachment 338524 [details]
output of "cave resolve" (like "emerge")
Comment 2 Christoph Lange 2013-02-10 16:48:28 UTC
Created attachment 338526 [details]
output of "cave info =media-plugins/kipi-plugins-3.0.0"
Comment 3 Christoph Lange 2013-02-10 20:57:40 UTC
Not sure whether this justifies closing the bug, but "cave fix-linkage" (which does the same job as revdep-rebuild) solved the problem.  In my case the following packages were rebuilt; among them at least libkexiv2 seems related to kipi-plugins:

* app-misc/strigi
* kde-base/gwenview
* kde-base/kdebase-kioslaves
* kde-base/libkexiv2
* kde-base/nepomuk-core
Comment 4 Martux 2013-02-11 11:51:46 UTC
It fails for me as well, at random percentage: 

/usr/bin/x86_64-pc-linux-gnu-ranlib ../../../lib/libHUpnpAv.a
make[2]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build'
/usr/bin/cmake -E cmake_progress_report /var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build/CMakeFiles  15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42
[ 88%] Built target HUpnpAv
make[1]: Leaving directory `/var/tmp/portage/media-plugins/kipi-plugins-3.0.0/work/kipi-plugins-3.0.0_build'
make: *** [all] Fehler 2
 * ERROR: media-plugins/kipi-plugins-3.0.0 failed (compile phase):
 *   emake failed

What is this "cave" command, cannot find it.
I thought this error is due to my usage of gcc-4.7.2 but another user reported it in the forums with 4.6.3 as well.


Here's my emerge --info:

Portage 2.2.0_alpha161 (default/linux/amd64/13.0/desktop/kde, gcc-4.7.2, glibc-2.16.0, 3.7.6-gentoo x86_64)
=================================================================
System uname: Linux-3.7.6-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_M_620_@_2.67GHz-with-gentoo-2.2
KiB Mem:     3898088 total,    711984 free
KiB Swap:    1951860 total,   1951860 free
Timestamp of tree: Mon, 11 Feb 2013 09:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo my_local_overlay
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/env.d/43kdepaths /etc/env.d/99skype /usr/share/config /usr/share/config/kdm/kdmrc /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=5.0 --with-bdeps=y --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://91.121.125.139/gentoo-distfiles/"
LANG="de_DE@euro.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 asf avahi berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib css cups cxx dbus declarative dri dts dvd dvdr emboss encode fam fbcondecor ffmpeg firefox flac fortran gdbm gif glib gpm gstreamer hddtemp iconv icu id3tag java jpeg jpeg2k kde kipi lame lcms libnotify lzma mad matroska mmx mng modemmanager modules mp3 mp4 mpeg mtp mudflap multilib mysql ncurses networkmanager nls nptl nsplugin ogg opencl opengl openmp pam pango pch pcre pdf phonon pic plasma png policykit ppds python3 qt3support qt4 quicktime readline sdl session sip smp spell sse sse2 ssl ssse3 startup-notification svg symlink taglib tcpd theora threads tiff truetype twolame udev udisks unicode upnp upower usb v4l vcd vdpau vorbis wav wavpack wxwidgets x264 xcb xcomposite xinerama xml xscreensaver xv xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 5 Rafał Mużyło 2013-02-11 11:59:37 UTC
@comment 4: that snippet of yours shows exactly nothing - attach full log.
Also, your problem (at least going by the provided info) seems unrelated to the original problem of this bug.
Comment 6 Christoph Lange 2013-02-11 12:55:36 UTC
(In reply to comment #4)
> What is this "cave" command, cannot find it.
I'm using paludis (http://paludis.exherbo.org), an alternative package manager.  "cave resolve" does a job similar to "emerge"; "cave info" is similar to "emerge --info".
Comment 7 Martux 2013-02-11 13:55:43 UTC
(In reply to comment #5)
> @comment 4: that snippet of yours shows exactly nothing - attach full log.
> Also, your problem (at least going by the provided info) seems unrelated to
> the original problem of this bug.

I don't see how it's unrelated. Btw. my build.log is 4,5MB(!) how and where to attach? Are files that size okay here?
Comment 8 Christoph Lange 2013-02-11 14:05:34 UTC
(In reply to comment #7)
> Btw. my build.log is 4,5MB(!) how and where
> to attach? Are files that size okay here?
You need to gzip it and upload it as an attachment of type application/octet-stream.
Comment 9 Martux 2013-02-11 14:08:52 UTC
Created attachment 338592 [details]
This is my complete buil.log attached.
Comment 10 Rafał Mużyło 2013-02-11 20:13:59 UTC
(In reply to comment #9)
> Created attachment 338592 [details]
> This is my complete buil.log attached.

/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.2/../../../../x86_64-pc-linux-gnu/bin/ld:
 cannot find -lGLU

The question is whether it's a direct or indirect dependency.
Though it seems to answer why 'cave fix-linkage' might have made a difference.

Though it would (on portage side) made it a revdep-rebuild problem, so not really a bug.
Comment 11 Martux 2013-02-11 20:58:55 UTC
Yet this is nothing which can be fixed by a simple revdep-rebuild.
Comment 12 Chris Reffett gentoo-dev Security 2013-02-11 23:21:50 UTC
Remerge media-libs/glu and try again.
Comment 13 Martux 2013-02-11 23:50:09 UTC
(In reply to comment #12)
> Remerge media-libs/glu and try again.

Thanks, that worked for me!
Comment 14 Chris Reffett gentoo-dev Security 2013-02-12 00:20:32 UTC
Okay, that's solved. Regarding the original problem: the error appears to have been "/usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libexiv2.so.10, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/4.5.4/../../../../lib64/libkexiv2.so, not found (try using -rpath or -rpath-link)", so the rebuild of libexiv2 was most likely what sorted that out. Now that we're all happy, I'm resolving the bug.