Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456388 - kde-misc/krename-4.0.9: fatal error: freetype/config/ftheader.h: No such file or directory
Summary: kde-misc/krename-4.0.9: fatal error: freetype/config/ftheader.h: No such file...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo KDE team
Depends on:
Reported: 2013-02-10 06:27 UTC by BT
Modified: 2013-03-18 12:24 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,100.94 KB, text/plain)
2013-02-10 06:27 UTC, BT
Use FREETYPE_INCLUDE_DIRS (krename-4.0.9-freetype-include.patch,511 bytes, patch)
2013-02-24 10:35 UTC, Sven Wehner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description BT 2013-02-10 06:27:43 UTC
Created attachment 338468 [details]

emerge --info
Portage 2.2.0_alpha161 (default/linux/amd64/13.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-_i5-3570K_CPU_@_3.40GHz-with-gentoo-2.1
KiB Mem:     7859992 total,    696712 free
KiB Swap:    1048572 total,   1048572 free
Timestamp of tree: Sun, 10 Feb 2013 01:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo amak79
CFLAGS="-march=corei7-avx -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=corei7-avx -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acpi alsa amd64 berkdb bluetooth bzip2 cairo caps cdda cdinstall cdr cli consolekit cracklib crypt css cups cxx dbus declarative dri dts dvd dvdr encode exif ffmpeg flac fortran gdbm gif gpm iconv joystick jpeg kde kipi lcms mad matroska mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline scanner sdl session spell sse sse2 ssl svg taglib tcpd theora threads tiff truetype udev udisks unicode upower usb vorbis x264 xcb xcomposite xinerama xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Agostino Sarubbo gentoo-dev 2013-02-10 09:44:33 UTC
The correct path is: /usr/include/freetype2/freetype/config/ftheader.h
Comment 2 Michael Palimaka (kensington) gentoo-dev 2013-02-10 16:23:32 UTC
In file included from /var/tmp/portage/kde-misc/krename-4.0.9/work/krename-4.0.9/src/fontplugin.h:28:0,
                 from /var/tmp/portage/kde-misc/krename-4.0.9/work/krename-4.0.9/src/pluginloader.cpp:40:
/usr/include/ft2build.h:56:38: fatal error: freetype/config/ftheader.h: No such file or directory

@fonts, any idea why ft2build.h from freetype is including a header that does not exist?
Comment 3 DrSlony 2013-02-10 22:25:28 UTC
Same error here. I need to recompile krename because of libexiv2 update from 4.9.5 to 4.10.0

Comment 4 Pavel 2013-02-11 07:51:35 UTC
Comment 5 Till Schäfer 2013-02-11 13:21:44 UTC
(In reply to comment #4)
> Confirm.
> media-libs/freetype-2.4.11
> kde-misc/krename-4.0.9

same here (confirm)
Comment 6 Richard H. 2013-02-15 02:36:32 UTC
same here on x86_64. The header exists. But I guess the path is wrong.

USE="-truetype" is my fix for now.
Comment 7 Sven Wehner 2013-02-24 10:34:12 UTC
The error seems to be quite trivial. The FindFreetype.cmake file reports two different *_INCLUDE_DIR directories: FREETYPE_INCLUDE_DIR_ft2build and FREETYPE_INCLUDE_DIR_freetype2. If you want to use both paths you have to use FREETYPE_INCLUDE_DIRS (appending "S").
The following patch made krename compile again with truetype enabled.
You can test the patch by copying it to /etc/portage/patches/kde-misc/krename/.
Comment 8 Sven Wehner 2013-02-24 10:35:33 UTC
Created attachment 339928 [details, diff]

Fixes the include path for freetype.
Comment 9 Erik Zeek 2013-03-02 13:46:02 UTC
media-gfx/kpovmodeler-1.1.3 has the exact same error.
Comment 10 Till Schäfer 2013-03-18 09:00:33 UTC
Any progress here? This bug is very anoying because it makes krename unusable for gentoo at all (only one version, not compiling on fresh installs). Since there is already a patch i would love to see this fix in the main tree.
Comment 11 Michael Palimaka (kensington) gentoo-dev 2013-03-18 11:40:59 UTC
Thanks everyone, this is now fixed in CVS.

+  18 Mar 2013; Michael Palimaka <>
+  +files/krename-4.0.9-freetype-include.patch, krename-4.0.9.ebuild:
+  Add patch by Sven Wehner <> fixing build with
+  USE="truetype", wrt bug 456388.
Comment 12 Till Schäfer 2013-03-18 12:24:52 UTC
wow that was fast ;) THX