Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 456180 - media-gfx/graphicsmagick-1.3.16-r1: Perl bindings not linked properly
Summary: media-gfx/graphicsmagick-1.3.16-r1: Perl bindings not linked properly
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
Depends on:
Reported: 2013-02-08 15:45 UTC by Michael Eichenberger
Modified: 2014-01-06 10:08 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Michael Eichenberger 2013-02-08 15:45:17 UTC
After a fresh install of media-gfx/graphicsmagick-1.3.16-r1 the following ldd output only returned libc and co. did not appear.

# ldd /usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux/auto/Graphics/Magick/ (0x00007fff8c9ff000) => /usr/lib64/ (0x00007f3b4400c000) => /lib64/ (0x00007f3b43d0f000) => /lib64/ (0x00007f3b43967000) => /lib64/ (0x00007f3b43741000) => /lib64/ (0x00007f3b43530000) => /lib64/ (0x00007f3b43318000) => /usr/lib64/ (0x00007f3b4310d000) => /lib64/ (0x00007f3b42f09000)
        /lib64/ (0x00007f3b44567000) => /lib64/ (0x00007f3b42cec000)

This led to the following error, when perl tried to load graphicsmagick:

[Fri Feb 08 16:21:47 2013] [error] [client] Can't load '/usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux/auto/Graphics/Magick/' for module Graphics::Magick: /usr/lib64/perl5/vendor_perl/5.12.4/x86_64-linux/auto/Graphics/Magick/ undefined symbol: DestroyImageInfo at /usr/lib64/perl5/5.12.4/x86_64-linux/ line 200.

Reproducible: Always

Actual Results:  
After executing emerge --oneshot graphicsmagick -va everything works as exected.
Comment 1 Tiziano Müller (RETIRED) gentoo-dev 2013-06-07 15:30:58 UTC
ok for me to commit a 1.3.18-r1 with the following patch applied?
Upstream bug reported (see URL).

diff --git a/PerlMagick/ b/PerlMagick/
index 9937e8e..1700f0c 100644
--- a/PerlMagick/
+++ b/PerlMagick/
@@ -23,7 +23,7 @@ my $magick_LDFLAGS='@LDFLAGS@';
 my $magick_BIN_DIR="$ENV{'DESTDIR'}@BIN_DIR@";
 my $magick_DEP_LIBS='@MAGICK_DEP_LIBS@';
+my $magick_LIB_DIR="../magick/.libs";
 # Compute test specification
 my $delegate_tests='t/*.t';
Comment 2 Tim Harder gentoo-dev 2014-01-02 09:02:52 UTC
Fixed in 1.3.19.
Comment 3 Michael Eichenberger 2014-01-02 10:10:55 UTC
Thank you!

Kind regards, Michael
Comment 4 Tiziano Müller (RETIRED) gentoo-dev 2014-01-06 10:08:40 UTC
Unfortunately upstream does not want it solved that way (see URL), I do not understand their arguments though since they already rely on specific behaviour of Make:Maker.
Anyway: according to them, one should first install GraphicsMagick and then build the perl bindings against the installed libs.
Since graphviz was fixed using a similar patch ages ago without problems I would recommend to just keep our patch and split the ebuild iff problems arise with it.