Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455918 - x11-drivers/nvidia-drivers-313.18 fails to compile with linux-3.7.6-gentoo
Summary: x11-drivers/nvidia-drivers-313.18 fails to compile with linux-3.7.6-gentoo
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-06 21:45 UTC by Mark Nowiasz
Modified: 2013-02-07 01:33 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,3.14 KB, text/plain)
2013-02-06 21:47 UTC, Mark Nowiasz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Nowiasz 2013-02-06 21:45:31 UTC
When trying to emerge nvidia-drivers after updating to linux-3.7.6, emerge -1 nvidia-drivers fails with "*** Unable to determine the target kernel version. ***

Reproducible: Always

Steps to Reproduce:
1. update to linux-3.7.6
2. emerge -1 nvidia-drivers
3.
Actual Results:  
*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1
 * ERROR: x11-drivers/nvidia-drivers-313.18 failed (compile phase):
 *   emake failed



emerge --info
Portage 2.1.11.50 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.16.0, 3.7.4-gentoo x86_64)
=================================================================
System uname: Linux-3.7.4-gentoo-x86_64-Intel-R-_Core-TM-_i7-2600_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16421948 total,   6030040 free
KiB Swap:   33554428 total,  33554428 free
Timestamp of tree: Wed, 06 Feb 2013 18:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.mneisen.org/ http://de-mirror.org/distro/gentoo/ ftp://de-mirror.org/distro/gentoo/ http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ ftp://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://mirror.jamit.de/gentoo/ http://mirror.netcologne.de/gentoo/ ftp://mirror.netcologne.de/gentoo/ "
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi aim alsa amd64 apng audiofile bash-completion bcmath berkdb blas bluetooth branding bzip2 cairo calendar cdb cdda cddb cdinstall cdparanoia cdr chromium cli clutter consolekit cracklib crypt css cups curl curlwrappers cvs cxx dbus djvu dri dts dv dvb dvd dvdr eds encode enscript evo exif expat fam ffmpeg fftw flac fontconfig foomaticdb fortran ftp gd gdbm gdu geoip gif gimp git glut gmp gnome gnome-keyring gnome-online-accounts gnuplot gnutls gphoto2 gpm graphviz gsl gsm gstreamer gtk gtk3 gtkhtml gudev gzip handbook hbci hddtemp hdf5 iconv icq icu idn imagemagick imap imlib ipv6 jabber jack java java6 javascript jbig jingle joystick jpeg jpeg2k kde lame lapack lash latex lcms ldap libcaca libedit libffi libnotify libsamplerate libwww lm_sensors lua lzma lzo mad maildir matroska memlimit mercurial mhash mikmod milter mime mmap mms mmx mng modplug modules mono mp3 mp4 mpeg mpi mplayer msn mtp mudflap multilib musepack musicbrainz mysql mysqli nas nautilus ncurses netcdf nls nntp nocd nptl nsplugin ocr odbc offensive ofx ogg openal openexr opengl openmp osc oscar pam pcntl pcre pda pdf php plasma plotutils png policykit postgres ppds pulseaudio python qt3support qt4 quicktime raw rdesktop readline recode rss samba sasl scanner sdl semantic-desktop session sharedmem shorten slang slp smp sndfile snmp soap sockets sound sox speex spell sqlite sqlite3 sse sse2 sse3 ssl startup-notification subversion suid svg syslog szip taglib tcl tcpd themes theora threads tiff timidity tk tokenizer tracker truetype unicode upnp usb v4l vala vcd videos vim-syntax vnc vorbis vpn vpnc wavpack webkit wmf wxwidgets x264 xattr xcb xcomposite xface xft xine xinerama xml xmlrpc xmp xmpp xosd xpm xscreensaver xsl xulrunner xv xvid yahoo yaz zeitgeist zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Mark Nowiasz 2013-02-06 21:47:12 UTC
Created attachment 338150 [details]
build.log
Comment 2 Stijn Tintel 2013-02-06 23:36:40 UTC
Same problem here, gentoo-sources-3.7.6, amd64. Found a workaround in http://forums.gentoo.org/viewtopic-p-7240158.html?sid=2ca86d86af8354d5ae570a4fca7155d0
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-02-07 01:33:10 UTC

*** This bug has been marked as a duplicate of bug 447566 ***