Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455816 - net-libs/gupnp-igd - src_prepare(): libgupnp-igd/Makefile.am:64: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL
Summary: net-libs/gupnp-igd - src_prepare(): libgupnp-igd/Makefile.am:64: HAVE_INTROSP...
Status: RESOLVED DUPLICATE of bug 468100
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo net-p2p team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-06 10:53 UTC by cyberbat
Modified: 2013-05-04 11:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cyberbat 2013-02-06 10:53:26 UTC
cat /var/tmp/portage/net-libs/gupnp-igd-0.2.1/temp/automake.out
***** automake *****
***** PWD: /var/tmp/portage/net-libs/gupnp-igd-0.2.1/work/gupnp-igd-0.2.1
***** automake --add-missing --copy

libgupnp-igd/Makefile.am:64: HAVE_INTROSPECTION does not appear in AM_CONDITIONAL


cat /var/tmp/portage/net-libs/gupnp-igd-0.2.1/temp/build.log
 * Package:    net-libs/gupnp-igd-0.2.1
 * Repository: gentoo
 * Maintainer: net-p2p@gentoo.org
 * USE:        consolekit elibc_glibc kernel_linux policykit userland_GNU x86
 * FEATURES:   ccache sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking gupnp-igd-0.2.1.tar.gz to /var/tmp/portage/net-libs/gupnp-igd-0.2.1/work
>>> Source unpacked in /var/tmp/portage/net-libs/gupnp-igd-0.2.1/work
>>> Preparing source in /var/tmp/portage/net-libs/gupnp-igd-0.2.1/work/gupnp-igd-0.2.1 ...
 * Applying gupnp-igd-0.1.11-disable_static_modules.patch ...                                                           [ ok ]
 * Running eautoreconf in '/var/tmp/portage/net-libs/gupnp-igd-0.2.1/work/gupnp-igd-0.2.1' ...
 * Skipping 'gtkdocize --copy' due gtkdocize not installed
 * Running libtoolize --install --copy --force --automake ...                                                           [ ok ]
 * Running aclocal -I m4 ...                                                                                            [ ok ]
 * Running autoconf ...                                                                                                 [ ok ]
 * Running autoheader ...                                                                                               [ ok ]
 * Running automake --add-missing --copy ...                                                                            [ !! ]

 * Failed Running automake !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/net-libs/gupnp-igd-0.2.1/temp/automake.out

 * ERROR: net-libs/gupnp-igd-0.2.1 failed (prepare phase):
 *   Failed Running automake !
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_prepare
 *   environment, line 5472:  Called eautoreconf
 *   environment, line 1408:  Called eautomake
 *   environment, line 1357:  Called autotools_run_tool 'automake' '--add-missing' '--copy'
 *   environment, line 1170:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 * 
 * If you need support, post the output of `emerge --info '=net-libs/gupnp-igd-0.2.1'`,
 * the complete build log and the output of `emerge -pqv '=net-libs/gupnp-igd-0.2.1'`.
/usr/lib/portage/bin/isolated-functions.sh: line 213: wait: `Failed Running automake !': не идентификатор  процесса или правильное имя задачи
 * The complete build log is located at '/var/tmp/portage/net-libs/gupnp-igd-0.2.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/gupnp-igd-0.2.1/temp/environment'.
 * Working directory: '/var/tmp/portage/net-libs/gupnp-igd-0.2.1/work/gupnp-igd-0.2.1'
 * S: '/var/tmp/portage/net-libs/gupnp-igd-0.2.1/work/gupnp-igd-0.2.1'

emerge --info
Portage 2.1.11.31 (default/linux/x86/10.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.7.4-gentoo i686)
=================================================================
System uname: Linux-3.7.4-gentoo-i686-Intel-R-_Core-TM-_i7-3930K_CPU_@_3.20GHz-with-gentoo-2.1
Timestamp of tree: Wed, 06 Feb 2013 08:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=corei7-avx -mno-cx16 -mno-movbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mno-avx -mno-sse4.2 -mno-sse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7-avx -mno-cx16 -mno-movbe -mno-aes -mno-pclmul -mno-popcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-tbm -mno-avx -mno-sse4.2 -mno-sse4.1 --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=6144 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage-distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news nodoc noinfo noman parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="ru_RU.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j13"
PKGDIR="/usr/portage-local/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi branding bzip2 cairo cli consolekit cracklib crypt cups cxx dbus declarative device-mapper dirac dri dts dvb dvd dvdr emboss exif fam firefox flac fmpeg fortran gif gnutls gpm gtk iconv icu idn jpeg jpeg2k kde kipi lcms libass libnotify libsamplerate lzma mad matroska mms mmx mng modules mp3 mp4 mpeg mtp mudflap musepack ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline schroedinger sdl session speex spell sse sse2 sse3 ssl ssse3 startup-notification svg taglib theora threads tiff truetype udev udisks unicode upower usb vlc vorbis wavpack wxwidgets x264 x86 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="caps lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport wiki-publisher" LINGUAS="ru en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="virtualbox" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS
Comment 1 dE 2013-03-16 13:50:15 UTC
Confirmed.
Comment 2 Sergey Popov gentoo-dev 2013-04-08 14:53:50 UTC
Confirming this too for 0.2.1 and for 0.2.2 with USE='-introspection'
Comment 3 Andreis Vinogradovs ( slepnoga ) 2013-04-08 17:07:27 UTC
Problem code:
26 GOBJECT_INTROSPECTION_CHECK([0.10])
27 if test "x$found_introspection" = "xyes"; then
28    INTROSPECTION_TYPELIBDIR=`$PKG_CONFIG --variable=typelibdir --define-variable="libdir=${libdir}" gobject-introspection-1.0`
29    INTROSPECTION_GIRDIR=`$PKG_CONFIG --variable=girdir --define-variable="datadir=${datadir}" gobject-introspection-1.0`
30    AC_SUBST(INTROSPECTION_TYPELIBDIR)
31    AC_SUBST(INTROSPECTION_GIRDIR)
32 fi
not subst HAVE_INTROSPECTION

Untested fix:

    AC_SUBST(INTROSPECTION_TYPELIBDIR)
+   AC_SUBST([HAVE_INTROSPECTION])
    AC_SUBST(INTROSPECTION_GIRDIR)
 fi
Comment 4 Justin Lecher gentoo-dev 2013-05-04 11:40:27 UTC

*** This bug has been marked as a duplicate of bug 468100 ***