Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455636 - app-emulation/libvirt-1.0.2 USE=-libvirtd - node_device/node_device_udev.c:1608:37: error: unknown type name 'virStateInhibitCallback'
Summary: app-emulation/libvirt-1.0.2 USE=-libvirtd - node_device/node_device_udev.c:16...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Doug Goldstein
URL: https://www.redhat.com/archives/libvi...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-05 17:46 UTC by majlo
Modified: 2013-03-20 19:08 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,66.57 KB, text/plain)
2013-02-05 17:46 UTC, majlo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description majlo 2013-02-05 17:46:09 UTC
app-emulation/libvirt-1.0.2 fails to compile with disabled libvirtd USE flag.

Reproducible: Always




Portage 2.1.11.50 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.3, glibc-2.16.0, 3.7.4-pf x86_64)
=================================================================
System uname: Linux-3.7.4-pf-x86_64-AMD_Athlon-tm-_64_X2_Dual-Core_Processor_TK-42-with-gentoo-2.2
KiB Mem:     2822268 total,    549660 free
KiB Swap:    2093052 total,   1907212 free
Timestamp of tree: Tue, 05 Feb 2013 15:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3, 4.7.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo milo000-overlay flameeyes-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps=y --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/milo000-overlay /var/lib/layman/flameeyes-overlay"
SYNC="rsync://rsync2.nl.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 amr bash-completion berkdb bluetooth branding bzip2 cairo cdda cddb cdr cli consolekit cracklib crypt cups curl cxx dbus declarative development dirac djvu dri dts dv dvd dvdr emboss encode exif fam fbcon ffmpeg fftw firefox flac fontconfig fortran fuse gd gdbm gif gimp gmp gnutls gpm gsm gstreamer gtk iconv icu id3tag ipc ipv6 java jpeg kde kipi lame laptop latex lcms libass libnotify libsamplerate lzma lzo mad matroska mmx mmxext mng modules mp3 mp4 mpeg mpi mplayer mtp mudflap multilib ncurses networkmanager nls nptl nsplugin offensive ogg openal opengl openmp pam pango pch pcre pdf perl phonon plasma plotutils png policykit postscript ppds private-headers python qt3support qt4 readline samba scanner sdl semantic-desktop session smp source speex spell sqlite sse sse2 sse3 ssl startup-notification svg taglib tcpd theora threads thumbnail tiff tk truetype udev udisks unicode upower usb v4l vim-syntax vorbis vpx wxwidgets x264 xcb xcomposite xinerama xml 
xscreensaver xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df 
interface irq load memory rrdtool swap syslog" DRACUT_MODULES="crypt lvm" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US pl" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 majlo 2013-02-05 17:46:57 UTC
Created attachment 338030 [details]
build.log
Comment 2 Doug Goldstein gentoo-dev 2013-02-22 04:27:54 UTC
Try libvirt-1.0.2-r2 and let me know.
Comment 3 majlo 2013-02-22 07:09:42 UTC
Unfortunately still fails with libvirt-1.0.2-r2.
Comment 4 Björn Baumbach 2013-02-27 16:15:02 UTC
I see the same issue while compiling
app-emulation/libvirt-1.0.2-r2 [0.10.2.1] USE="caps macvtap nls policykit python udev vepa -audit -avahi -firewalld% -iscsi -libvirtd -lvm -lxc -nfs -numa -openvz -parted -pcap -phyp -qemu -rbd -sasl (-selinux) -uml -virt-network -virtualbox -xen (-debug%)" 0 kB
Comment 5 Martin Samek 2013-03-04 22:31:38 UTC
I have this problem too.

pp-emulation/libvirt-1.0.2-r2 [0.10.2.1] USE="caps macvtap nls (policykit) python udev vepa -audit -avahi -firewalld% -iscsi -libvirtd -lvm -lxc -nfs -numa -openvz -parted -pcap -phyp -qemu -rbd -sasl (-selinux) -uml -virt-network -virtualbox -xen (-debug%)"
Comment 6 Aaron Burnett 2013-03-14 15:10:33 UTC
I can confirm this also.  I have the same USE flags as Martin above.  The same failure occurs with app-emulation/libvirt-1.0.3-r1 as well.  This will compile with the "libvirtd" USE, but the daemon isn't always desired obviously.
Comment 7 Doug Goldstein gentoo-dev 2013-03-17 02:13:26 UTC
I've posted a fix to the libvirt ML. You should be able to put it in /etc/portage/patches/app-emulation/libvirt/ until we carry it in tree.

Once its accepted upstream I'll backport it to v1.0.3-maint and v1.0.2-maint and we'll have it in Gentoo.
Comment 8 Björn Baumbach 2013-03-17 10:29:16 UTC
(In reply to comment #7)
> I've posted a fix to the libvirt ML. You should be able to put it in
> /etc/portage/patches/app-emulation/libvirt/ until we carry it in tree.
> 
> Once its accepted upstream I'll backport it to v1.0.3-maint and v1.0.2-maint
> and we'll have it in Gentoo.

fixed :-)

>>> Installing (1 of 1) app-emulation/libvirt-1.0.2-r2
mv: cannot stat ‘/var/tmp/portage/app-emulation/libvirt-1.0.2-r2/image//etc/sysctl.d/libvirtd’: No such file or directory
 * Compilation and optimization of Python modules for CPython 2.7 ...    [ ok ]
Comment 9 Doug Goldstein gentoo-dev 2013-03-20 19:07:49 UTC
Fixed in 1.0.3-r2, which I will request for stable soon.
Comment 10 Doug Goldstein gentoo-dev 2013-03-20 19:08:05 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > I've posted a fix to the libvirt ML. You should be able to put it in
> > /etc/portage/patches/app-emulation/libvirt/ until we carry it in tree.
> > 
> > Once its accepted upstream I'll backport it to v1.0.3-maint and v1.0.2-maint
> > and we'll have it in Gentoo.
> 
> fixed :-)
> 
> >>> Installing (1 of 1) app-emulation/libvirt-1.0.2-r2
> mv: cannot stat
> ‘/var/tmp/portage/app-emulation/libvirt-1.0.2-r2/image//etc/sysctl.d/
> libvirtd’: No such file or directory
>  * Compilation and optimization of Python modules for CPython 2.7 ...    [
> ok ]

Different issue, but I'll look into it.