Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455604 - mail-filter/spamassassin-3.3.2-r1 initd script fails because checkpath is missing
Summary: mail-filter/spamassassin-3.3.2-r1 initd script fails because checkpath is mis...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: 583908
  Show dependency tree
 
Reported: 2013-02-05 14:14 UTC by Frieder Bürzele
Modified: 2016-06-04 15:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
add checkpath and userdetection (etc_init.d_spamd_spamassassin-3.3.2-r1.patch,584 bytes, patch)
2013-02-05 14:17 UTC, Frieder Bürzele
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frieder Bürzele 2013-02-05 14:14:03 UTC
checkpath is missing in init script, so if you configure spamd to use another directory for the pidfile. eg. if you want to run it with another user it fails.

Reproducible: Always
Comment 1 Frieder Bürzele 2013-02-05 14:17:55 UTC
Created attachment 338012 [details, diff]
add checkpath and userdetection

fix the problem:
* add checkpath
* detect and set permission/directory
* chown if user specified
Comment 2 Jeroen Roovers gentoo-dev 2013-02-05 21:32:46 UTC
Comment on attachment 338012 [details, diff]
add checkpath and userdetection

It shouldn't use /var/run at all, but /run instead.
Comment 3 Frieder Bürzele 2013-02-05 21:53:32 UTC
(In reply to comment #2)
> Comment on attachment 338012 [details, diff] [details, diff]
> add checkpath and userdetection
> 
> It shouldn't use /var/run at all, but /run instead.

agree it should not use /var/run but the patch still fixes the path creation and user chown.

So in the file /etc/conf.d/spamd the PIDFILE should also be moved to /run/spamd.pid
Comment 4 Quincy 2013-02-26 09:38:18 UTC
I also stumbled across this when upgrading several production systems to use tmpfs for /run. I don't quite understand why the working patch got removed, nothing said about /var/run in that. Definitely there should be an updated init script in portage, because it can stop spamassassin from working at all which is really a bad thing in webhosting environments.
Comment 5 Marcin Mirosław 2016-05-31 12:23:35 UTC
See also bug #523960, "-u" doesn't change running user of master process. I don't see reason to move pidfile elsewhere. Is a good reason to have option to set PIDFILE in conf.d/spamd? I think it can be removed.
Comment 6 Michael Orlitzky gentoo-dev 2016-06-04 15:37:46 UTC
I just fixed this in yet-another-revision:

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=19ff5b04b9db6b1319b35e9a6da3d26972bf04b5

I reworked the spamd init/config -- now the PID file is hard-coded, and all that is needed is one simple call to `checkpath --directory`.