Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455286 - =media-libs/gstreamer-0.10.36 upgrade causes kde-base/dragon-4.9.5 to crash when playing movies
Summary: =media-libs/gstreamer-0.10.36 upgrade causes kde-base/dragon-4.9.5 to crash w...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-03 14:53 UTC by Tanktalus
Modified: 2013-06-21 20:54 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Full backtrace, all threads (full-bt.gstreamer.out,27.50 KB, text/plain)
2013-02-04 17:58 UTC, Tanktalus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tanktalus 2013-02-03 14:53:30 UTC
Any movie I have, including the ones made by my camera, crashes under KDE's dragon after upgrading gstreamer to 0.10.36 from 0.10.35.  Sometimes the window starts up before a crash, but not usually.



Reproducible: Always

Actual Results:  
[dmcbride@naboo 12-ChristmasEvents]$ dragon MOV07684.MPG 
dragonplayer(31453)/kdecore (KSycoca) KSycocaPrivate::openDatabase: Trying to open ksycoca from "/var/tmp/kdecache-dmcbride/ksycoca4"
dragonplayer(31453) Phonon::KdePlatformPlugin::createBackend: using backend:  "GStreamer"
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
dragonplayer(31453) Dragon::MainWindow::engineStateChanged: Stopped state
dragonplayer(31453) Dragon::MainWindow::engineStateChanged: updated actions
dragonplayer(31453) Dragon::MainWindow::engineStateChanged: updated menus
dragonplayer(31453) Dragon::MainWindow::updateTitleBarText: set titles
dragonplayer(31453) Dragon::MainWindow::engineSeekableChanged: seekable changed to  false
dragonplayer(31453) Dragon::MainWindow::open: KUrl("file:///disk1/share/albums/2012/12-ChristmasEvents/MOV07684.MPG")
dragonplayer(31453)/kio (Scheduler) KIO::SchedulerPrivate::doJob: KIO::SimpleJob(0x271a4f0)
dragonplayer(31453)/kio (Scheduler) KIO::SchedulerPrivate::protoQ: creating ProtoQueue instance for "file"
dragonplayer(31453)/kio (Scheduler) KIO::ProtoQueue::ProtoQueue: m_maxConnectionsTotal: 5 m_maxConnectionsPerHost: 5
QPainter::begin: Paint device returned engine == 0, type: 2
dragonplayer(31453)/kio (Slave) KIO::Slave::createSlave: createSlave "file" for KUrl("file:///disk1/share/albums/2012/12-ChristmasEvents/MOV07684.MPG")
dragonplayer(31453)/kio (KIOConnection) KIO::ConnectionServer::listenForRemote: Listening on  "local:/tmp/ksocket-dmcbride/dragonplayerw31453.slave-socket"
dragonplayer(31453)/kio (Scheduler) KIO::SchedulerPrivate::jobFinished: KIO::StatJob(0x271a4f0) KIO::Slave(0x2842620)
dragonplayer(31453) Dragon::VideoWindow::load: detected mimetype:  "video/mpeg"
dragonplayer(31453) Dragon::MainWindow::open: Initial offset is  0
QPainter::begin: Paint device returned engine == 0, type: 2
dragonplayer(31453) Dragon::AudioView::resizeEvent: QRectF(0,0 619x459) QRectF(0,0 619x459)
dragonplayer(31453) Dragon::VideoWindow::stateChanged: chapters:  0  titles:  0
dragonplayer(31453) Dragon::VideoWindow::stateChanged: going from  "Loading"  to  "Stopped"
dragonplayer(31453) Dragon::MainWindow::engineStateChanged: Stopped state
dragonplayer(31453) Dragon::MainWindow::engineStateChanged: updated actions
dragonplayer(31453) Dragon::MainWindow::engineStateChanged: updated menus
dragonplayer(31453) Dragon::MainWindow::updateTitleBarText: set titles
QPainter::begin: Paint device returned engine == 0, type: 2
dragonplayer(31453) Dragon::AudioView::resizeEvent: QRectF(0,0 634x474) QRectF(0,0 634x474)
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
dragonplayer(31453) Dragon::AudioView::resizeEvent: QRectF(0,0 1914x1038) QRectF(0,0 1914x1038)
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = dragon path = /usr/bin pid = 31453
KCrash: Arguments: /usr/bin/dragon --nocrashhandler MOV07684.MPG 
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/dmcbride/.kde4/socket-naboo/kdeinit4__0
Unable to start Dr. Konqi
-----
(note that no window came up here this time, not that that is likely relevant.)

Expected Results:  
Some Christmas magic, just like with vlc
Comment 1 Agostino Sarubbo gentoo-dev 2013-02-04 17:22:01 UTC
Could you post a significan backtrace?
Comment 2 Tanktalus 2013-02-04 17:58:00 UTC
It's a bit harder now that I've switched to phonon-vlc, but this seems to be it.

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffdf1b3700 (LWP 16116)]
0x00007fffe7d15daf in gst_structure_foreach ()
   from /usr/lib64/libgstreamer-0.10.so.0
(gdb) bt
#0  0x00007fffe7d15daf in gst_structure_foreach ()
   from /usr/lib64/libgstreamer-0.10.so.0
#1  0x00007fffe7cd116a in gst_caps_is_equal ()
   from /usr/lib64/libgstreamer-0.10.so.0
#2  0x00007fffe65760c5 in gst_base_transform_buffer_alloc ()
   from /usr/lib64/libgstbase-0.10.so.0
#3  0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#4  0x00007fffe7ce3e37 in gst_proxy_pad_bufferalloc_default ()
   from /usr/lib64/libgstreamer-0.10.so.0
#5  0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#6  0x00007fffe2afd7ee in gst_queue_bufferalloc ()
   from /usr/lib64/gstreamer-0.10/libgstcoreelements.so
#7  0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#8  0x00007fffe7ce3e37 in gst_proxy_pad_bufferalloc_default ()
   from /usr/lib64/libgstreamer-0.10.so.0
#9  0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#10 0x00007fffe1751ba3 in gst_stream_synchronizer_sink_bufferalloc ()
   from /usr/lib64/gstreamer-0.10/libgstplaybin.so
#11 0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#12 0x00007fffe7ce3e37 in gst_proxy_pad_bufferalloc_default ()
   from /usr/lib64/libgstreamer-0.10.so.0
#13 0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#14 0x00007fffe2af5080 in gst_selector_pad_bufferalloc ()
   from /usr/lib64/gstreamer-0.10/libgstcoreelements.so
#15 0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#16 0x00007fffe7ce3e37 in gst_proxy_pad_bufferalloc_default ()
   from /usr/lib64/libgstreamer-0.10.so.0
#17 0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#18 0x00007fffe7ce3e37 in gst_proxy_pad_bufferalloc_default ()
   from /usr/lib64/libgstreamer-0.10.so.0
#19 0x00007fffe7cf4b6a in gst_pad_alloc_buffer_full ()
   from /usr/lib64/libgstreamer-0.10.so.0
#20 0x00007fffddf09259 in gst_mpeg2dec_alloc_sized_buf (obuf=0x7fffdf1b2840, 
    size=460800, mpeg2dec=0xc374b0) at gstmpeg2dec.c:386
#21 gst_mpeg2dec_alloc_buffer (obuf=<synthetic pointer>, offset=1452251, 
    mpeg2dec=0xc374b0) at gstmpeg2dec.c:426
#22 handle_picture (mpeg2dec=0xc374b0, info=<optimized out>)
    at gstmpeg2dec.c:687
#23 gst_mpeg2dec_chain (pad=<optimized out>, buf=<optimized out>)
    at gstmpeg2dec.c:1144
#24 0x00007fffe7cf5cca in gst_pad_push_data ()
   from /usr/lib64/libgstreamer-0.10.so.0
#25 0x00007fffe7cf96c6 in gst_pad_push ()
   from /usr/lib64/libgstreamer-0.10.so.0
#26 0x00007fffe655d30e in gst_base_parse_push_frame ()
   from /usr/lib64/libgstbase-0.10.so.0
#27 0x00007fffe655e236 in gst_base_parse_handle_and_push_frame.isra.9 ()
   from /usr/lib64/libgstbase-0.10.so.0
#28 0x00007fffe655f13f in gst_base_parse_chain ()
   from /usr/lib64/libgstbase-0.10.so.0
#29 0x00007fffe7cf97da in gst_pad_push ()
   from /usr/lib64/libgstreamer-0.10.so.0
#30 0x00007fffe2afc26e in gst_multi_queue_loop ()
   from /usr/lib64/gstreamer-0.10/libgstcoreelements.so
#31 0x00007fffe7d20d8c in gst_task_func ()
   from /usr/lib64/libgstreamer-0.10.so.0
#32 0x00007ffff192d288 in g_thread_pool_thread_proxy ()
   from /usr/lib64/libglib-2.0.so.0
#33 0x00007ffff192ca45 in g_thread_proxy () from /usr/lib64/libglib-2.0.so.0
#34 0x00007ffff2d87d96 in start_thread () from /lib64/libpthread.so.0
#35 0x00007ffff47b146d in clone () from /lib64/libc.so.6
Comment 3 Tanktalus 2013-02-04 17:58:38 UTC
Created attachment 337928 [details]
Full backtrace, all threads
Comment 4 Johannes Huber gentoo-dev 2013-06-21 19:03:18 UTC
@kde-stable: Please test if anybody can confirm this with current stable 4.10.3 or upcoming stable 4.10.4 and give feedback.
Comment 5 jim.sublette@gmail.com 2013-06-21 20:22:13 UTC
gstreamer 0.10.36 and dragon 4.10.3 do not crash.  Tested with a movie from dvd and a movie from my camera.
Comment 6 Johannes Huber gentoo-dev 2013-06-21 20:44:27 UTC
Thanks jim.sublette@gmail.com for feedback.
Comment 7 Michael Mair-Keimberger (iamnr3) 2013-06-21 20:54:19 UTC
Tested a few videos with upcoming kde-4.10.4. No problems and no crashes.