Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455282 - dev-libs/libpqxx-4.0.1 with python 3.x - TypeError: 'str' does not support the buffer interface
Summary: dev-libs/libpqxx-4.0.1 with python 3.x - TypeError: 'str' does not support th...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Aaron W. Swenson
Depends on:
Reported: 2013-02-03 13:16 UTC by jannis
Modified: 2013-05-03 10:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,12.54 KB, text/plain)
2013-02-03 13:16 UTC, jannis
emerge --info (einfo,22.70 KB, text/plain)
2013-02-03 13:17 UTC, jannis
python-updater-log.txt (python-updater-log.txt,193.11 KB, text/plain)
2013-02-14 12:13 UTC, jannis

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2013-02-03 13:16:17 UTC
Created attachment 337788 [details]

see build.log
Comment 1 jannis 2013-02-03 13:17:27 UTC
Created attachment 337790 [details]
emerge --info
Comment 2 Aaron W. Swenson gentoo-dev 2013-02-03 13:26:53 UTC
Does switching to Python2 solve the issue?

root@host # eselect python set python2
Comment 3 jannis 2013-02-03 20:07:16 UTC
Yep, solves it; builds fine with python 2.7
Comment 4 Aaron W. Swenson gentoo-dev 2013-02-04 16:04:24 UTC
Try switching back to Python3, run python-updater, then try the emerge again.
Comment 5 Aaron W. Swenson gentoo-dev 2013-02-08 18:59:55 UTC
Seems like a python-updater issue to me and not actually related to libpqxx.
Comment 6 jannis 2013-02-14 12:07:19 UTC
I ran "python-updater -p -v" in the meantime, allowing myself to exclude libreoffice, scribus and geos from the rebuild since they take ages and geos would've pulled an older SLOT of php. One package failed but it was from the pro-audio overlay and needs to be fixed (not compatible with python-3.x yet). The other packages emerged just fine but the error is still the same when I try to emerge libpqxx with python-3.2 set as active version.
Comment 7 jannis 2013-02-14 12:13:42 UTC
Created attachment 338858 [details]

Don't know if it's any help but here is the console log of python-updater and the following merges
Comment 8 Aaron W. Swenson gentoo-dev 2013-05-03 10:39:10 UTC
  03 May 2013; Aaron W. Swenson <> libpqxx-4.0.1.ebuild:
  Inherit python-any-r1 to pull in a Python 2 interpreter. Use sed to fix
  shebangs to call python2 instead of python which could be set to a
  Python 3 interpreter. Fixes bug 455282.