Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455268 - =dev-lisp/sbcl-1.1.3 - WARNING! Some of the contrib modules did not build successfully or pass their self-tests. Failed contribs:" sb-bsd-sockets
Summary: =dev-lisp/sbcl-1.1.3 - WARNING! Some of the contrib modules did not build suc...
Status: RESOLVED DUPLICATE of bug 486552
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Panagiotis Christopoulos (RETIRED)
Depends on:
Reported: 2013-02-03 11:10 UTC by Benjamin Schulz
Modified: 2013-10-14 09:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

buildlog (,387.14 KB, application/zip)
2013-02-03 14:15 UTC, Benjamin Schulz
1.1.3 (,382.31 KB, application/zip)
2013-02-03 14:16 UTC, Benjamin Schulz

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Schulz 2013-02-03 11:10:45 UTC
I tried to emerge sbcl for maxima- With all recent versions (including the stable, keywords and masked packages, sbcl fails with:

 make: Leaving directory `/var/tmp/portage/dev-lisp/sbcl-1.1.3/work/sbcl-1.1.3/contrib/sb-sprof'

WARNING! Some of the contrib modules did not build successfully or pass
their self-tests. Failed contribs:"
 * ERROR: dev-lisp/sbcl-1.1.3 failed (compile phase):
 *   make failed
 * Call stack:
 *, line  93:  Called src_compile
 *   environment, line 2452:  Called die
 * The s

this happened after an emerge -uD world. before, it worked. I was able to install sbcl [1.0.55-r1] before. However, it is now broken. maxima and cantor can apparently not connect to my sbcl library via socket xommunication
Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2013-02-03 11:38:02 UTC
Provide output of `emerge --info` and attach complete build.log here too.
Comment 2 Benjamin Schulz 2013-02-03 13:56:12 UTC
emerge --info
Portage (default/linux/amd64/10.0/desktop/kde, gcc-4.5.4, glibc-2.15-r3, 3.7.1-gentoo x86_64)
System uname: Linux-3.7.1-gentoo-x86_64-Intel-R-_Core-TM-_i5-2520M_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Sun, 03 Feb 2013 09:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo java-overlay sage-on-gentoo
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 Intel-SDP"
CFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/sage-on-gentoo"
USE="64bit X X509 a52 aac aacplus acl acpi afp alsa alstream amd64 analitza archive aspell atmo audio audiofile audioscrobbler autoipd automount avahi avcodec avx berkdb bittorrent bl bluetooth bluray bmp branding bs2b bzip2 cairo canberra cdda cdparanoia cdr cdrdao cdrom cgi chromium clamav clearpasswd cleartype cli clucene colord connection-sharing connman consolekit contrast corefonts cpudetection cracklib crypt cue cups curl cvs cxx cython d3d dbus dc1394 dcc_video declarative demosaic dga dhcp-tools dhcpcd dia dirac directx djvu dot dri drm dshow dts dv dvb dvd dvdnav dvdr dvi dvi2tty dvipdfm dxva2 eap-sim ebook egl emacs emboss enchant encode equalizer ethernet ewf excel exceptions exif faac faad facebook fam fasteap fbosd ffmpeg fftw firefox fits flac flickr fluidsynth font-styles fontconfig fonts foomaticdb fortran fpx ftp fuse g3dvl g711 g722 g7221 g729 gbm gcdmaster gd gdbm gdu geo geonames ggi gif gimp git glamor gles gles1 gles2 glut gmath gme gnome gnome-keyring gnumeric gpg gphoto2 gpm gps graph graphics graphicsmagick graphite graphviz groupwise growl gs gsm gstreamer gtk gtk3 gudev gzip h281 hdaps hdri hostip howl-compat html http hwdb hyperestraier i18n iconv icq icu idn ieee1394 image-cache imagemagick inotify introspection ios ipv6 jack java javascript jbig jingle jpeg jpeg2k kde kdm kerberos kexiv2 keymap kipi konqueror kontact ladspa lame lapack laptop lastfm lastfmfingerprint lastfmradio latex latex3 lcms ldap ldb lensfun libass libcaca libedit libffi libkms libmpeg2 libnotify libproxy libsamplerate libv4l libv4l2 libvisual libxml2 lilo lm_sensors logrotate lyx lzma lzo mad math mathml matplotlib matroska md5sum mdnsresponder-compat meanwhile midi minizip mjpeg mms mmx mmxext mng modemmanager modplug modules mp3 mp4 mpeg mpg123 mplayer msn mudflap multilib multimedia musepack nas ncurses network networkmanager new-clx nfsv3 nfsv4 nfsv41 nls nominatim nptl nss ntfs nut ocr octave offensive ogg ogg123 okular omxil openal opencl opencv openexr opengl openmp openssl openvg openxml opus oscar otr pam pango pci pcmcia pcre pdf pdf-writer pdfimport perl phonon pic plasma plazes plotutils pm-utils png policykit portaudio postscript powersave powertop ppds prelink preview-latex previewer projectm ps pstoedit pstricks pulseaudio pvr pyqt4 python python2 python3 q16 qalculate qmake qt3support qt4 quicktime rar raw rawspeed rcs readline realtime resolvconf rpm rsh rss rtaudio rtc rtf rtmp rtsp samba sbcl scanner schroedinger science sdl sdl-image sensord session sha sha1 sha512 shine shout sid skyhook skype smp sms smtp sna sockets socks socks5 sound speex spell spidermonkey sql sqlite sse sse2 sse3 ssh ssl ssse3 startup-notification subversion svg switcher systeminfo taglib tcpd tdb tex4ht text theora thesaurus thin-splines thinkpad threads thumbnail tiff timezone tk tools transcode truetype twolame type3 udev udisks udisks2 umfpack unicode unzip upekbsapi upnp upower usb uuid v4l vaapi vba vcd vcdx video vlc vlm vocoder volume vorbis vpx wav wavpack webkit webp wicd wifi wimax win32 wma wma-fixed wmf wxwidgets x264 xa xanim xattr xcb xcomposite xetex xft xine xinerama xml xmlpatterns xmp xorg xosd xpm xprint xrandr xrender xscreensaver xterm xv xvid xvmc yahoo zip zlib zvbi" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel vesa i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 3 Benjamin Schulz 2013-02-03 14:15:01 UTC
Created attachment 337800 [details]

Comment 4 Benjamin Schulz 2013-02-03 14:16:46 UTC
Created attachment 337802 [details]

buildlog for 1.1.3 in zip format
Comment 5 Benjamin Schulz 2013-02-03 14:18:19 UTC
the build logs are in compressed zip format. In could not upload them uncompressed and was too lazy to cut them manually....
Comment 6 Rafał Mużyło 2013-02-03 16:03:46 UTC
Compressed logs are better than random snippets, but why zip ?

Anyway, in attachment 337800 [details], the problem happens at line 82746, but the lisp backtrace is it quite large and you need to know lisp for it to make sense.

All I see is that it's doing something with and fails.
Comment 7 Benjamin Schulz 2013-02-05 16:16:54 UTC
Perhaps i should add that i tried to emerge maxima  all the different lisps available. With the exception of sbcl they all compile. However wxmaxima which connects to maxima through sockets fails with all these lisps to communicate via sockets. So it may be that sbcl just fails because the ebuild tests this stuff after compilation. All i know is that the error started after an emerge -ud world. So perhaps this error is due to a different package on which all lisps depend?
Comment 8 fssirc 2013-08-26 02:38:52 UTC
Actually, it might be because of some mandatory access control system installed, like RBAC or selinux. I got exactly the same errors when I had selinux enabled. Only when I turned it off, had I been able to manage to compile it, because it was denying name_connect for tcp_socket opened by portage_sandbox_t.
Comment 9 Benjamin Schulz 2013-09-22 09:55:19 UTC
Hi, Unfortunately, I do not have selinux or rbac installed. I'm just using the normal gentoo system
Comment 10 Benjamin Schulz 2013-10-11 17:26:55 UTC
I have now recompiled my entire system on ~amd64, unstable. (Before, my system was amd64, stable).

Now sbcl works and programs like wxmaxima can use the sockets module to establish a connection to maxima.

However, I do not know which library prevented this on my earlier stable amd64 system.
Comment 11 Andrey Grozin gentoo-dev 2013-10-14 09:03:03 UTC

*** This bug has been marked as a duplicate of bug 486552 ***