Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455234 - kmix: dbuscontrolwrapper.cpp:(.text+0x169): undefined reference to `vtable for DBusControlWrapper'
Summary: kmix: dbuscontrolwrapper.cpp:(.text+0x169): undefined reference to `vtable fo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-03 07:05 UTC by Igor Franchuk
Modified: 2013-03-09 21:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Kmix compilation error, build log (build.log,282.40 KB, text/plain)
2013-02-03 07:06 UTC, Igor Franchuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Franchuk 2013-02-03 07:05:13 UTC
Kmix 4.9.3 to Kmix 4.9.5 fails with 

CMakeFiles/kdeinit_kmixctrl.dir/dbus/dbuscontrolwrapper.o: In function `DBusControlWrapper::DBusControlWrapper(std::tr1::shared_ptr<MixDevice>, QString const&)':
dbuscontrolwrapper.cpp:(.text+0x30): undefined reference to `vtable for DBusControlWrapper'
CMakeFiles/kdeinit_kmixctrl.dir/dbus/dbuscontrolwrapper.o: In function `DBusControlWrapper::~DBusControlWrapper()':
dbuscontrolwrapper.cpp:(.text+0x169): undefined reference to `vtable for DBusControlWrapper'
collect2: ld returned 1 exit status
make[2]: *** [lib/libkdeinit4_kmixctrl.so] Error 1

with automake 1.11.1

Reproducible: Always

Steps to Reproduce:
1.Upgrade to 4.9.5 from 4.9.3 with automake 1.11.1




It looks like Kmix 4.9.5 ebuild should depend on automake 1.11.6
After upgrating automke from 1.11.1 to 1.11.6 the problem disappeared.
Comment 1 Igor Franchuk 2013-02-03 07:06:26 UTC
Created attachment 337746 [details]
Kmix compilation error, build log

Kmix log file
Comment 2 Andreas K. Hüttel gentoo-dev 2013-03-09 21:38:48 UTC
Automake 1.11.6 is newest stable, so we can close this.