Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 45508 - mod_php killed during emerge - missing operand
Summary: mod_php killed during emerge - missing operand
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC Linux
: High major (vote)
Assignee: PHP Bugs
Depends on:
Reported: 2004-03-23 09:06 UTC by Steve
Modified: 2004-03-29 21:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Steve 2004-03-23 09:06:11 UTC
Here's the error message...

{standard input}: Assembler messages:
{standard input}:12560: Warning: end of file not at end of a line; newline inserted
{standard input}:13218: Error: missing operand
{standard input}:13218: Error: missing operand
gcc: Internal error: Killed (program cc1)
Please submit a full bug report.
See <URL:> for instructions.
make: *** [ext/pcre/pcrelib/pcre.lo] Error 1
make: *** Waiting for unfinished jobs....

!!! ERROR: dev-php/mod_php-4.3.4-r4 failed.
!!! Function php-sapi_src_compile, Line 466, Exitcode 2
!!! compile problem

GCC is up to date. I had tried unsuccessfully to install mod_php previously. The first time, I cancelled it. The second time, I got the same error as this time.

Reproducible: Always
Steps to Reproduce:
1. emerge mod_php
Actual Results:  
emerge died, with the error message above.

Expected Results:  
Installed mod_php.

I have apache2 installed.
Comment 1 rob holland (RETIRED) gentoo-dev 2004-03-23 09:17:48 UTC
no idea wtf this was assigned to keychain@ :/
Comment 2 SpanKY gentoo-dev 2004-03-24 12:12:22 UTC
what if you emerge & run the cpuburn app ?
does your box die ?
what kernel version you using ? how much ram you got ? does dmesg have anything to say ?
Comment 3 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-03-24 15:09:57 UTC
'emerge info' output
and MORE of the error output.
Comment 4 Stuart Herbert (RETIRED) gentoo-dev 2004-03-28 16:40:18 UTC
Acknowleding the bug (house keeping, don't mind me)
Comment 5 Stuart Herbert (RETIRED) gentoo-dev 2004-03-29 11:11:06 UTC
Hi there,

We need more information before we can help you.  We need you to paste (or attach) more of the output from when the fault happened.  The output you've provided doesn't tell us anything.  We also need you to attach the output of 'emerge info' to your bug.

Thank you,
Comment 6 Stuart Herbert (RETIRED) gentoo-dev 2004-03-29 21:44:41 UTC
Closing bug