Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 455072 - net-dns/pdns-3.1 with USE="sqlite3" - checking for SQLITE3... configure: error: +Could not find sqlite3
Summary: net-dns/pdns-3.1 with USE="sqlite3" - checking for SQLITE3... configure: erro...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Sven Wegener
Depends on:
Reported: 2013-02-01 23:53 UTC by Marios Andreopoulos
Modified: 2014-03-10 21:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,10.94 KB, text/plain)
2013-02-01 23:53 UTC, Marios Andreopoulos
config.log.gz (config.log.gz,24.27 KB, application/x-gzip)
2013-02-02 15:04 UTC, Marios Andreopoulos
pdns-3.1.ebuild.patch (pdns-3.1.ebuild.patch,595 bytes, patch)
2013-05-29 19:48 UTC, Jan Pobrislo
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marios Andreopoulos 2013-02-01 23:53:10 UTC
When I try to emerge net-dns/pdns-3.1 with the sqlite3 USE flag, the emerge fails during the configure phase because it can't find the sqlite3.

I am on ~amd64. This happens to both hardened and non-hardened systems and is irrelevant of mysql and sqlite USE flags.

The actual error is:
checking for SQLITE3... configure: error: +Could not find sqlite3

I tried to fix the problem before reporting here but couldn't find a relevant ./configure switch. :(

# emerge --info '=net-dns/pdns-3.1'
Portage (hardened/linux/amd64, gcc-4.6.3, glibc-2.16.0, 3.7.4-hardened-Alfred x86_64)
                         System Settings
System uname: Linux-3.7.4-hardened-Alfred-x86_64-Intel-R-_Pentium-R-_CPU_G840_@_2.80GHz-with-gentoo-2.2
KiB Mem:     8069572 total,   1691112 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sat, 26 Jan 2013 17:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x-personal
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=native -mtune=native"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -mtune=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl acpi alsa amd64 apache2 archive avahi avi bash-completion berkdb btrfs bzip2 cli consolekit cracklib crypt cryptsetup cups cxx dbus dirac dlna dri drm ebook exif exiv2 fat ffmpeg fontconfig foomatic-db freetype ftp fuse gallium gdbm geolocation git gmp gpm gpu gstreamer hardened iconv id3 id3tag imagemagick imlib ipv6 ithreads jpeg justify kerberos kpathsea lame laptop latex libass libnotify lm_sensors logrotate lvm mad matroska mbox mdadm memlimit mhash mime mmx mmxext modules mp3 mp4 mpeg mpeg2 mplayer mtp mudflap multilib mysql ncurses network nfs nls nptl ntfs ogg ogm opencl openmp pam pax_kernel pcre plotutils png posix ppds private-headers ps pulseaudio rdp readline recode reiserfs remote reports rrdtool session smp smtp snmp sockets socks5 sox spell sqlite sqlite3 srt sse sse2 sse3 sse4 sse4_1 sse4_2 ssl ssse3 stats stream tcpd theora threads thumbnail truetype udev unicode upnp urandom usb v4l v4l2 vhosts vorbis vpx webdav webinterface wifi wma x264 xattr xfs xmp xvid xvmc zeroconf zip zlib" 
ALSA_CARDS="intel8x0 intel8x0m hda-intel usb-audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_http proxy_balancer unixd socache_shmcb proxy_fcgi" APACHE2_MPMS="worker" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin 
garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="el gr en_GB en el en_US el_GR" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="intel v4l vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

# emerge -pqv '=net-dns/pdns-3.1'
[ebuild  N    ] net-dns/pdns-3.1  USE="mysql sqlite sqlite3 -debug -doc -ldap -opendbx -postgres -static"

Reproducible: Always
Comment 1 Marios Andreopoulos 2013-02-01 23:53:45 UTC
Created attachment 337636 [details]
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-02-02 08:15:30 UTC
> !!! Please attach the following file when seeking support:
> !!! /var/tmp/portage/net-dns/pdns-3.1/work/pdns-3.1/config.log

Could you attach that file a well?
Comment 3 Marios Andreopoulos 2013-02-02 15:04:47 UTC
Created attachment 337674 [details]

Here it is!

Sorry I ommited it. The relevant message was before the error message (red asterisks) and somehow it escaped me...
Comment 4 Jan Pobrislo 2013-05-29 17:43:49 UTC
It's problem with configure script not autodetecting pkg-config.
When I run PKG_CONFIG=/usr/bin/pkg-config ./configure ... manually it finds all libraries successfully.
Comment 5 Jan Pobrislo 2013-05-29 19:48:04 UTC
Created attachment 349594 [details, diff]
Comment 6 Sven Wegener gentoo-dev 2014-03-10 21:40:13 UTC
with pdns-3.3.1 going stable, this bug should be fixed.