Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 454808 - net-libs/webkit-gtk-1.10.2-r300 - File "./Tools/Scripts/run-gtk-tests", line 168: Could not start accessibility bus, so skipping TestWebKitAccessibility
Summary: net-libs/webkit-gtk-1.10.2-r300 - File "./Tools/Scripts/run-gtk-tests", line ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-31 10:48 UTC by Markus Oehme
Modified: 2013-09-03 18:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build-log (compressed with xz) (net-libs:webkit-gtk-1.10.2-r300:20130131-074033.log.xz,214.90 KB, application/octet-stream)
2013-01-31 10:48 UTC, Markus Oehme
Details
emerge --info (info.txt,6.26 KB, text/plain)
2013-01-31 10:48 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2013-01-31 10:48:06 UTC
Created attachment 337430 [details]
build-log (compressed with xz)

I see the following error on my hardened ~amd64 box with gcc-4.7.2 and python-3.2 when running the test-suite of webkit-gtk.

make  check-local
make[2]: Entering directory `/var/tmp/portage/net-libs/webkit-gtk-1.10.2-r300/work/webkitgtk-1.10.2'
./Tools/Scripts/run-gtk-tests
  File "./Tools/Scripts/run-gtk-tests", line 168
    print "Could not start accessibility bus, so skipping TestWebKitAccessibility"
                                                                                 ^
SyntaxError: invalid syntax
make[2]: *** [check-local] Error 1
Comment 1 Markus Oehme 2013-01-31 10:48:57 UTC
Created attachment 337432 [details]
emerge --info
Comment 2 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-31 19:56:12 UTC
Might be a duplicate of bug #454772, please check.
Comment 3 Markus Oehme 2013-01-31 22:03:52 UTC
In bug #454772 the issue is a failed import in line 26 here it's a syntax error in line 168. I don't think that this has the same cause. For reference: I have pygobject:3 installed.
Comment 4 Pacho Ramos gentoo-dev 2013-08-24 13:23:50 UTC
Please test with 2.0.4
Comment 5 Markus Oehme 2013-09-03 09:07:21 UTC
(In reply to Pacho Ramos from comment #4)
> Please test with 2.0.4

2.0.4 runs tests fine for me, but at the end of the test phase, there is the following warning in the build log.


make  check-local
make[2]: Entering directory `/var/tmp/portage/net-libs/webkit-gtk-2.0.4/work/webkitgtk-2.0.4'
./Tools/Scripts/run-gtk-tests --timeout=-1
***
*** Warning: jhbuild environment not present. Run update-webkitgtk-libs before build-webkit to ensure proper testing.
***
Comment 6 Pacho Ramos gentoo-dev 2013-09-03 18:18:08 UTC
Thanks for feedback

Regarding the warning, I am unsure it's valid for us: I have checked if it's run in any other distributions and it's not, I have also unable to find it in Tools/Scripts :/