Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 454560 - x11-drivers/nvidia-drivers-313.18 with kernel 3.7.4 - NVRM: This PCI I/O region assigned to your NVIDIA device is invalid: BAR1 is 0M @ 0x0 (PCI:0000:03:00.0)
Summary: x11-drivers/nvidia-drivers-313.18 with kernel 3.7.4 - NVRM: This PCI I/O regi...
Status: RESOLVED DUPLICATE of bug 447566
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL: https://bugzilla.kernel.org/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-29 17:43 UTC by Roman Gruber
Modified: 2013-04-04 15:39 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_454560.txt,8.51 KB, text/plain)
2013-01-29 17:46 UTC, Roman Gruber
Details
kernel 3.3.8 working /var/log/messages (file_454560.txt,103.03 KB, text/plain)
2013-01-29 17:48 UTC, Roman Gruber
Details
kernel 3.7.4-gentoo and x11-drivers/nvidia-drivers-313.18 not working (file_454560.txt,120.53 KB, text/plain)
2013-01-29 17:51 UTC, Roman Gruber
Details
gentoo 3.7.4 kernel config (file_454560.txt,80.93 KB, text/plain)
2013-01-29 17:53 UTC, Roman Gruber
Details
3.3.8 kernel config (the working kernel) (file_454560.txt,80.92 KB, text/plain)
2013-01-29 17:58 UTC, Roman Gruber
Details
lspci kernel 3.3.8 working (file_454560.txt,16.58 KB, text/plain)
2013-01-29 18:05 UTC, Roman Gruber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Gruber 2013-01-29 17:43:29 UTC
Latest working gentoo-sources: Linux localhost 3.3.8-gentoo_02_Dec_2012
Lastest working nvidia-drivers: 310.19


This gentoo-sources were removed from portage tree, thats why i am forced to upgrade to a newer version, else any bug reports commited will be invalid, because of outdated gentoo-sources!

Affected gentoo-sources:   (3.6.11), (3.7.4), 3.4.X

Problem:
--------

Memory Bar allocation of these gentoo-sources breaks the reserved area of the graphic card form nvidia which causes non functioning x server and a /var/log/message log which is constantly filled up with:

Jan 29 18:12:50 localhost dbus[3289]: [system] Successfully activated service 'org.freedesktop.ConsoleKit'
Jan 29 18:12:50 localhost login[4110]: ROOT LOGIN  on '/dev/tty1'
Jan 29 18:14:08 localhost dbus[3289]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.6" (uid=0 pid=10359 comm="/usr/sbin/gdm-binary ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.7" (uid=0 pid=10361 comm="/usr/libexec/gdm-simple-slave --display-id /org/gn")
Jan 29 18:14:08 localhost acpid: client connected from 10366[0:0]
Jan 29 18:14:08 localhost acpid: 1 client rule loaded
Jan 29 18:14:08 localhost kernel: [  110.164043] nvidia: module license 'NVIDIA' taints kernel.
Jan 29 18:14:08 localhost kernel: [  110.164047] Disabling lock debugging due to kernel taint
Jan 29 18:14:08 localhost kernel: [  110.181039] NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
Jan 29 18:14:08 localhost kernel: [  110.181039] NVRM: BAR1 is 0M @ 0x0 (PCI:0000:03:00.0)
Jan 29 18:14:08 localhost kernel: [  110.181043] NVRM: The system BIOS may have misconfigured your GPU.
Jan 29 18:14:08 localhost kernel: [  110.181047] nvidia: probe of 0000:03:00.0 failed with error -1
Jan 29 18:14:08 localhost kernel: [  110.181060] NVRM: The NVIDIA probe routine failed for 1 device(s).
Jan 29 18:14:08 localhost kernel: [  110.181062] NVRM: None of the NVIDIA graphics adapters were initialized!
Jan 29 18:14:08 localhost gdm-simple-slave[10361]: WARNING: Child process 10366 was already dead.
Jan 29 18:14:08 localhost gdm-simple-slave[10361]: GLib-GObject-CRITICAL: g_object_ref: assertion `object->ref_count > 0' failed
Jan 29 18:14:08 localhost gdm-simple-slave[10361]: GLib-GObject-CRITICAL: g_object_unref: assertion `object->ref_count > 0' failed
Jan 29 18:14:08 localhost gdm-binary[10359]: WARNING: GdmDisplay: display lasted 0,170444 seconds
Jan 29 18:14:08 localhost gdm-binary[10359]: WARNING: GdmDisplay: display lasted 0,171860 seconds
Jan 29 18:14:08 localhost dbus[3289]: [system] Rejected send message, 1 matched rules; type="method_call", sender=":1.6" (uid=0 pid=10359 comm="/usr/sbin/gdm-binary ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination=":1.8" (uid=0 pid=10376 comm="/usr/libexec/gdm-simple-slave --display-id /org/gn")
Jan 29 18:14:08 localhost acpid: client 10366[0:0] has disconnected
Jan 29 18:14:08 localhost acpid: client connected from 10380[0:0]
Jan 29 18:14:08 localhost acpid: 1 client rule loaded
Jan 29 18:14:08 localhost kernel: [  110.271277] NVRM: This PCI I/O region assigned to your NVIDIA device is invalid:
Jan 29 18:14:08 localhost kernel: [  110.271277] NVRM: BAR1 is 0M @ 0x0 (PCI:0000:03:00.0)
Jan 29 18:14:08 localhost kernel: [  110.271282] NVRM: The system BIOS may have misconfigured your GPU.
Jan 29 18:14:08 localhost kernel: [  110.271286] nvidia: probe of 0000:03:00.0 failed with error -1

localhost roman # lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 03)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 04)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 04)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 04)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 04)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 04)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 04)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 04)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 04)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 04)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 04)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 04)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f4)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M-E) LPC Interface Controller (rev 04)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 04)
01:00.0 PCI bridge: NVIDIA Corporation Device 01b3 (rev a3)
02:00.0 PCI bridge: NVIDIA Corporation Device 01b3 (rev a3)
02:01.0 PCI bridge: NVIDIA Corporation Device 01b3 (rev a3)
03:00.0 VGA compatible controller: NVIDIA Corporation G94 [GeForce 9800M GTS] (rev a1)
05:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 13)
06:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN [Kedron] Network Connection (rev 61)
0a:00.0 SATA controller: JMicron Technology Corp. JMB360 AHCI Controller (rev 02)
0b:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
0b:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
0b:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
0b:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
0b:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)

----

lspci -v => for the gpu => working entry for current 3.3.8 gentoo -sources

03:00.0 VGA compatible controller: NVIDIA Corporation G94 [GeForce 9800M GTS] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 2015
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at fa000000 (64-bit, non-prefetchable) [size=32M]
	I/O ports at 9c00 [size=128]
	[virtual] Expansion ROM at fdd80000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [b4] Vendor Specific Information: Len=14 <?>
	Capabilities: [100] Virtual Channel
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
	Kernel driver in use: nvidia



for the non working recent gentoo sources, not sure if htere is invalid but the second bar is wrong initalized and it says invalid or something like that. look s like this...


03:00.0 VGA compatible controller: NVIDIA Corporation G94 [GeForce 9800M GTS] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 2015
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
	Memory at <invalid> (64-bit, prefetchable) [size=256M]
	Memory at fa000000 (64-bit, non-prefetchable) [size=32M]
	I/O ports at 9c00 [size=128]
	[virtual] Expansion ROM at fdd80000 [disabled] [size=512K]
	Capabilities: [60] Power Management version 3
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [78] Express Endpoint, MSI 00
	Capabilities: [b4] Vendor Specific Information: Len=14 <?>
	Capabilities: [100] Virtual Channel
	Capabilities: [128] Power Budgeting <?>
	Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>

---

REading on google there may be a way to set this area with setpci.

as several kernel worked in teh past, and even the working nvidia drivers dont work anymore with this newer kernel, its a kernel bug.

Please if I should submit a bug report somewhere else pls post me the relevant links and I do it.

Reproducible: Always

Steps to Reproduce:
1. upgrade kernel from gentoo-sources 3.3.8 to newer e.g. non working 3.7.4 3.7.3 3.7.2 3.5.x 3.4.x
2. reboot new kernel, emerge nvidia-drivers
3. launch gdm, via command line, 
4. /var/log/messages flooded from nvidia-drivers NVRM thing with bar1 wrong set.

BTW. 3.3.8 gentoo-sources works fine with recent all updated box. I just dislike using a kernel which was removed from the portage tree.
Actual Results:  
X server cant start because kernel sets the memory bars wrong for my gpu.



Expected Results:  
X server works, non flooded /var/log/messages
memory bars right set for device 3: nivida 9800m GTS
Comment 1 Roman Gruber 2013-01-29 17:46:09 UTC
Created attachment 337252 [details]
emerge --info
Comment 2 Roman Gruber 2013-01-29 17:48:25 UTC
Created attachment 337254 [details]
kernel 3.3.8 working /var/log/messages
Comment 3 Roman Gruber 2013-01-29 17:51:28 UTC
Created attachment 337256 [details]
kernel  3.7.4-gentoo and x11-drivers/nvidia-drivers-313.18 not working

nvidia-driver 313.18 and 310.19(which works with 3.3.8) doesnt works ...
Comment 4 Roman Gruber 2013-01-29 17:53:12 UTC
Created attachment 337258 [details]
gentoo 3.7.4 kernel config
Comment 5 Roman Gruber 2013-01-29 17:58:58 UTC
Created attachment 337260 [details]
3.3.8 kernel config (the working kernel)
Comment 6 Roman Gruber 2013-01-29 18:05:33 UTC
Created attachment 337262 [details]
lspci kernel 3.3.8 working
Comment 7 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-29 18:38:27 UTC
Importance is to be set by the maintainers.

> 3.6.11

I run =sys-kernel/gentoo-sources-3.6.11 with =x11-drivers/nvidia-drivers-313.18 and I can't reproduce this; so, this is specific to your hardware configuration.

> Jan 29 18:14:08 localhost kernel: [  110.181043] NVRM: The system BIOS may have misconfigured your GPU.

This is the first occurence of something that tells us what may have happened, this one is particularly interesting as this would indicate your BIOS does something incorrectly; suggestion: Can you try upgrading your BIOS?

> REading on google there may be a way to set this area with setpci.

Do you have a link to this, it can put some light on the details this involves.

> as several kernel worked in teh past, and even the working nvidia drivers dont work anymore with this newer kernel, its a kernel bug.

I can write "as several nvidia drivers worked in the past, and even the working kernels dont work anymore with this newer nvidia driver, its a nvidia bug" as well, this doesn't really mean anything.

All we know is that there is a high chance that this is a bug in your BIOS, this would mean the BIOS developers have the main responsibility to fix this if that's the case. If we put BIOS out of the view (because it's not always easy to get them to do that), then you can still wonder whether the bug lies with Nvidia or the kernel. And since Nvidia is proprietary we can't really tell this soon.

Though, setpci works so it seems a quirk fix from the kernel is possible.

> Please if I should submit a bug report somewhere else pls post me the relevant links and I do it.

1) Can you try upgrading your BIOS?
2) Can you try to contact your BIOS developers about this?
3) Could you link to that setpci trick you have found?
4) Could you report this at http://bugzilla.kernel.org and comment here with a link to that bug?
5) If they won't do it, can you try to contact Nvidia about this?
Comment 8 Roman Gruber 2013-01-29 19:55:26 UTC
1) Can you try upgrading your BIOS?
2) Can you try to contact your BIOS developers about this?


No, its an ASUSG70SG Laptop, 3 Years old.
Asus dont support GNU LINUX.



3) Could you link to that setpci trick you have found?

e.g like that is the problem..

http://www.nvnews.net/vbulletin/showthread.php?t=42906
Region 1: Memory at <ignored> (64-bit, prefetchable)

well what i have written down and treid from google, but is not working. and what was always suggested something like that. and i changed it so it fits my chard, my card is at 03.00.0 instead of 01.00.0

setpci -s 03.00.0 BASE_ADDRESS_0=0x0xf2000000

honestly i have a knowledge about hex numbers.

but if its now BASE_ADDRESS_1 or 0 or something else ...

i only know ihave to set the range to 0xf2000000 as you can see on the attachmetns i made, becasue Region1 is ignored.


4) Could you report this at http://bugzilla.kernel.org and comment here with a link to that bug?

OKAY, sure will do.


5) If they won't do it, can you try to contact Nvidia about this?

well thats the issue.

i read their forum and they hardly fix anything.


------------

Personal opinion:

In my understandings the Bios should set the memory regions and the IRQ and such stuff.
And the kernel overwrites this areas or changes these settings.

There are userland tools or kernel settings to get over the "borked" bios. But thats a matter of defintion whats "borked" and whats not.


Thank you for your response.

I have read that linux has diferent memory mappings and thats the problem.

as some memoery mappings overwrite block(which seems the case here) "used" areas.
Comment 9 Roman Gruber 2013-01-29 20:30:06 UTC
kernel bug

https://bugzilla.kernel.org/show_bug.cgi?id=53181
Comment 10 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-29 21:13:40 UTC
Thank you for reporting upstream.

> setpci -s 03.00.0 BASE_ADDRESS_0=0x0xf2000000

03.00.0 should be 03:00.0 according to `setpci --help`'s listed formats.

0x0xf2000000 should be 0xf2000000, you had 0x twice.

Also, the _0 behind BASE_ADDRESS might have to be _1 or something else. You can figure out which region is set incorrectly by executing `lspci -vv` and looking for your graphics card there.

So, it should be something along the lines of

> setpci -s 03:00.0 BASE_ADDRESS_1=0xf2000000
Comment 12 Jeroen Roovers gentoo-dev 2013-04-04 15:39:10 UTC

*** This bug has been marked as a duplicate of bug 447566 ***