Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 4544 - sandbox locks up
Summary: sandbox locks up
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2002-07-04 14:47 UTC by robbin bonthond
Modified: 2011-10-30 22:20 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description robbin bonthond 2002-07-04 14:47:38 UTC
First off all, thank you all for gentoo, i really like it ! 
This morning (04/07/02) I tried to emerge KDE-3.0.2. After doing "emerge 
--clean rsync" at 07:50 I did "emerge -u kde", and went to work. When I got 
back from work my system had crashed. That crash wrecked my XFS partitions. By 
using my portage install CD I used xfs_repair to get the partition working 
again, however I lost some clusters and portage (2.0.9) got broken. my 
/var/cache directory appears to be fine (found nothing in /lost+found). 
So i used /usr/portage/sys-apps/portage/files/portage-rescue-1.8.19.tbz2 to get 
portage working again. This worked (had to modify make.conf to work with 
current mirror setup). However, when i tried to emerge portage-2.0.9 back, 
emerge locked up. It was was sandbox that took 100% cpu usage and appeard to be 
in an endless-loop. Removed /etc/, touched it back. Found out I 
had to change FEATURE="sandbox" to FEATURE="" in /etc/make.globals. Managed to 
get portage 2.0.9 installed again. Copied the ._cfg make files to 
/etc/make.conf and /etc/make.globals.  
Tried emerge portage again (paranoia is good ;]), but again the sandbox locked 
up. Disabled the FEATURE setting again and emerge works ... but i assume the 
FEATURE="sandbox" should be implace, so ... any ideas ? 
btw, been using gentoo since rc6 ... been upgrading weekly since then... how do  
i find out what my current gentoo version is ?
Comment 1 robbin bonthond 2002-07-04 16:42:55 UTC
fixed it ... removed /tmp/sandboxpids.tmp ... portage now works with 
thanks anyway ;]