Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 45436 - laptop hangs when pcmcia card (wireless NIC) inserted
Summary: laptop hangs when pcmcia card (wireless NIC) inserted
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Mobile Herd (OBSOLETE)
Depends on:
Blocks: 68964
  Show dependency tree
Reported: 2004-03-22 14:09 UTC by thegarbageman
Modified: 2004-12-29 06:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description thegarbageman 2004-03-22 14:09:41 UTC
When I insert my DWL-650 (rev I2) Dlink wireless adapter into the PCMCIA slot, the computer hangs, and disrupts the display.  After that, powering down is the only option.

Reproducible: Always
Steps to Reproduce:
1. Insert DWL-650 card

Actual Results:  
System hang.  No log output.  Must power down laptop.  Also, display shows 
vertical lines. 

Expected Results:  
Insert of device, eth1/wlan0 

(PCMCIA not in kernel) 
(Wireless LAN enabled, but no drivers) 
DWL-650 (Rev.: I2) wireless LAN adapter 
ENE CB1410 Cardbus controller 
on a HP Pavillion zt1170 laptop 
If the card is already inserted on boot, the system hangs when pcmcia is 
started.  Otherwise, it waits until the card is inserted.  The "link" LED 
lights at this time. 
Any help is appreciated.
Comment 1 thegarbageman 2004-03-23 06:00:36 UTC
I tried a US Robotics wireless adapter card with the same results.  Afterwards, I tried using the PCMCIA kernel module instead of the pcmcia-cs package.  That worked well.  I would rather use the standalone tree, if possible.  While I enabled kernel PCMCIA and wireless support, I did not select any wireless kernel drivers.
Comment 2 Peter Johanson (RETIRED) gentoo-dev 2004-03-29 20:28:27 UTC
Often this is a result of autoprobing touching some sensitive areas in memory. Try removing some of the ranges from the "include memory" lines found in /etc/pcmcia/config.opts and see if this helps. 
Comment 3 thegarbageman 2004-03-30 09:34:01 UTC
I will try that, thank you.
I must say I am reluctant.  I don't like screwing around with settings I don't understand.  If that memory is "sensitive" (?), why do the kernel PCMCIA modules work with the same settings?
It seems to me even if removing the memory ranges proves successful, this is still a bug - whether it's a problem with the Gentoo installation guide, the pcmcia-cs package, or something else entirely.
I will try removing memory ranges from the file you mentioned, but I would think a default installation should just work.
Thanks again.  I appreciate the contribution Gentoo makes to the OS community.
Comment 4 Doug Goldstein (RETIRED) gentoo-dev 2004-09-22 09:41:14 UTC
What kind of laptop? there's known issues with Dells and there are notes in the configuration file that address this.
Comment 5 Henrik Brix Andersen 2004-11-01 05:32:57 UTC
This bug report is awaiting feedback from the reporter.
Comment 6 Henrik Brix Andersen 2004-12-29 06:18:34 UTC
Closing due to lack of feedback.