Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 454306 - sys-apps/portage-2.1.11.50: openssl:0.9.8 is installed but libssl.so.0.9.8 and libcrypto.so.0.9.8 are preserved
Summary: sys-apps/portage-2.1.11.50: openssl:0.9.8 is installed but libssl.so.0.9.8 an...
Status: RESOLVED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: preserve-libs
  Show dependency tree
 
Reported: 2013-01-27 13:17 UTC by Peter Asplund
Modified: 2013-02-09 22:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Asplund 2013-01-27 13:17:10 UTC
This problem has been around for quite a long time on ~amd64 (not sure about the other platforms).

net-misc/dropbox is listed as needing emerge via @preserved-rebuild no matter how many times I run it

>>> package: dev-libs/openssl-1.0.0a-r3
 *  - /usr/lib64/libssl.so.0.9.8
 *      used by /opt/dropbox/dropbox (net-misc/dropbox-1.4.23)
 *      used by /opt/dropbox/library.zip (net-misc/dropbox-1.4.23)
 *  - /usr/lib64/libcrypto.so.0.9.8
 *      used by /opt/dropbox/dropbox (net-misc/dropbox-1.4.23)
 *      used by /opt/dropbox/library.zip (net-misc/dropbox-1.4.23)

root@skare$ emerge --info
Portage 2.1.11.50 (default/linux/amd64/10.0/desktop/gnome, gcc-4.6.3, glibc-2.16.0, 3.7.1-gentoo x86_64)
=================================================================
System uname: Linux-3.7.1-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.2
KiB Mem:    12306164 total,   5675936 free
KiB Swap:    2072380 total,   2063292 free
Timestamp of tree: Sun, 27 Jan 2013 10:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p42
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/ccache:          3.1.9
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.1
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo x11 multimedia qt sunrise aluco gamerlay AzP
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=9 --load-average=19 --keep-going"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://trumpetti.atm.tut.fi/gentoo/ http://ftp.ntua.gr/pub/linux/gentoo/ ftp://ftp.linux.ee/pub/gentoo/distfiles/ http://ftp.uoi.gr/mirror/OS/gentoo/"
LANG="en_EN.UTF-8"
LDFLAGS="-Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/multimedia /var/lib/layman/qt /var/lib/layman/sunrise /var/lib/layman/aluco /var/lib/layman/gamerlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="32bit 3dnow 3dnowext 64bit S3TC X a52 aac aalib acl acpi alsa amazon amd64 amr amrnb amrwb apng asf aspell autoipd avahi avi bash-completion bidi binary-drivers bineditor bluetooth bookmarks branding bzip2 cairo ccache cdda cdr cg cgi cleartype cli clutter cmake colord consolekit cover coverart cracklib crypt css cue cups curl custom-optimization cxx daap dbus dconf debugger device-mapper devil dga dirac divx dmx dns dri dts dvd dvdr dvdread emboss encode evo exif fakevim fam fastcgi fat fbcon ffmpeg firefox flac fluidsynth fontconfig fortran freeimage ftp fuse g3dvl gaim gd gdbm gdu gflags ggi gif git glamor glib glut gmail gmailtimestamps gmedia gnome gnome-keyring gnome-online-accounts gnutls gpm gstreamer gtk gtk2 gtk3 gtkhtml gvim gzip h224 h281 h323 howl-compat hpijs iconv icq icu idn imap inotify introspection iphone ipod jabber java java6 jingle jpeg jpeg2k kde kdrive lame lcms ldap libnotify libsexy libssh2 libv4l libv4l2 lm_sensors mad madwifi mbox md5sum mdnsresponder-compat mh midi mikmod mime minizip mmx mmxext mng moc mod modplug modules mozembed mozilla moznocompose moznoirc moznomail moznoroaming mozsha1 mozsvg mp2 mp3 mp4 mp4live mpeg msn mudflap multilib multimedia musepack musicbrainz nas nautilus ncurses nemesi new-hpcups nls nptl nsplugin ntfs ntfsprogs nx ofa ogg openal opencore-amr opengl openmp openssl opensslcrypt optimization pam pango pcntl pcre pdf pdflib perl php pidgin pipechan png pnm policykit pop ppds private-headers pulseaudio pvr python python3 qml qt3support qt4 qtscript quicktime radio raw rdesktop readline realmedia reiser4 reiserfs rtc s3tc samba sasl schroedinger scintilla sdl secure-delete session sid sip sndfile socialweb sockets spell sql sqlite srt sse sse2 sse4.1 sse4.2 ssh ssl ssse3 startup-notification subtitles subversion suid svg tcpd telepathy teletext tga theora threads tiff transcode truetype udev udisks unicode upnp upower usb v4l v4l2 vaapi valgrind vdpau video videos vim vim-pager vim-syntax vim-with-x vorbis vte wav wavpack webdav webdav-neon webdav-serf webkit wifi wma wma-fixed wmf wmp wxwidgets x264 xanim xcb xcomposite xdmcp xext xfs xine xinerama xml xulrunner xv xvid xvmc zeroconf zip zlib zoran" ALSA_CARDS="emu10k1 hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="openssl" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en sv" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="i386 arm x86_64" QEMU_USER_TARGETS="i386 arm x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always

Steps to Reproduce:
I think this happened after an update to openssl (or perhaps libcrypto).
Actual Results:  
net-misc/dropbox is listed as needing a rebuild even after rebuilding it.

Expected Results:  
net-misc/dropbox is not listed as packages needing a rebuild after running 'emerge @preserved-rebuild'
Comment 1 Naohiro Aota gentoo-dev 2013-01-29 04:03:31 UTC
Don't you have openssl:0.9.8 installed? dropbox-1.4.23 is RDEPENDing on dev-libs/openssl:0.9.8, so that /usr/lib64/libssl.so.0.9.8 should not even be preserved-rebuild target.
Comment 2 Peter Asplund 2013-02-02 17:09:05 UTC
I seem to have both 0.9.8x and 1.0.1c installed.

root@skare$ eix openssl -I
[I] dev-libs/openssl
     Available versions:  
     (0.9.8) 0.9.8u 0.9.8v 0.9.8w 0.9.8x
     (0)    1.0.0h 1.0.0i 1.0.0j (~)1.0.1a (~)1.0.1b 1.0.1c
       {bindist gmp kerberos rfc3779 sse2 static-libs test vanilla zlib}
     Installed versions:  0.9.8x(0.9.8)(20:30:48 2012-05-12)(sse2 zlib -bindist -gmp -kerberos -test) 1.0.1c(20:32:47 2012-05-12)(sse2 zlib -bindist -gmp -kerberos -rfc3779 -static-libs -test -vanilla)
     Homepage:            http://www.openssl.org/
     Description:         full-strength general purpose cryptography library (including SSL v2/v3 and TLS v1)

root@skare$ ll /usr/lib/libssl*
lrwxrwxrwx 1 root root   13 19 jan 13.02 /usr/lib/libssl3.so -> libssl3.so.12*
-rwxr-xr-x 1 root root 273K 19 jan 13.02 /usr/lib/libssl3.so.12*
lrwxrwxrwx 1 root root   15 12 maj  2012 /usr/lib/libssl.so -> libssl.so.1.0.0*
-rwxr-xr-x 1 root root 340K 12 maj  2012 /usr/lib/libssl.so.0.9.8*
-r-xr-xr-x 1 root root 418K 12 maj  2012 /usr/lib/libssl.so.1.0.0*
Comment 3 Naohiro Aota gentoo-dev 2013-02-07 00:50:34 UTC
and

% ldd /opt/dropbox/dropbox
/opt/dropbox/dropbox:
        linux-vdso.so.1 (0x00007fff407fe000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007fab31d9e000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007fab31b9a000)
        libutil.so.1 => /lib64/libutil.so.1 (0x00007fab31997000)
        libm.so.6 => /lib64/libm.so.6 (0x00007fab3169c000)
        libssl.so.0.9.8 => /usr/lib64/libssl.so.0.9.8 (0x00007fab31446000)
        libcrypto.so.0.9.8 => /usr/lib64/libcrypto.so.0.9.8 (0x00007fab310b2000)
        libc.so.6 => /lib64/libc.so.6 (0x00007fab30d06000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fab31fbb000)
        libz.so.1 => /lib64/libz.so.1 (0x00007fab30af0000)

then, this could be portage bug? I need your comment, portage team.
Comment 4 Zac Medico gentoo-dev 2013-02-07 02:52:48 UTC
It looks like a portage bug. Please attach output of the following command:

    grep openssl /var/log/emerge.log
Comment 5 Zac Medico gentoo-dev 2013-02-07 02:54:52 UTC
As a workaround, this will probably make the problem go away:

   emerge --oneshot openssl:0.9.8
Comment 6 Peter Asplund 2013-02-08 08:00:36 UTC
root@skare$ grep openssl /var/log/emerge.log
1350513491:  >>> emerge (1 of 419) dev-libs/openssl-1.0.1c to /
1350513491:  === (1 of 419) Cleaning (dev-libs/openssl-1.0.1c::/usr/portage/dev-libs/openssl/openssl-1.0.1c.ebuild)
1350513491:  === (1 of 419) Compiling/Merging (dev-libs/openssl-1.0.1c::/usr/portage/dev-libs/openssl/openssl-1.0.1c.ebuild)
1350541774:  >>> emerge (1 of 184) dev-python/pyopenssl-0.13 to /
1350541774:  === (1 of 184) Cleaning (dev-python/pyopenssl-0.13::/usr/portage/dev-python/pyopenssl/pyopenssl-0.13.ebuild)
1350541774:  === (1 of 184) Compiling/Merging (dev-python/pyopenssl-0.13::/usr/portage/dev-python/pyopenssl/pyopenssl-0.13.ebuild)
1355384387:  *** emerge --jobs=9 --keep-going --verbose --load-average=19.0 --oneshot --deep app-admin/eclean-kernel:0 app-benchmarks/bootchart2:0 app-portage/gentoolkit:0 dev-java/java-config:2 dev-java/javatoolkit:0 dev-libs/boost:0 dev-python/argparse:0 dev-python/astng:0 dev-python/autopep8:0 dev-python/beaker:0 dev-python/beautifulsoup:4 dev-python/bsddb3:0 dev-python/cython:0 dev-python/dbus-python:0 dev-python/docutils:0 dev-python/feedparser:0 dev-python/ipy:0 dev-python/logilab-common:0 dev-python/lxml:0 dev-python/mako:0 dev-python/markupsafe:0 dev-python/numpy:0 dev-python/pep8:0 dev-python/pip:0 dev-python/pycairo:0 dev-python/pycrypto:0 dev-python/pygments:0 dev-python/pygobject:3 dev-python/pylint:0 dev-python/pymountboot:0 dev-python/pyopenssl:0 dev-python/PyQt4:0 dev-python/pyxdg:0 dev-python/setuptools:0 dev-python/sip:0/9 dev-python/unittest2:0 dev-python/winpdb:0 dev-util/gdbus-codegen:0 net-irc/xchat:2 net-misc/dropbox:0 net-zope/zope-fixers:0 net-zope/zope-interface:0 sys-apps/file:0 sys-devel/gdb:0 sys-libs/libcap-ng:0
1360004512:  >>> emerge (7 of 15) dev-python/pyopenssl-0.13-r1 to /
1360004512:  === (7 of 15) Cleaning (dev-python/pyopenssl-0.13-r1::/usr/portage/dev-python/pyopenssl/pyopenssl-0.13-r1.ebuild)
1360004512:  === (7 of 15) Compiling/Merging (dev-python/pyopenssl-0.13-r1::/usr/portage/dev-python/pyopenssl/pyopenssl-0.13-r1.ebuild)
1360004521:  === (7 of 15) Merging (dev-python/pyopenssl-0.13-r1::/usr/portage/dev-python/pyopenssl/pyopenssl-0.13-r1.ebuild)
1360004523:  >>> AUTOCLEAN: dev-python/pyopenssl:0
1360004523:  === Unmerging... (dev-python/pyopenssl-0.13)
1360004526:  >>> unmerge success: dev-python/pyopenssl-0.13
1360004528:  === (7 of 15) Post-Build Cleaning (dev-python/pyopenssl-0.13-r1::/usr/portage/dev-python/pyopenssl/pyopenssl-0.13-r1.ebuild)
1360004528:  ::: completed emerge (7 of 15) dev-python/pyopenssl-0.13-r1 to /
1360268414:  >>> emerge (4 of 90) dev-libs/openssl-0.9.8y to /
1360268414:  === (4 of 90) Cleaning (dev-libs/openssl-0.9.8y::/usr/portage/dev-libs/openssl/openssl-0.9.8y.ebuild)
1360268414:  === (4 of 90) Compiling/Merging (dev-libs/openssl-0.9.8y::/usr/portage/dev-libs/openssl/openssl-0.9.8y.ebuild)
1360268414:  >>> emerge (5 of 90) dev-libs/openssl-1.0.1d to /
1360268414:  === (5 of 90) Cleaning (dev-libs/openssl-1.0.1d::/usr/portage/dev-libs/openssl/openssl-1.0.1d.ebuild)
1360268414:  === (5 of 90) Compiling/Merging (dev-libs/openssl-1.0.1d::/usr/portage/dev-libs/openssl/openssl-1.0.1d.ebuild)
1360268513:  === (4 of 90) Merging (dev-libs/openssl-0.9.8y::/usr/portage/dev-libs/openssl/openssl-0.9.8y.ebuild)
1360268515:  >>> AUTOCLEAN: dev-libs/openssl:0.9.8
1360268515:  === Unmerging... (dev-libs/openssl-0.9.8x)
1360268518:  >>> unmerge success: dev-libs/openssl-0.9.8x
1360268520:  === (4 of 90) Post-Build Cleaning (dev-libs/openssl-0.9.8y::/usr/portage/dev-libs/openssl/openssl-0.9.8y.ebuild)
1360268520:  ::: completed emerge (4 of 90) dev-libs/openssl-0.9.8y to /
1360268520:  === (5 of 90) Merging (dev-libs/openssl-1.0.1d::/usr/portage/dev-libs/openssl/openssl-1.0.1d.ebuild)
1360268524:  >>> AUTOCLEAN: dev-libs/openssl:0
1360268524:  === Unmerging... (dev-libs/openssl-1.0.1c)
1360268527:  >>> unmerge success: dev-libs/openssl-1.0.1c
1360268533:  === (5 of 90) Post-Build Cleaning (dev-libs/openssl-1.0.1d::/usr/portage/dev-libs/openssl/openssl-1.0.1d.ebuild)
1360268533:  ::: completed emerge (5 of 90) dev-libs/openssl-1.0.1d to /

It seems I have a huge emerge.log ;)
Comment 7 Zac Medico gentoo-dev 2013-02-08 15:35:04 UTC
Comment #0 shows the libraries preserved for openssl-1.0.0a-r3, but this version does not show in emerge.log. Did you trim your emerge.log at some point in the past, so it no longer contains the merge of openssl-1.0.0a-r3? Has emerge been showing that these libraries are preserved for a very long time? Does /var/db/pkg/dev-libs/openssl-1.0.0a-r3 still exist?

Does `emerge --oneshot openssl:0.9.8` make the problem go away?
Comment 8 Peter Asplund 2013-02-09 18:39:33 UTC
1) Yes, I've probably deleted my emerge.log a couple of times in the past. Seems like the first entry is from 20th of June 2012, and this system has been up and running for at least 3 years. Probably even more. Might be 9 years :) I've migrated it a couple of times (to new disks, new hardware, etc), but not sure 
Is there a way to check that btw?

2) Yes, the issue has been present for quite some time, at least half a year. Might be a year even, I've just figured it would go away by itself at some point, so I didn't bother reporting it. It's such a small annoyance anyway, just figured I'd finally report it since it hadn't gone away.

3) I'll get back to you on the last point..
Comment 9 Peter Asplund 2013-02-09 22:01:17 UTC
Yes, the issue seems to have been resolved. I did however seem to see that it was fixed just before I ran 'emerge -1 openssl-openssl:0.9.8', but I'm not sure. Sounds a bit too good to be true :)
Comment 10 Zac Medico gentoo-dev 2013-02-09 22:23:32 UTC
I suspect that the problem may have been fixed a long time ago. I guess we can just close it for now, since nobody has reported anything like this happening recently.