Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453962 - net-fs/autofs-5.0.6-r5: umount automounted NFS share fails
Summary: net-fs/autofs-5.0.6-r5: umount automounted NFS share fails
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Yixun Lan
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-25 10:58 UTC by Juergen Rose
Modified: 2013-07-22 14:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2013-01-25 10:58:42 UTC
I can't unmount automounted NFS shares:


root@impala:/root(21)# mount | grep nfs
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw,nodev,noexec,nosuid)
caiman:/home_caiman on /net/caiman/home_caiman type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.86,clientaddr=192.168.1.81)
caiman:/usr on /net/caiman/usr type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.86,clientaddr=192.168.1.81)
caiman:/usr/local/portage/distfiles_caiman on /net/caiman/usr/local/portage/distfiles_caiman type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.86,clientaddr=192.168.1.81)

root@impala:/root(22)# umount /net/caiman/home_caiman
umount.nfs: /net/caiman/home_caiman: device is busy

Only the automount process accesses this NFS share (it happens just after booting the system):

root@impala:/root(23)# lsof | grep /net/caiman/home_caiman
lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /home_impala/rose/.gvfs
      Output information may be incomplete.
automount 25876             root    5r      DIR               0,29         0      12845 /net/caiman/home_caiman
automount 25876 25877       root    5r      DIR               0,29         0      12845 /net/caiman/home_caiman
automount 25876 25878       root    5r      DIR               0,29         0      12845 /net/caiman/home_caiman
automount 25876 25881       root    5r      DIR               0,29         0      12845 /net/caiman/home_caiman
automount 25876 25884       root    5r      DIR               0,29         0      12845 /net/caiman/home_caiman


root@impala:/root(24)# qlist -Iv nfs-utils
net-fs/nfs-utils-1.2.6

'umount -lf' works:

root@impala:/root(25)# umount -lf /net/caiman/home_caiman
root@impala:/root(26)# mount | grep nfs
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw,nodev,noexec,nosuid)
caiman:/usr on /net/caiman/usr type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.86,clientaddr=192.168.1.81)
caiman:/usr/local/portage/distfiles_caiman on /net/caiman/usr/local/portage/distfiles_caiman type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.86,clientaddr=192.168.1.81)
Comment 1 Juergen Rose 2013-01-25 11:35:51 UTC
Maybe this issue is also the reason for Bug 453880 .
Comment 2 Juergen Rose 2013-01-31 11:07:41 UTC
Today I have the problem, that I cant't access a automounted share. Maybe it has the reason as the problem with the unmounting of NFS shares.

I release at caiman several directories for the access from impala and I can check this form impala:

root@impala:/root(22)# /usr/sbin/showmount -e caiman | grep impala
/var                                wildcat.homenet,impala.homenet,lynx2.homenet,lynx.homenet,inspironM12.homenet,thinkpad.homenet,condor.homenet,vilm.homenet,grizzly.homenet,tarantel.homenet
/home_caiman                        wildcat.homenet,impala.homenet,lynx2.homenet,lynx.homenet,condor.homenet,vilm.homenet,grizzly.homenet,inspironM12.homenet,thinkpad.homenet,tarantel.homenet,laptop.homenet,STar.homenet,NewSTar.homenet,lionhomenet.homenet,laptop450.homenet,shark.homenet,cathomenet.homenet,mouse.homenet
...

The home directory at caiman I can now access without problems:

root@impala:/root(23)# ll /net/caiman/home_caiman/
total 20
drwxr-xr-x  2 root root     0 Jan 31 09:45 ftp/
drwx------  2 root root 16384 Jan 21  2011 lost+found/
drwxr-xr-x 55 rose rose  4096 Jan 24 18:54 rose/

but the access to the /var directory hangs:

root@impala:/root(24)# ll /net/caiman/var
^C/bin/ls: cannot access /net/caiman/var: Interrupted system call


'mount' shows me, that that caiman:/var is not mounted:

root@impala:/root(26)# mount | grep nfs
rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw,nodev,noexec,nosuid)
caiman:/usr on /net/caiman/usr type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.86,clientaddr=192.168.1.81)
caiman:/home_caiman on /net/caiman/home_caiman type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.86,clientaddr=192.168.1.81)
condor:/home_condor on /net/condor/home_condor type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.76,clientaddr=192.168.1.81)
condor:/var on /net/condor/var type nfs (rw,nosuid,nodev,intr,sloppy,vers=4,addr=192.168.1.76,clientaddr=192.168.1.81)


I can mount caiman:/var manually:

root@impala:/root(27)# mount caiman:/var /mnt/test2/
root@impala:/root(28)# ll /mnt/test2/
total 64
drwxr-xr-x 20 root   root       4096 May 12  2012 cache/
drwxr-xr-x  7 root   root       4096 Jan 31 04:07 db/
drwxr-xr-x  3 root   root       4096 Jan 19 02:32 empty/
drwxrwx--T  2 root   pulse      4096 Nov 26  2011 gdm/
drwxr-xr-x 67 root   root       4096 Jan 21 11:58 lib/
lrwxrwxrwx  1 root   root          9 Oct 25 09:23 lock -> /run/lock/
drwxr-xr-x 19 root   root       4096 Jan 29 05:02 log/
drwx------  2 root   root      16384 Jan 21  2011 lost+found/
lrwxrwxrwx  1 root   root         15 Oct 13 04:23 mail -> /var/spool/mail/
drwxr-xr-x  6 aspnet haldaemon  4096 Jan 24 15:09 nagios/
drwxr-xr-x  2 root   root       4096 Oct 29  2011 nmbd/
lrwxrwxrwx  1 root   root          4 Oct 25 09:23 run -> /run/
drwxr-xr-x 10 root   root       4096 Apr  2  2011 spool/
drwxr-xr-x  2 root   root       4096 Jan 13  2011 state/
drwxr-xr-x  2 root   root       4096 Jan 21  2011 tmp/
drwxr-xr-x  3 apache root       4096 Jun 26  2011 www/


Thus, it seems to be an autofs issue. I have the following /etc/autofs/auto.master and /etc/conf.d/autofs:

root@impala:/root(30)# grep ^[^#] /etc/autofs/auto.master 
/misc   /etc/autofs/auto.misc
/net    -hosts
+auto.master


root@impala:/root(32)# grep ^[^#]  /etc/conf.d/autofs 
MASTER_MAP_NAME="/etc/autofs/auto.master"
TIMEOUT=300
BROWSE_MODE="no"
USE_MISC_DEVICE="yes"


Is anything wrong with this configuration? If I try to restart autofs, I come again to  Bug 453880:


root@impala:/root(33)# /etc/init.d/autofs restart
 * Stopping automounter ...
 * start-stop-daemon: 1 process refused to stop                                                                    [ !! ]
 * ERROR: autofs failed to stop
Comment 3 Juergen Rose 2013-01-31 15:13:25 UTC
Just after rebooting impala, the access of an additional NFS share of caiman fails:

root@impala:/root(1)# ll /net/caiman/usr/local/portage/
total 0
drwxr-xr-x 2 root root 0 Jan 31 16:01 distfiles_caiman/

root@impala:/root(2)# ll /net/caiman/usr/local/portage/distfiles_caiman
/bin/ls: cannot open directory /net/caiman/usr/local/portage/distfiles_caiman: No such file or directory

root@impala:/root(3)# showmount -e caiman | grep "/usr/local/portage/distfiles_caiman.*impala"
/usr/local/portage/distfiles_caiman wildcat.homenet,impala.homenet,lynx2.homenet,lynx.homenet,condor.homenet,vilm.homenet,grizzly.homenet,inspironM12.homenet,thinkpad.homenet,cheetah.homenet,cathomenet.homenet,tarantel.homenet,shark.homenet,lionhomenet.homenet,scorpion.homenet,laptop450.homenet,mouse.homenet
Comment 4 Juergen Rose 2013-01-31 16:16:30 UTC
If I now to try to mount caiman:/usr/local/portage/distfiles_caiman, I get again Bug 453306:

root@impala:/root(4)# mount caiman:/usr/local/portage/distfiles_caiman /mnt/test2
mount.nfs: Cannot allocate memory
Comment 5 Yixun Lan gentoo-dev 2013-06-06 15:47:53 UTC
can you try with lastest version, 5.0.7-r1?
since I can't reproduce your problem here

Iā€˜m not sure whether the maintainer bumped the ebuild without increasing the revision number. ( can't check now..)
Comment 6 Yixun Lan gentoo-dev 2013-07-22 14:01:19 UTC
mark as obsolte, can't reproduce this in latest version (5.0.7-r2).
if you still have problem, please re-open again.

thanks