Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453644 - sys-cluster/torque-2.5.12 - qstat-qstat.o: In function `tcl_run': qstat.c:(.text+0x1ac5): undefined reference to `Tcl_GetErrorLine'
Summary: sys-cluster/torque-2.5.12 - qstat-qstat.o: In function `tcl_run': qstat.c:(.t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Justin Bronder (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-23 09:05 UTC by Volkmar Glauche
Modified: 2013-03-08 07:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (sys-cluster:torque-2.5.12:20130122-133926.log,270.03 KB, text/plain)
2013-01-23 09:07 UTC, Volkmar Glauche
Details
patch for src/cmds/qstat.c that fixes the issue for me (torque-3.0.6-tcl_geterrorline.patch,307 bytes, patch)
2013-02-06 16:34 UTC, JTRiley
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Volkmar Glauche 2013-01-23 09:05:41 UTC
See attached build log. 

Reproducible: Always

Steps to Reproduce:
1. emerge -u sys-cluster/torque
2.
3.
Actual Results:  
Build failure.

Expected Results:  
Build should not fail.

Portage 2.1.11.31 (default/linux/amd64/10.0, gcc-4.5.4, glibc-2.15-r3, 3.5.7-gentoo-2013-01-22 x86_64)
=================================================================
System uname: Linux-3.5.7-gentoo-2013-01-22-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.1
Timestamp of tree: Wed, 23 Jan 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13::<unknown repository>, 2.69
sys-devel/automake:       1.5-r1, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo science x-overlay
Installed sets: @system
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon64"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gdm/themes:/usr/share/X11/xorg.conf.d /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/spool/maui /var/spool/torque"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=athlon64"
DISTDIR="/adm/swinstall/gentoo/portage/distfiles"
EMERGE_DEFAULT_OPTS="-j 3 --keep-going y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ "
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/adm/swinstall/gentoo/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/adm/swinstall/gentoo/portage"
PORTDIR_OVERLAY="/var/lib/layman/science /adm/swinstall/gentoo/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d a52 aac aalib accessibility acl acpi adns afs alsa amd64 ao audiofile auto-hinter avahi bash-completion bcmath berkdb bindist blas bonobo bzip2 cairo calendar caps cdparanoia cdr clamav cli consolekit cracklib crypt cscope ctype cups curl curlwrappers cxx dbm dbus dga dri dts dv dvb dvd dvdr eds emacs emboss encode esd evo exif expat fam fax fbcon ffmpeg fftw firefox flac flash flatfile fltk fortran ftp gcj gd gdbm geoip ggi gif gimp glut gmp gnome gnome-keyring gnutls gphoto2 gpm graphviz gtk gtkhtml guile hardened http iconv idn ieee1394 imagemagick imap imlib inifile ipod ipv6 jack java javascript jbig jpeg jpeg2k kde kerberos ladspa lame lapack lash lcms ldap leim libcaca libedit libnotify libvisual libwww lm_sensors logrotate lua m17n-lib mad maildir matroska mbox memlimit mhash migemo mikmod mime mmap mms mmx mng modules mono motif mozilla mp3 mpeg mplayer mudflap mule multilib musepack nas nautilus ncurses neXt netboot netcdf nls nntp nptl nsplugin offensive ogg openal openexr opengl openmp pam pcntl pcre pda pdf perl php plotutils png policykit posix profile pulseaudio python qt4 quicktime rdesktop readline recode ruby sasl scanner sdl session sharedmem shorten simplexml slang slp smartcard sndfile soap sockets sox speex spell sqlite sqlite3 sse sse2 ssl startup-notification svg sysvipc szip taglib tcl tcpd theora threads tidy tiff tk tokenizer truetype twolame udev udisks unicode usb vcd vim-syntax vorbis vpx wavpack wmf wxwidgets xft xine xinetd xml xmlrpc xpm xsl xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de it fr" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="dummy fbdev modesetting nv noveau mga radeon vesa vga ati fglrx intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Volkmar Glauche 2013-01-23 09:07:56 UTC
Created attachment 336558 [details]
build log
Comment 2 JTRiley 2013-02-06 16:34:18 UTC
Created attachment 338118 [details, diff]
patch for src/cmds/qstat.c that fixes the issue for me

This patch adds forwards/backwards compatibility for Tcl_GetErrorLine() to src/cmds/qstat.c. Still needs to be reported upstream...
Comment 3 Sean Santos 2013-02-23 23:26:07 UTC
I'm having this problem too. But isn't this caused by a patch in portage, not upstream? There are these three:

torque-2.5.12-tcl8.6.patch
torque-2.5.9-tcl8.6.patch
torque-3.0.6-tcl8.6.patch

These were created recently for bug 453154.

AFAICT these are always being applied, but should only be applied if the "tk" use flag is on. Or the patch from comment 2 could be added to these, but it makes more sense to me to not apply the patch in the first place if "tk" is not on.
Comment 4 Justin Bronder (RETIRED) gentoo-dev 2013-03-08 03:27:53 UTC
Sorry for the delay guys, I admit to slacking.

I've fixed the immediate problem for USE=-tk people with:

  08 Mar 2013; Justin Bronder <jsbronder@gentoo.org> torque-2.5.9-r1.ebuild,
  torque-2.5.12.ebuild, torque-3.0.6-r1.ebuild:
  Toggle --enable-tcl-qstat based on USE=tk, resolves #453644

However, #453154 has been reopened as the patches break with USE=tk and <tk-8.6

Thanks for your patience and for reporting.
Comment 5 Justin Lecher gentoo-dev 2013-03-08 07:10:49 UTC
I am sorry. I wasn't aware of the backward incompatibility. Actually I checker for Tcl_GetStringResult() which is fine, but Tcl_GetErrorLine() is new in 8.6