Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453636 - media-sound/abcde-2.5.4: Add USE-flag "cdio"
Summary: media-sound/abcde-2.5.4: Add USE-flag "cdio"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-23 08:30 UTC by Massimo Burcheri
Modified: 2014-04-05 09:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Massimo Burcheri 2013-01-23 08:30:17 UTC
Please add USE-flag "cdio" to abcde, as done by media-video/mplayer2 for example in order to replace old cdparanoia with the libcdio replacement.

The separate ebuild dev-libs/libcdio-paranoia-0.90 has been introduced recently.

As described here [1] abcde is already working with libcdio-paranoia:
[1] https://forums.gentoo.org/viewtopic-p-7128160.html#7128160
..using this config:

$ grep para /etc/abcde/abcde.conf |grep -v "^#"
CDROMREADERSYNTAX=cdparanoia
CDPARANOIA=libcdio-paranoia


Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2014-04-05 09:02:13 UTC
  23 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> abcde-2.5.4.ebuild:
  Only cdparanoia executable is used. Convert the dependency to || () for
  libcdio-paranoia support.
Comment 2 Samuli Suominen gentoo-dev 2014-04-05 09:04:55 UTC
USE="cdparanoia" pulls in libcdio-paranoia where supports, and if not, then falls back to cdparanoia
USE="cdio" is for libcdio, not for libcdio-paranoia
Futher, you don't need to configure abcde.conf at all for this, you can simply select libcdio-paranoia as the provider of `cdparanoia` like:

# eselect cdparanoia list
Available cdparanoia binary implementations:
  [1]   cdparanoia-paranoia
  [2]   libcdio-paranoia *

# eselect cdparanoia set 2