Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453562 - x11-libs/gtk+-3.6.3-r2 USE="wayland" - ./.libs/ undefined reference to `wl_egl_pixmap_create_buffer'
Summary: x11-libs/gtk+-3.6.3-r2 USE="wayland" - ./.libs/ undefined referen...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2013-01-22 19:01 UTC by jannis
Modified: 2013-07-27 11:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,114.52 KB, text/plain)
2013-01-22 19:01 UTC, jannis
emerge --info (einfo,22.72 KB, text/plain)
2013-01-22 19:02 UTC, jannis

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2013-01-22 19:01:11 UTC
Trying to compile gtk+ with USE="wayland" with the error seen in build.log. The (masked) USE-flag "egl" doesn't have any influence, same error with +egl

Reproducible: Always
Comment 1 jannis 2013-01-22 19:01:45 UTC
Created attachment 336514 [details]
Comment 2 jannis 2013-01-22 19:02:13 UTC
Created attachment 336516 [details]
emerge --info
Comment 3 Rafał Mużyło 2013-01-24 09:23:22 UTC
Consider this an upstream bug: this API was removed ( shortly before wayland 1.0.0 release.

It's been workaround with this commit:
The solution for the <=3.6.x ebuilds (as for the time being the commit hasn't been picked into 3.6 branch) seems to be '--disable-wayland-cairo-gl'.
Comment 4 Malte E. 2013-03-11 05:47:25 UTC
Please consider adjusting the dependencies and/or adding a warning, so people will know.
Comment 5 Pacho Ramos gentoo-dev 2013-07-27 11:38:51 UTC
should be solved in 3.8.2