Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453424 - app-office/openerp-7.0.20130118 - various problems
Summary: app-office/openerp-7.0.20130118 - various problems
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Patrick Lauer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-21 21:58 UTC by A. Person
Modified: 2014-01-25 14:23 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
openerp-7.0.20130917.ebuild (openerp-7.0.20130917.ebuild,2.91 KB, text/plain)
2013-09-20 03:03 UTC, Martin Andres Gomez Gimenez
Details
latest default config file (openerp.cfg,1.47 KB, text/plain)
2013-09-26 17:56 UTC, A. Person
Details
openerp-7.0.20130924.ebuild (openerp-7.0.20130924.ebuild,3.12 KB, application/x-extension-ebuild)
2013-09-27 17:02 UTC, Martin Andres Gomez Gimenez
Details
openerp-7.0.20130924.ebuild (openerp-7.0.20130924.ebuild,3.12 KB, application/x-extension-ebuild)
2013-09-27 17:11 UTC, Martin Andres Gomez Gimenez
Details
openerp-7.0.20131008.ebuild (openerp-7.0.20131008.ebuild,3.12 KB, text/plain)
2013-10-10 04:49 UTC, Yixun Lan
Details
openerp-7.0.20131008.ebuild r2 (openerp-7.0.20131008.ebuild,3.60 KB, text/plain)
2013-10-10 11:36 UTC, Yixun Lan
Details
dev-python/gevent-psycopg2 ebuild (gevent-psycopg2-0.0.3.ebuild,581 bytes, text/plain)
2014-01-24 02:54 UTC, A. Person
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A. Person 2013-01-21 21:58:47 UTC
The openerp-6.1.1 ebuild works great but the 7.0.20130118 ebuild has various problems.

1. loading hostname:8069, I only get a blank page containing the following code:

<!DOCTYPE html>
<html style="height: 100%">
    <head>
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1"/>
        <meta http-equiv="content-type" content="text/html; charset=utf-8" />
        <title>OpenERP</title>
        <link rel="shortcut icon" href="/web/static/src/img/favicon.ico" type="image/x-icon"/>
        <link rel="stylesheet" href="/web/static/src/css/full.css" />
        <link rel="stylesheet" href="/web/webclient/css">
        <script type="text/javascript" src="/web/webclient/js"></script>
        <script type="text/javascript">
            $(function() {
                var s = new openerp.init([]);
                var wc = new s.web.WebClient();wc.appendTo($(document.body));
            });
        </script>
    </head>
    <body>
        <!--[if lte IE 8]>
        <script src="http://ajax.googleapis.com/ajax/libs/chrome-frame/1/CFInstall.min.js"></script>
        <script>CFInstall.check({mode: "overlay"});</script>
        <![endif]-->
    </body>
</html>

2. The following dependencies are missing:

dev-python/mock
dev-pythong/unittest2

3. When upgrading from 6.1.1, I had to emerge 7.0.20130118 twice in order to keep the /var/run/openerp directory.

4. The openerp log reports 404 errors for full.css and favicon.ico.

Reproducible: Always
Comment 1 barrie backhurst 2013-01-23 14:19:09 UTC
I am currently working my way through this

Items 1 & 4 
should be solved by adding 
"addons_path = /usr/openerp/addons" 
to 
/etc/openerp/openerp.cfg

Item 2
I had not found
dev-python/unittest2
as it was already installed, but I believe it will be drawn in if the "test" USE flag is enforced on
dev-python/mock

I had also found that

dev-python/jinja

was a missing dependancy for email templates

Item 3
Interesting, I will try reemerging as I have been recreating and changing ownership manually so far
Comment 2 barrie backhurst 2013-01-23 14:38:09 UTC
Re. Item 3
Are you saying that re-emerging stopped the directory being deleted, or was necessary for you to recreate it on each occasion?
Comment 4 barrie backhurst 2013-01-23 15:04:21 UTC
Trying to create a new database fails. Extract from the log


2013-01-23 14:58:01,636 4397 INFO testdemo7 openerp.modules.loading: module base: loading base_data.xml
2013-01-23 14:58:02,065 4397 ERROR testdemo7 openerp.service.web_services: CREATE DATABASE failed:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/openerp/service/web_services.py", line 76, in _initialize_db
    update_module=True)[1]
  File "/usr/lib64/python2.7/site-packages/openerp/pooler.py", line 39, in restart_pool
    registry = RegistryManager.new(db_name, force_demo, status, update_module)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/registry.py", line 214, in new
    openerp.modules.load_modules(registry.db, force_demo, status, update_module)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/loading.py", line 303, in load_modules
    loaded_modules, processed_modules = load_module_graph(cr, graph, status, perform_checks=update_module, report=report)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/loading.py", line 190, in load_module_graph
    load_data(module_name, idref, mode)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/loading.py", line 75, in <lambda>
    load_data = lambda *args: _load_data(cr, *args, kind='data')
  File "/usr/lib64/python2.7/site-packages/openerp/modules/loading.py", line 126, in _load_data
    tools.convert_xml_import(cr, module_name, fp, idref, mode, noupdate, report)
  File "/usr/lib64/python2.7/site-packages/openerp/tools/convert.py", line 943, in convert_xml_import
    etree.parse(os.path.join(config['root_path'],'import_xml.rng' )))
  File "lxml.etree.pyx", line 3170, in lxml.etree.parse (src/lxml/lxml.etree.c:63115)
  File "parser.pxi", line 1549, in lxml.etree._parseDocument (src/lxml/lxml.etree.c:90392)
  File "parser.pxi", line 1578, in lxml.etree._parseDocumentFromURL (src/lxml/lxml.etree.c:90685)
  File "parser.pxi", line 1478, in lxml.etree._parseDocFromFile (src/lxml/lxml.etree.c:89743)
  File "parser.pxi", line 1025, in lxml.etree._BaseParser._parseDocFromFile (src/lxml/lxml.etree.c:86654)
  File "parser.pxi", line 565, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/lxml.etree.c:82228)
  File "parser.pxi", line 656, in lxml.etree._handleParseResult (src/lxml/lxml.etree.c:83209)
  File "parser.pxi", line 594, in lxml.etree._raiseParseError (src/lxml/lxml.etree.c:82505)
IOError: Error reading file '/usr/lib64/python2.7/site-packages/openerp/import_xml.rng': failed to load external entity "/usr/lib64/python2.7/site-packages/openerp/import_xml.rng"
2013-01-23 14:58:02,178 4397 ERROR testdemo7 openerp.netsvc: Unable to use a closed cursor.


locate shows import_xml.rng to be in a different location

$ locate import_xml.rng
/usr/openerp/import_xml.rng
Comment 5 A. Person 2013-01-23 20:41:19 UTC
Re. Item 3

I had 6.1.1 installed and all was well.  I emerged 7.0.20130118 and tried to restart openerp and but I got an error indicating that the pid file in /var/run/openerp did not exist.  I saw that there was no /var/run/openerp directory at all.  I emerged 7.0.20130118 again and the directory appeared and openerp was able to restart.

Is the import_xml.rng problem an upstream one?
Comment 6 barrie backhurst 2013-01-23 23:59:08 UTC
>Is the import_xml.rng problem an upstream one?

I don't think so, I didn't find much with Google so other distributions are presumably ok?
Comment 7 A. Person 2013-01-25 23:49:10 UTC
OK, I hope Patrick can step in and straighten this out.
Comment 8 barrie backhurst 2013-01-26 00:18:24 UTC
In the mean time the file can be linked to the expected location

#ln -s /usr/openerp/import_xml.rng /usr/lib64/python2.7/site-packages/openerp/import_xml.rng

allowing the creation of a new database
Comment 9 A. Person 2013-02-10 04:47:34 UTC
I rebooted and got the same error again about the pid file in /var/run/openerp when trying to start openerp.  I re-emerged openerp-6.1.1 again and it started working again.  I get this at the end of the emerge:

 * One or more symlinks to directories have been preserved in order to
 * ensure that files installed via these symlinks remain accessible. This
 * indicates that the mentioned symlink(s) may be obsolete remnants of an
 * old install, and it may be appropriate to replace a given symlink with
 * the directory that it points to.
 * 
 * 	/var/run

Does this mean I should delete /var/run/ and re-emerge openerp?
Comment 10 A. Person 2013-02-16 20:04:59 UTC
It looks like Flameeyes is having the same /var/run issue with app-office/openerp-server-5.0.16:

https://bugs.gentoo.org/show_bug.cgi?id=451764

I should have mentioned that I'm having this problem with 6.1.1 as well as 7.0.20130118.
Comment 11 Patrick Lauer gentoo-dev 2013-02-19 09:32:44 UTC
+  19 Feb 2013; Patrick Lauer <patrick@gentoo.org> +openerp-7.0.20130219.ebuild:
+  Bump, first part of fixes for #453424

This fixes dependencies. Rest coming as soon as I find some time for it.
Comment 12 Patrick Lauer gentoo-dev 2013-02-19 09:52:13 UTC
+  19 Feb 2013; Patrick Lauer <patrick@gentoo.org> +files/openerp-2,
+  +files/openerp-confd-2, +openerp-7.0.20130219-r1.ebuild:
+  Fixing for /run migration

So now there's just the "misplaced files" issue
Comment 13 A. Person 2013-02-20 07:54:01 UTC
Thanks Patrick, your work is much appreciated.
Comment 14 barrie backhurst 2013-02-20 12:53:49 UTC
Patrick thanks from me as well!

I have tried the openerp-7.0.20130219-r1 and I am still getting a file missing error on startup. I believe that this is due to the $PIDFILE being created by both the start-stop-daemon and the openerp-server code(I had thought this was the problem before but couldn't get my head round the startup processes). Although you have adjusted the PIDFILE path in openerp-confd-2, it still points to /var/run/openerp/openerp-server.pid in the openerp.cfg file.

@Grant is your startup working?
Comment 15 Penetsdorfer Martin 2013-02-20 15:03:01 UTC
emerge =app-office/openerp-7.0.20130219-r4 sucessfull, but can not start openerp:

# /etc/init.d/openerp-2 start
* Starting openerp server ...
* start-stop-daemon: fopen `': No such file or directory 

# start-stop-daemon --start --quiet --pidfile "/run/openerp/openerp.pid" --exec /usr/bin/openerp-server --make-pidfile --user "openerp" -- /etc/openerp/openerp.cfg

Traceback (most recent call last):
  File "/usr/bin/openerp-server", line 5, in <module>
    openerp.cli.main()
  File "/usr/lib64/python2.7/site-packages/openerp/cli/__init__.py", line 51, in main
    __import__(m)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/module.py", line 133, in load_module
    mod = imp.load_module('openerp.addons.' + module_part, f, path, descr)
  File "/usr/lib64/python2.7/site-packages/openerp/addons/base_action_rule/__init__.py", line 23, in <module>
    import test_models
  File "/usr/lib64/python2.7/site-packages/openerp/addons/base_action_rule/test_models.py", line 1, in <module>
    from osv import osv, fields
ImportError: No module named osv
 * start-stop-daemon: failed to start `/usr/bin/openerp-server'
Comment 16 barrie backhurst 2013-02-20 21:46:29 UTC
There is name mismatch for the conf.d & init.d entries, renaming /etc/init.d/openerp-2 to /etc/init.d/openerp solves that.

However although the process starts without error, running
/etc/init.d/openerp status
shows that the process has crashed

# /etc/init.d/openerp start
 * Caching service dependencies ...                                                                                                                                                                            [ ok ]
 * Starting openerp server ...

# /etc/init.d/openerp status
 * status: crashed
Comment 17 A. Person 2013-02-20 22:19:59 UTC
Barrie, it's not working for me yet.
Comment 18 Penetsdorfer Martin 2013-02-21 14:48:34 UTC
Can emerge and start =app-office/openerp-7.0.20130219-r5 successful

# /etc/init.d/openerp start
 * Starting openerp server ... 

# /etc/init.d/openerp status
 * status: started

If I start openerp http://localhost:8069/ in konqueror in WebKit or in KHTML mode - I see only a blank page 

But I start openerp http://localhost:8069/ in firefox (=www-client/firefox-18.0.1) in see the openerp login screen, after I set follow links:

ln -s /usr/openerp/import_xml.rng /usr/lib64/python2.7/site-packages/openerp/import_xml.rng

ln -s /usr/openerp/addons/base/res/res_company_logo.png /usr/lib64/python2.7/site-packages/openerp/addons/base/res/res_company_logo.png

can create a new database and can intall all listen apps in openerp without an error
Comment 19 Blake Leverett 2013-04-05 17:54:56 UTC
I have been running openerp-server from the yarik overlay.  I loaded openerp-7.0.20130219-r5 to try it out.  I can open the webpage at localhost:8069, and the program finds my existing database.

I cannot create a new database. I get this message:

Client Traceback (most recent call last):
  File "/usr/openerp/addons/web/http.py", line 195, in dispatch
    response["result"] = method(self, **self.params)
  File "/usr/openerp/addons/web/controllers/main.py", line 719, in create
    params['create_admin_pwd'])
  File "/usr/openerp/addons/web/session.py", line 31, in proxy_method
    result = self.session.send(self.service_name, method, *args)
  File "/usr/openerp/addons/web/session.py", line 104, in send
    raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)


Server Traceback (most recent call last):
  File "/usr/openerp/addons/web/session.py", line 90, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/usr/lib64/python2.7/site-packages/openerp/netsvc.py", line 295, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/usr/lib64/python2.7/site-packages/openerp/service/web_services.py", line 122, in dispatch
    return fn(*params)
  File "/usr/lib64/python2.7/site-packages/openerp/service/web_services.py", line 168, in exp_create_database
    _initialize_db(self, id, db_name, demo, lang, user_password)
  File "/usr/lib64/python2.7/site-packages/openerp/service/web_services.py", line 98, in _initialize_db
    cr.close()
  File "/usr/lib64/python2.7/site-packages/openerp/sql_db.py", line 161, in wrapper
    raise psycopg2.OperationalError(msg)
OperationalError: Unable to use a closed cursor.


I cannot log into the new database, I get:

Client Traceback (most recent call last):
  File "/usr/openerp/addons/web/http.py", line 195, in dispatch
    response["result"] = method(self, **self.params)
  File "/usr/openerp/addons/web/controllers/main.py", line 818, in authenticate
    req.session.authenticate(db, login, password, env)
  File "/usr/openerp/addons/web/session.py", line 116, in authenticate
    uid = self.proxy('common').authenticate(db, login, password, env)
  File "/usr/openerp/addons/web/session.py", line 31, in proxy_method
    result = self.session.send(self.service_name, method, *args)
  File "/usr/openerp/addons/web/session.py", line 104, in send
    raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)


Server Traceback (most recent call last):
  File "/usr/openerp/addons/web/session.py", line 90, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/usr/lib64/python2.7/site-packages/openerp/netsvc.py", line 295, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/usr/lib64/python2.7/site-packages/openerp/service/web_services.py", line 425, in dispatch
    return fn(*params)
  File "/usr/lib64/python2.7/site-packages/openerp/service/web_services.py", line 436, in exp_authenticate
    res_users = pooler.get_pool(db).get('res.users')
  File "/usr/lib64/python2.7/site-packages/openerp/pooler.py", line 49, in get_pool
    return get_db_and_pool(db_name, force_demo, status, update_module)[1]
  File "/usr/lib64/python2.7/site-packages/openerp/pooler.py", line 33, in get_db_and_pool
    registry = RegistryManager.get(db_name, force_demo, status, update_module)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/registry.py", line 192, in get
    update_module)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/registry.py", line 214, in new
    openerp.modules.load_modules(registry.db, force_demo, status, update_module)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/loading.py", line 303, in load_modules
    loaded_modules, processed_modules = load_module_graph(cr, graph, status, perform_checks=update_module, report=report)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/loading.py", line 190, in load_module_graph
    load_data(module_name, idref, mode)
  File "/usr/lib64/python2.7/site-packages/openerp/modules/loading.py", line 75, in <lambda>
    load_data = lambda *args: _load_data(cr, *args, kind='data')
  File "/usr/lib64/python2.7/site-packages/openerp/modules/loading.py", line 126, in _load_data
    tools.convert_xml_import(cr, module_name, fp, idref, mode, noupdate, report)
  File "/usr/lib64/python2.7/site-packages/openerp/tools/convert.py", line 943, in convert_xml_import
    etree.parse(os.path.join(config['root_path'],'import_xml.rng' )))
  File "lxml.etree.pyx", line 3170, in lxml.etree.parse (src/lxml/lxml.etree.c:63115)
  File "parser.pxi", line 1549, in lxml.etree._parseDocument (src/lxml/lxml.etree.c:90392)
  File "parser.pxi", line 1578, in lxml.etree._parseDocumentFromURL (src/lxml/lxml.etree.c:90685)
  File "parser.pxi", line 1478, in lxml.etree._parseDocFromFile (src/lxml/lxml.etree.c:89743)
  File "parser.pxi", line 1025, in lxml.etree._BaseParser._parseDocFromFile (src/lxml/lxml.etree.c:86654)
  File "parser.pxi", line 565, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/lxml.etree.c:82228)
  File "parser.pxi", line 656, in lxml.etree._handleParseResult (src/lxml/lxml.etree.c:83209)
  File "parser.pxi", line 594, in lxml.etree._raiseParseError (src/lxml/lxml.etree.c:82505)
IOError: Error reading file '/usr/lib64/python2.7/site-packages/openerp/import_xml.rng': failed to load external entity "/usr/lib64/python2.7/site-packages/openerp/import_xml.rng"


I cannot log into my old database, I get:

Client Traceback (most recent call last):
  File "/usr/openerp/addons/web/http.py", line 195, in dispatch
    response["result"] = method(self, **self.params)
  File "/usr/openerp/addons/web/controllers/main.py", line 818, in authenticate
    req.session.authenticate(db, login, password, env)
  File "/usr/openerp/addons/web/session.py", line 119, in authenticate
    if uid: self.get_context()
  File "/usr/openerp/addons/web/session.py", line 171, in get_context
    self.context = self.model('res.users').context_get() or {}
  File "/usr/openerp/addons/web/session.py", line 43, in proxy
    result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw)
  File "/usr/openerp/addons/web/session.py", line 31, in proxy_method
    result = self.session.send(self.service_name, method, *args)
  File "/usr/openerp/addons/web/session.py", line 104, in send
    raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)


Server Traceback (most recent call last):
  File "/usr/openerp/addons/web/session.py", line 90, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/usr/lib64/python2.7/site-packages/openerp/netsvc.py", line 295, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/usr/lib64/python2.7/site-packages/openerp/service/web_services.py", line 614, in dispatch
    res = fn(db, uid, *params)
  File "/usr/lib64/python2.7/site-packages/openerp/osv/osv.py", line 169, in execute_kw
    return self.execute(db, uid, obj, method, *args, **kw or {})
  File "/usr/lib64/python2.7/site-packages/openerp/osv/osv.py", line 123, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/openerp/osv/osv.py", line 179, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/usr/lib64/python2.7/site-packages/openerp/osv/osv.py", line 166, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/usr/lib64/python2.7/site-packages/openerp/tools/cache.py", line 18, in lookup
    r = self.lookup(self2, cr, *args)
  File "/usr/lib64/python2.7/site-packages/openerp/tools/cache.py", line 46, in lookup
    value = d[key] = self.method(self2, cr, *args)
  File "/usr/openerp/addons/base/res/res_users.py", line 348, in context_get
    res = getattr(user,k) or False
  File "/usr/lib64/python2.7/site-packages/openerp/osv/orm.py", line 484, in __getattr__
    return self[name]
  File "/usr/lib64/python2.7/site-packages/openerp/osv/orm.py", line 399, in __getitem__
    field_values = self._table.read(self._cr, self._uid, ids, field_names, context=self._context, load="_classic_write")
  File "/usr/openerp/addons/base/res/res_users.py", line 793, in read
    res = super(users_view, self).read(cr, uid, ids, fields, context=context, load=load)
  File "/usr/openerp/addons/base/res/res_users.py", line 268, in read
    result = super(res_users, self).read(cr, uid, ids, fields=fields, context=context, load=load)
  File "/usr/lib64/python2.7/site-packages/openerp/osv/orm.py", line 3604, in read
    result = self._read_flat(cr, user, select, fields, context, load)
  File "/usr/lib64/python2.7/site-packages/openerp/osv/orm.py", line 3656, in _read_flat
    cr.execute(query, [tuple(sub_ids)] + rule_params)
  File "/usr/lib64/python2.7/site-packages/openerp/sql_db.py", line 162, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/openerp/sql_db.py", line 227, in execute
    res = self._obj.execute(query, params)
ProgrammingError: column res_users.login_date does not exist
LINE 1: SELECT res_users."menu_id",res_users."login_date",res_users....
                                   ^
Comment 20 Martin Andres Gomez Gimenez 2013-04-16 21:49:46 UTC
(In reply to comment #8)
> In the mean time the file can be linked to the expected location
> 
> #ln -s /usr/openerp/import_xml.rng
> /usr/lib64/python2.7/site-packages/openerp/import_xml.rng
> 
> allowing the creation of a new database

The same should be done for x86, with the following exception:

#ln -s /usr/openerp/import_xml.rng > /usr/lib/python2.7/site-packages/openerp/import_xml.rng

Please create a correction in the ebuild for this problem.
Comment 21 Vicente Jiménez Aguilar 2013-05-28 17:43:05 UTC
The OpenERP project had done a lot of bug fixes since the version that install the latest ebuild from portage.
I would like to see a new ebuild with the symbolic links correction from above (or another solution that solves the same problem) and with a newer version of OpenERP 7.0.
Comment 22 A. Person 2013-05-29 17:42:05 UTC
I would love to see that too.
Comment 23 Blake Leverett 2013-05-29 18:00:38 UTC
I have been able to get openerp working by emerging app-office/openerp-7.0.20130219-r5, just to install the dependencies and write a valid config file.

Then I downloaded the latest openerp sources, which are all python, and extracted the archive to my home directory.  I then run the server from a terminal with:
./openerp-server -c /etc/openerp/openerp.cfg

Of course I had to setup postgresql and the openerp.cfg file.  This works great.  I never could get the portage version to work.

Most problems working with openerp come down to the extreme strictness and opaqueness of postgresql.  I am new to the database world and have been working with both postgresql and mysql.  Mysql has been so easy to work with, while postgresql is a nightmare.  Obviously the problem is my ignorance of the nuances of postgresql, but you shouldn't need a PhD in postgresql to be able to admin a basic system.
Comment 24 A. Person 2013-06-05 05:24:28 UTC
Maybe if we vote?
Comment 25 Martin Andres Gomez Gimenez 2013-09-20 03:03:22 UTC
Created attachment 359090 [details]
openerp-7.0.20130917.ebuild
Comment 26 Martin Andres Gomez Gimenez 2013-09-20 03:06:20 UTC
Comment on attachment 359090 [details]
openerp-7.0.20130917.ebuild

Fix error on /usr/openerp/import_xml.rng
Comment 27 A. Person 2013-09-20 06:49:19 UTC
Thanks Martin, I will try this soon.
Comment 28 A. Person 2013-09-23 20:26:27 UTC
Fantastic job Martin.  It installs and functions perfectly here as far as I can tell.  Thank you.
Comment 29 A. Person 2013-09-26 17:56:49 UTC
Created attachment 359544 [details]
latest default config file
Comment 30 A. Person 2013-09-26 17:57:19 UTC
The openerp.cfg file installed by the ebuild is out of date.  I've attached the very latest default one.  I commented and replaced 4 lines to get it working with Gentoo.
Comment 31 Martin Andres Gomez Gimenez 2013-09-27 17:02:59 UTC
Created attachment 359630 [details]
openerp-7.0.20130924.ebuild

New version. Also fixes error on /usr/openerp/addons/base/res/res_company_logo.png that refers to Python site directory.
Comment 32 Martin Andres Gomez Gimenez 2013-09-27 17:11:01 UTC
Created attachment 359636 [details]
openerp-7.0.20130924.ebuild
Comment 33 A. Person 2013-09-28 11:42:21 UTC
Thanks Martin.  It installs great.  Does the following line need to be changed in the ebuild in order to use the new openerp.cfg?  I don't understand what it's doing.

newins "${FILESDIR}"/openerp.cfg.2 openerp.cfg || die
Comment 34 Martin Andres Gomez Gimenez 2013-09-28 20:53:49 UTC
(In reply to A. Person from comment #33)
> Thanks Martin.  It installs great.  Does the following line need to be
> changed in the ebuild in order to use the new openerp.cfg?  I don't
> understand what it's doing.
> 
> newins "${FILESDIR}"/openerp.cfg.2 openerp.cfg || die


Sorry for my bad english! I will try explicate what it's doing: the newins function installs the openerp configuration file in the directory /etc/openerp. For this takes the file from /usr/portage/app-office/openerp/files/openerp.cfg.2 and renames it to openerp.cfg.

You have two options:

1) Put your settings in the openerp.cfg.2

or

2) Modify the ebuild
Comment 35 A. Person 2013-09-29 06:28:01 UTC
Martin, your explanation makes perfect sense.  Do you know what files/openerp.cfg is for?  It's slightly different than files/openerp.cfg.2.
Comment 36 Martin Andres Gomez Gimenez 2013-09-30 12:39:41 UTC
(In reply to A. Person from comment #35)
> Martin, your explanation makes perfect sense.  Do you know what
> files/openerp.cfg is for?  It's slightly different than files/openerp.cfg.2.

It's used for openerp-6.1.1-r1.ebuild
Comment 37 A. Person 2013-10-01 09:58:14 UTC
Now I get it.  Thanks Martin.
Comment 38 Yixun Lan archtester gentoo-dev 2013-10-10 04:49:04 UTC
Created attachment 360544 [details]
openerp-7.0.20131008.ebuild


bases on @martin work, but I remove some cosmetic changes, which will keep the changes minimal (if compare to the one in official portage tree)

1) keep the depends fix 
2) keep the broken symbol fix
3) remove userPN typo (probably caused by bad sed operation?)
Comment 39 Yixun Lan archtester gentoo-dev 2013-10-10 11:36:21 UTC
Created attachment 360568 [details]
openerp-7.0.20131008.ebuild r2

convert to distutils-r1 and EPAI=5, fix typo in "dosym" line.
Comment 40 Johannes Huber gentoo-dev 2013-12-01 14:17:16 UTC
Please dont add arches by yourself.
Comment 41 A. Person 2014-01-24 02:53:19 UTC
I've renamed the openerp ebuild to use the latest nightly for OpenERPv8.  v8 has an instant messaging feature and there is some guidance on setting it up here:

http://help.openerp.com/question/22521/how-to-activate-chat-im-in-v8-trunk/

dev-python/gevent and dev-python/psycopg are in portage and I've attached an ebuild for dev-python/gevent-psycopg2 which should cover the dependencies.  I haven't gotten instant messaging to work yet though.  I'll post again when I do.
Comment 42 A. Person 2014-01-24 02:54:48 UTC
Created attachment 368602 [details]
dev-python/gevent-psycopg2 ebuild
Comment 43 A. Person 2014-01-24 03:34:39 UTC
It's better if I point to the dev-python/gevent-psycopg2 ebuild bug instead of attaching the ebuild:

https://bugs.gentoo.org/show_bug.cgi?id=499090
Comment 44 A. Person 2014-01-24 16:55:19 UTC
Now that I look again I can see that I didn't rename the v7 ebuild to v8.  I used the v8 ebuild in dlan's overlay.
Comment 45 Yixun Lan archtester gentoo-dev 2014-01-25 01:38:39 UTC
hi @A. Person, I've talked to @patrick that I will bump this ebuild, but haven't really got time to sit down and look into this.

I'll do this in a few days. thanks

btw, if you willing to help proxy-maint this ebuild, let me know, I can help..
Comment 46 Yixun Lan archtester gentoo-dev 2014-01-25 14:23:31 UTC
+*openerp-8.0.20140125 (25 Jan 2014)
+*openerp-7.0.20140125 (25 Jan 2014)
+
+  25 Jan 2014; Yixun Lan <dlan@gentoo.org> +openerp-7.0.20140125.ebuild,
+  +openerp-8.0.20140125.ebuild, metadata.xml:
+  version bump, stable and development

please open another bug for requesting "an instant messaging feature" since I haven't addressed it in this revision bump, so this long-time-opened bug can be closed.

thanks