Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 453276 - sys-block/targetcli snapshot request
Summary: sys-block/targetcli snapshot request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Alexey Shvetsov
URL:
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2013-01-21 03:11 UTC by Andrew Hamilton
Modified: 2016-09-02 17:19 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
targetcli snapshot ebuild (targetcli-2.0_rc1_p20130119.ebuild,727 bytes, text/plain)
2013-01-21 03:12 UTC, Andrew Hamilton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Hamilton 2013-01-21 03:11:38 UTC
targetcli is used for managing the new SCSI target subsystem in the kernel.  I've copied the -9999 ebuild into a snapshot ebuild since upstream rarely tags releases (last tagged release is well over a year old).

Reproducible: Always
Comment 1 Andrew Hamilton 2013-01-21 03:12:11 UTC
Created attachment 336298 [details]
targetcli snapshot ebuild

ebuild SRC_URI references a snapshot I created that can be used by the maintainers as desired.
Comment 2 toon 2016-03-28 14:59:35 UTC
Well Jeroen,

Alexey hasn't been acting or reacting on any ticket since years.
See for instance bug #562284.
Why is he still listed as maintainer for this package?

Andrew's initiative was a very good one.
It is weird that there only is an unstable 9999-ebuild for
such an essential and critical subsystem like targetcli.

(yes, this a booster comment)
Comment 3 Alexey Shvetsov gentoo-dev 2016-03-28 19:11:45 UTC
I dont react since i didnt use it for few years. So this packages should be listed as maintainer needed
Comment 4 toon 2016-04-16 10:15:58 UTC
Hi Alexey, thanks for reaction.  Much appreciated!
So this clarifies the silence.
What is the procedure to list this package as 'maintainer needed'?
Comment 5 Patrice Clement gentoo-dev 2016-09-02 17:19:06 UTC
commit f9bfa20b5ca4393f975ebd6f70090d236a2da778 (HEAD -> master, origin/master, origin/HEAD)
Author:     Diogo Pereira <sir.suriv@gmail.com>
AuthorDate: Sun Aug 7 01:36:29 2016 +0100
Commit:     Patrice Clement <monsieurp@gentoo.org>
CommitDate: Fri Sep 2 19:18:14 2016 +0200

sys-block/targetcli: add version 3.0_pre4

Gentoo-Bug: https://bugs.gentoo.org/453276
Reported-by: Andrew Hamilton <andrew@ahamilto.net>
Closes: https://github.com/gentoo/gentoo/pull/2034

Signed-off-by: Patrice Clement <monsieurp@gentoo.org>

sys-block/targetcli/Manifest                  |  1 +
sys-block/targetcli/targetcli-3.0_pre4.ebuild | 46 +++++++++++++++++++++++++++
2 files changed, 47 insertions(+)
create mode 100644 sys-block/targetcli/Manifest
create mode 100644 sys-block/targetcli/targetcli-3.0_pre4.ebuild

Commited, thanks!