Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453204 - dev-libs/libvformat-1.13-r2: fix some API documentation errors
Summary: dev-libs/libvformat-1.13-r2: fix some API documentation errors
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: NeedPatch
Depends on:
Blocks:
 
Reported: 2013-01-20 18:08 UTC by Raphaël Droz
Modified: 2015-11-06 14:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
fix API documentation (typo and misleading call samples) (documentation-type+cast+ME-error.patch,3.07 KB, patch)
2013-01-20 18:09 UTC, Raphaël Droz
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Raphaël Droz 2013-01-20 18:08:57 UTC
There are 3 errors in the API documentation.
One is about casting va_arg which could be time-consuming to figure-out.
Another is about a misleading assumption about a fetching inside a vcard group
The last one is only a typo where function names are capitalized.


On a side note: upstream bugtracker seems read-only and no update happened for more than a decade.
Alternatively to @sf.net upstream provides another contact email at the end of README.

@maintainer: Do you ever have, by any chance, taken contact with upstream to ensure project continuation in the long-run ?

See also:
http://sourceforge.net/projects/vformat/forums/forum/116479/topic/6136544
http://sourceforge.net/tracker/?func=detail&aid=3084909&group_id=37192&atid=419516

Reproducible: Always
Comment 1 Raphaël Droz 2013-01-20 18:09:56 UTC
Created attachment 336230 [details, diff]
fix API documentation (typo and misleading call samples)
Comment 2 Chris Reffett gentoo-dev Security 2013-08-21 19:44:56 UTC
Apparently we don't build documentation on this package. Also, your patch does not apply.
Comment 3 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2014-04-09 07:28:11 UTC
[QA]

The mobile-phone herd has been dissolved to maintainer-needed due to absence.

This package has no maintainer so this bug may go unnoticed for a long time.
Gentoo has a dedicated team[1] for assisting users in maintaining orphaned
packages. If you are interested in maintaining this package, please contact
proxy-maint@gentoo.org. 

[1]: https://wiki.gentoo.org/index.php?title=Project:Proxy_Maintainers