Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 453188 - [science overlay] kde-base/kdelibs-4.9.3 and sci-libs/plasma-2.4.6 file collision in /usr/include/plasma/plasma.h , /usr/lib64/
Summary: [science overlay] kde-base/kdelibs-4.9.3 and sci-libs/plasma-2.4.6 file colli...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Science Related Packages
Depends on:
Reported: 2013-01-20 15:28 UTC by disperato
Modified: 2013-10-31 20:27 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description disperato 2013-01-20 15:28:19 UTC
Messages for package sci-libs/plasma-2.4.6
Detected file collision(s):
 * 	/usr/include/plasma/plasma.h
 * 	/usr/lib64/
 * Searching all installed packages for file collisions...
 * Press Ctrl-C to Stop
 * kde-base/kdelibs-4.9.3:4::gentoo
 * 	/usr/include/plasma/plasma.h
 * 	/usr/lib64/
 * Package 'sci-libs/plasma-2.4.6' NOT merged due to file collisions. If
 * necessary, refer to your elog messages for the whole content of the
 * above message.

Reproducible: Always

Steps to Reproduce:
1. emerge kdelibs
2. emerge sci-libs/plasma::science
Actual Results:  
sci-libs/plasma::science doesn't merge

Expected Results:  
whereas it it should

I tried, to no avail (i.e. still fails with file collision error):
1. to leave out the opengl use flag for kdelibs (and re-emerge kdelibs) in /etc/portage/package.use, apparently related to plasma.
2. As above, but  also tried to manually delete plasma files installed from kdelibs.
I'm not using kde as a desktop, but need kdelibs for some packages from kde family.

emerge --info
Portage (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r3, 3.4.9-gentoo x86_64)
System uname: Linux-3.4.9-gentoo-x86_64-AMD_Turion_Dual-Core_RM-70-with-gentoo-2.1
Timestamp of tree: Fri, 18 Jan 2013 11:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
ccache version 3.1.8 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo science x-myebs
Installed sets: @system
CFLAGS="-march=athlon64 -O2 -pipe -msse3"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe -msse3"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sfperms unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,now -Wl,--hash-style=gnu"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes --timeout=23"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/science /sync/gentoo/myebs"
USE="3dnow 3dnowext X a52 aac aalib acl acpi alsa amd64 apache2 apm aspell audiofile avi bash-completion bcmath berkdb bindist bitmap-fonts bmp bzip2 bzip2cairo caps cdparanoia cdr cli clibpdf consolekit cracklib crypt cscope ctype cuda cups cxx dbus dbx diet dillo dio directfb divx4linux dri dv dvb dvd dvdr dvdread emul-linux-86 encode examples exif expat f90 f95 fam fbcon ffmpeg fftw flac flash foomaticdb fortran fortran90 fortran95 g95 gcj gd gdbm geforce gfortran ggi gif ginac glut glx gmp gnutls gphoto2 gpl gpm gsl gstreamer gtk gtkhtml guile hal handbook hardened hardenedphp hdf5 hdtemp headphones html2ps iconv ieee1394 imlib inifile innodb ipv6 jabber jack jikes jpeg junit ladcca lcms ldap libcaca libnotify libwww lm_sensors m17n-lib mad man mhash mikmod mime ming mjpeg mmx mng modules motif mp3 mpeg mplayer msession mudflap multilib mysql mysqli ncurses netcdf nforce nls nptl nsplugin nvidia nvidia-glx objc ofx ogg openal opengl openmp osc pam pcre pdflib perl php plotutils png policykit portaudio ppds pppd python qdbm qt qt3support qt4 quicktime radius readline ruby samba scanner sdl session sharedext shorten simplexml slp smu sndfile speex spell spl sse sse2 ssl ssse3 svg szip tcltk tcp tcpd tetex theora tidy tiff tls tokenizer truetype truetype-fonts type1-fonts udev unicode usb vcd videos vim-syntax vorbis wddx wifi wireless wmf xfce xfce4 xine xml xmlrpc xmms xosd xpm xscreensaver xsl xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access auth auth_dbm auth_anon auth_digest authz_host alias file-cache echo charset-lite cache disk-cache mem-cache ext-filter case_filter case-filter-in deflate filter mime-magic cern-meta expires headers usertrack unique_id proxy proxy-connect proxy-ftp proxy-http info include cgi cgid dav dav-fs vhost-alias speling rewrite log_config logio env setenvif mime status autoindex asis negotiation dir imap actions userdir so" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="epson epson2 canon canon630u canon_dr canon_pp" USERLAND="GNU" VIDEO_CARDS="fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Andrew Savchenko gentoo-dev 2013-10-01 03:13:31 UTC
Looks like this is fixed for 2.5.1:

*plasma-2.5.1 (12 Jul 2013)

  12 Jul 2013; Sébastien Fabbro <> +plasma-2.5.1.ebuild:
  sci-libs/plasma: Version bump. Avoid collision with KDE plasma (github issue

Please update and close this bug.