Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 452900 - dev-vcs/subversion-1.7.7 when rubygems isn't installed for ruby18 - .../work/subversion-1.7.7/libtool: line 1130: none: command not found
Summary: dev-vcs/subversion-1.7.7 when rubygems isn't installed for ruby18 - .../work/...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Thomas Sachau
URL:
Whiteboard:
Keywords:
: 458940 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-19 06:25 UTC by m.unarist
Modified: 2014-04-22 08:47 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (file_452900.txt,216.81 KB, text/plain)
2013-01-19 06:31 UTC, m.unarist
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.unarist 2013-01-19 06:25:40 UTC
Subversion's ruby binding depends dev-lang/ruby:18 only, but its compilation fails if rubygems isn't installed for ruby18.

I think this report is same as Bug 167536, but /etc/env.d/10rubygems is seems to be needed for
ruby19 in my environment.

Reproducible: Always

Steps to Reproduce:
1. emerge ruby:1.8 (without rubygems)
2. emerge subversion with ruby USE flag
Actual Results:  
ERROR: dev-vcs/subversion-1.7.7 failed (compile phase):
  Building of Subversion SWIG Ruby bindings failed

Expected Results:  
No errors reported.

# emerge --info
Portage 2.1.11.31 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_X_980_@_3.33GHz-with-gentoo-2.1
Timestamp of tree: Thu, 17 Jan 2013 09:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo local arcon betagarden sunrise
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-a -j5"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch parallel-install protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
LANG="ja_JP.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j25 -l 10.0"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/arcon /var/lib/layman/betagarden /var/lib/layman/sunrise"
SYNC="rsync://rsync.jp.gentoo.org/gentoo-portage"
USE="X acl acpi alsa amd64 bluetooth branding bzip2 cairo cdr cjk cli consolekit cracklib crypt cups cxx dbus device-mapper dri dvd dvdr faac ffmpeg flac gdbm gnome gnome-keyring gstreamer gtk iconv icu ipod jpeg lame libnotify lm_sensors mad mmx modules mp3 mudflap multilib mysql ncurses nls nptl nvidia opengl openmp pam pango pcre perl php png policykit pppd qt3support readline ruby samba session spice sqlite sqlite3 sse sse2 ssl ssse3 startup-notification symlink tcpd threads udev unicode usb vdpau vim-syntax xcb zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev wacom synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ja" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64 arm" RUBY_TARGETS="ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

# eselect ruby list
Available Ruby profiles:
  [1]   ruby18 *
  [2]   ruby19 (with Rubygems)
Comment 1 m.unarist 2013-01-19 06:31:56 UTC
Created attachment 336092 [details]
build.log
Comment 2 Hans de Graaff gentoo-dev 2013-01-20 08:50:40 UTC
(In reply to comment #0)
> Subversion's ruby binding depends dev-lang/ruby:18 only, but its compilation
> fails if rubygems isn't installed for ruby18.

Can you confirm that this problem is fixed when installing rubygems?

> I think this report is same as Bug 167536, but /etc/env.d/10rubygems is
> seems to be needed for
> ruby19 in my environment.

That environment file is shared between ruby implementations to avoid compatibility issues between 1.8 and 1.9 on Gentoo, we can drop it once 1.8 is gone from the tree. If you only install ruby 1.8 you don't technically need this file, but since you also have 1.9 installed this file gets installed and you have this problem with ruby 1.8.

@subversion maintainer: subversion still doesn't support ruby 1.9?
Comment 3 m.unarist 2013-01-20 09:22:23 UTC
(In reply to comment #2)
> Can you confirm that this problem is fixed when installing rubygems?

Yes, I tried below emerging,

# USE=ruby RUBY_TARGETS="ruby18 ruby19" emerge -1 rubygems
 subversion
[ebuild   R    ] dev-ruby/rubygems-1.8.24  RUBY_TARGETS="ruby18*" 
[ebuild   R    ] dev-vcs/subversion-1.7.7  USE="ruby*" 

and it was succeeded.

> > I think this report is same as Bug 167536, but /etc/env.d/10rubygems is
> > seems to be needed for
> > ruby19 in my environment.
> 
> That environment file is shared between ruby implementations to avoid
> compatibility issues between 1.8 and 1.9 on Gentoo, we can drop it once 1.8
> is gone from the tree. If you only install ruby 1.8 you don't technically
> need this file, but since you also have 1.9 installed this file gets
> installed and you have this problem with ruby 1.8.

So should I keep rubygems for all installed ruby implementations?
Comment 4 Thomas Sachau gentoo-dev 2013-04-19 18:08:23 UTC
(In reply to comment #2)
> (In reply to comment #0)
> > Subversion's ruby binding depends dev-lang/ruby:18 only, but its compilation
> > fails if rubygems isn't installed for ruby18.
> 
> Can you confirm that this problem is fixed when installing rubygems?
> 
> > I think this report is same as Bug 167536, but /etc/env.d/10rubygems is
> > seems to be needed for
> > ruby19 in my environment.
> 
> That environment file is shared between ruby implementations to avoid
> compatibility issues between 1.8 and 1.9 on Gentoo, we can drop it once 1.8
> is gone from the tree. If you only install ruby 1.8 you don't technically
> need this file, but since you also have 1.9 installed this file gets
> installed and you have this problem with ruby 1.8.
> 
> @subversion maintainer: subversion still doesn't support ruby 1.9?

last time i checked: no

i committed an updated subversion-1.7.9 ebuild, which requires rubygems[ruby_targets_ruby18] so this should enforce the needed rubygems versions and allow everyone to build subversion with ruby bindings.
Comment 5 Thomas Sachau gentoo-dev 2013-04-19 18:08:59 UTC
*** Bug 458940 has been marked as a duplicate of this bug. ***
Comment 6 Hans de Graaff gentoo-dev 2013-04-21 07:48:18 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > (In reply to comment #0)

> > @subversion maintainer: subversion still doesn't support ruby 1.9?
> 
> last time i checked: no

Note that ruby 1.8 is most likely going away sometime in the summer because at that time upstream will no longer provide support for it. Upstream currently only provides security-related support for this version.
Comment 7 m.unarist 2014-04-22 08:47:42 UTC
(In reply to Thomas Sachau from comment #4)
> i committed an updated subversion-1.7.9 ebuild, which requires
> rubygems[ruby_targets_ruby18] so this should enforce the needed rubygems
> versions and allow everyone to build subversion with ruby bindings.

The enforcing works fine, thanks!

I close this bug because new discussion about depending ruby1.8 is started in bug 483102.