Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 452852 - dev-util/insight-6.8.1 with >=dev-tcltk/itcl-4.0.0 - Error: can't find package Itcl 3.3
Summary: dev-util/insight-6.8.1 with >=dev-tcltk/itcl-4.0.0 - Error: can't find packag...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard: Pending removal: 2016-11-08
Keywords: PMASKED
Depends on:
Blocks: tcltk-8.6
  Show dependency tree
 
Reported: 2013-01-18 15:45 UTC by Andreas Proteus
Modified: 2016-11-09 10:24 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge.info,5.72 KB, text/plain)
2013-01-18 15:45 UTC, Andreas Proteus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Proteus 2013-01-18 15:45:45 UTC
Created attachment 336056 [details]
emerge --info

Steps to reproduce:

* emerge =dev-tcltk/itcl-4.0.0-r2 
 
* emerge =dev-util/insight-6.8.1 . 
  To do this you may need to look at bug #451368 and  bug #441036.

* Run Insight. It fails with the error message:
  "Error: can't find package Itcl 3.3"

* emerge =dev-tcltk/itcl-3.4.1
Insight then runs normally.
Comment 1 Fred Krogh 2015-06-16 23:42:17 UTC
I just installed insight-6.8.1-r1 and have the same problem with itcl-4.0.3.
Comment 2 Ralf Ramsauer 2015-09-02 14:30:33 UTC
Confirmed, same here.
Comment 3 Kobboi 2015-11-08 14:17:53 UTC
And here
Comment 4 Phil Stracchino (Unix Ronin) 2016-09-19 21:27:40 UTC
Just got bitten by this myself.  dev-tcltk/itcl-4.0.3, dev-tcltk/itk-4.0.1, dev-util/insight-6.8.1-r1, trying to use it to debug an input problem with media-sound/grip-3.3.1.  Cannot back out to dev-tcltk/itcl-3.4.1 because of multiple packages depending on >=dev-lang/tcl-8.6.

(Yes, I still use Grip even though Gentoo has dropped the ebuild.  Nothing even half as good, let alone compatible with its database, has come along to replace it.)
Comment 5 Pacho Ramos gentoo-dev 2016-09-30 15:38:21 UTC
CCing treecleaners as we won't block forever tcltk-8.6 stabilization for this (also, looking to the huge amount of patching this needs as I see in Fedora, this needs a dedicated maintainer)
Comment 6 Pacho Ramos gentoo-dev 2016-11-09 10:24:50 UTC
removed