Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 452608 - app-pda/gtkpod-2.1.3-r1 with dev-util/anjuta-3.4.3 - In function ‘on_layout_lock_toggle’: anjuta-action-callbacks.c:68:3: error: implicit declaration of function ‘gdl_dock_layout_get_master’ [-Werror=implicit-function-declaration]
Summary: app-pda/gtkpod-2.1.3-r1 with dev-util/anjuta-3.4.3 - In function ‘on_layout_l...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo PDA Herd
URL:
Whiteboard:
Keywords:
: 464074 (view as bug list)
Depends on:
Blocks: 463660
  Show dependency tree
 
Reported: 2013-01-16 21:07 UTC by Daniel Peters
Modified: 2013-04-10 15:29 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
app-pda-gtkpod-2.1.3-r1 build log (app-pda:gtkpod-2.1.3-r1:20130116-203537.log,44.09 KB, text/plain)
2013-01-17 20:21 UTC, Daniel Peters
Details
Only apply gdl 3.6 patch when needed (gtkpod.patch,484 bytes, patch)
2013-01-23 17:59 UTC, Andrew John Hughes
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Peters 2013-01-16 21:07:23 UTC
Building app-pda/gtkpod-3.1.3-r1 against dev-util/anjuta-3.4.3 fails with
"anjuta-app.c:255:5: error: implicit declaration of function ‘gdl_dock_layout_get_master’ [-Werror=implicit-function-declaration]"

With dev-util/anjuta-3.6.2-r1, everything is fine.

FF,
Daniel
Comment 1 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-01-16 21:52:26 UTC
1. Please provide the `emerge --info =app-pda/gtkpod-3.1.3-r1` output in a comment.
2. Please attach the complete build log to your bug.
Comment 2 Daniel Peters 2013-01-17 20:21:10 UTC
Created attachment 335950 [details]
app-pda-gtkpod-2.1.3-r1 build log
Comment 3 Daniel Peters 2013-01-17 20:21:48 UTC
Here we go:

# emerge --info =app-pda/gtkpod-3.1.3-r1
Portage 2.1.11.43 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r3, 3.7.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.7.0-gentoo-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.1
KiB Mem:     2028204 total,     89704 free
KiB Swap:    5654868 total,   4905872 free
Timestamp of tree: Wed, 16 Jan 2013 19:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo kde x11 systemd usr-local
Installed sets: @system
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA PUEL AdobeFlash-10.3"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /lib64/rcscripts/net /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/home/root/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n --with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde /var/lib/layman/x11 /var/lib/layman/systemd /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnowext X a52 aac acpi alsa amd64 audiofile avahi avi bash-completion berkdb bluetooth bzip2 cairo cdaudio cdda cdparanoia cdr chm cjk cli consolekit cracklib crypt css cups curl custom-cflags custom-optimization cvs cxx dbus declarative dirac divx4linux dri dts dv dvb dvd dvdr dvdread ebook encode exif expat extrafilters faac faad ffmpeg firefox flac fortran gd gdbm gimp glitz gpm gstreamer gtk handbook hbci iconv icu imagemagick imap innodb ipod java joystick jpeg kde kde4 kdeenablefinal kdehiddenvisibility kipi lame latex libsamplerate lm_sensors logrotate lzma mad mbox mikmod mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib musicbrainz mysql ncurses nls nptl ntp ofx ogg oggvorbis opengl openmp pam pcre pdf perl phonon plasma png policykit pppd python qt qt3support qt4 readline scanner sdl semantic-desktop session sndfile sox sql sqlite sqlite3 srvdir sse sse2 ssl ssse3 svg system-sqlite systemd taglib tcl tcltk tcpd theora threads tiff timidity tk truetype udev unicode usb v4l2 vcd videos vim-syntax vorbis vpx webkit wma wmf x264 xcb xcomposite xine xml xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de hu" LIRC_DEVICES="devinput hauppauge_dvb hauppauge serial" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="vesa i810 intel v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 4 jannis 2013-01-18 20:06:19 UTC
please change app-pda/gtkpod-3.1.3-r1 to app-pda/gtkpod-2.1.3-r1. Or did you really mean 3.?
Comment 5 Andrew John Hughes 2013-01-23 17:07:58 UTC
This is a dependency issue, both in gtkpod and the ebuild.  It requires gdl >= 3.6 for this function, though the gdl documentation doesn't appear to document it.
Comment 6 Andrew John Hughes 2013-01-23 17:10:49 UTC
Sorry, totally the ebuild at fault.  It applies a patch, gtkpod-2.1.3-gdl-3.6.patch unconditionally, without bumping the dependency.
Comment 7 Andrew John Hughes 2013-01-23 17:59:50 UTC
Created attachment 336616 [details, diff]
Only apply gdl 3.6 patch when needed

Simple fix to the ebuild.
Comment 8 Daniel Peters 2013-02-01 22:49:13 UTC
(In reply to comment #7)

With this path, it builds fine.

FF,
Daniel
Comment 9 darkbasic 2013-03-10 21:05:13 UTC
Why didn't somebody commit the patch? It's still broken in portage...
Comment 10 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-03-11 13:37:53 UTC
Because the Gentoo PDA herd only contains a single maintainer at the moment, and looking at the commit history that maintainer is quite busy at the moment; it'll be done once he comes across it in his queue.
Comment 11 Samuli Suominen gentoo-dev 2013-04-01 13:48:42 UTC
*** Bug 464074 has been marked as a duplicate of this bug. ***
Comment 12 Pacho Ramos gentoo-dev 2013-04-02 19:36:31 UTC
As gdl-3.6 is already stable, I would simply change dep to >=3.6 version
Comment 13 Samuli Suominen gentoo-dev 2013-04-10 15:29:24 UTC
fixed in 2.1.3-r1 ebuild without revbump