Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 452164 - dev-util/nvidia-cuda-toolkit-5.0.35: cuda-gdb linked against missing libtinfo.so.5
Summary: dev-util/nvidia-cuda-toolkit-5.0.35: cuda-gdb linked against missing libtinfo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Justin Lecher
URL:
Whiteboard:
Keywords:
Depends on: 452532
Blocks:
  Show dependency tree
 
Reported: 2013-01-15 00:03 UTC by Marius Brehler
Modified: 2013-02-12 15:18 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marius Brehler 2013-01-15 00:03:26 UTC
The Ubuntu and Fedora package include a version of the cuda-gdb which is linked against libtinfo.so.5.

revdep-rebuild reports:
[ 4% ]  *   broken /opt/cuda/bin/cuda-gdb (requires libtinfo.so.5)

It seems that libtinfo.so.5 is not shipped with Gentoo. After a short research it comes out that libtinfo.so actually is provided by libncurses.so. One possibility might be to provide a simlink (within the ncurses ebuild?) or another possibility (untested) is switching to the OpenSuSE binaries:

http://en.usenet.digipedia.org/thread/18916/18365/

Reproducible: Always
Comment 1 Justin Lecher gentoo-dev 2013-01-16 12:37:23 UTC
I requested libtinfo for ncurses. we will see how the maintainer react.

please use following hack meanwhile_if_necessary:

ln -sf libncurses.so /usr/lib/libtinfo.so.5
Comment 2 Marius Brehler 2013-01-16 20:07:11 UTC
Thanks the quick reply and your request regarding the ncurses package. Unfortunately the hack is not working:

cuda-gdb: error while loading shared libraries: /usr/lib64/libtinfo.so.5: invalid ELF header

Right now, I don't have to use the cuda-gdb, but as I follow the discussion on issue 452532, just a symlink doesn't seems to be the solution (using ncurses 5.9-r2).
Comment 3 Justin Lecher gentoo-dev 2013-01-17 07:44:31 UTC
+  17 Jan 2013; Justin Lecher <jlec@gentoo.org>
+  +nvidia-cuda-toolkit-5.0.35.ebuild:
+  Add new dep on libtinfo.so, #452164
+

deps fixed.
Comment 4 Marius Brehler 2013-01-17 19:18:56 UTC
Thanks for fixing it that fix and clean :-)
Comment 5 Joshua Anderson 2013-02-12 15:01:46 UTC
This fix appears to have been undone in -r2. There is no longer a depend on curses with the tinfo use flag.
Comment 6 Justin Lecher gentoo-dev 2013-02-12 15:18:44 UTC
+  12 Feb 2013; Justin Lecher <jlec@gentoo.org>
+  nvidia-cuda-toolkit-5.0.35-r2.ebuild:
+  Readd ncurses[tinfo], which was accidentally dropped
+