Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 451846 - wireless-tools no longer function with default installation
Summary: wireless-tools no longer function with default installation
Alias: None
Product: [OLD] Docs on
Classification: Unclassified
Component: Installation Handbook (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Docs Team
Depends on:
Reported: 2013-01-13 19:00 UTC by Ryan Domigan
Modified: 2013-02-23 17:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Domigan 2013-01-13 19:00:14 UTC
I attempted to configure my wireless card using wpa_supplicant -Dwext (as had worked with this card in my prior installation), but neither that nor iwconfig work with my new (January 5, 2013) installation.

wpa_supplicant -Dnl80211 works, and I can get status information with the 'iw' tool, but neither the necessary driver nor the tool are mentioned in the installation docs, and I spent quite a long time searching before stumbling on my solution.

I tried the linux-3.6.11-gentoo or linux-3.7.1-gentoo kernels.

the network card uses the rt2800pci module
03:00.0 Network controller [0280]: Ralink corp. RT2790 Wireless 802.11n 1T/2R PCIe [1814:0781]

Reproducible: Always

Steps to Reproduce:
1. Follow handbook installation guide
2. Configure kernel and load module for wireless card
3. install wireless-tools and wpa_supplicant
4. configure /etc/wpa_supplicant/wpa_supplicant.conf to use wext driver (as per previous installation)
5. try iwconfig
Actual Results:  
iwconfig gives the message "wlan0     no wireless extensions.", 
when attempting '/etc/init.d/net.wlan0 start' I get IOCTL errors followed by a 'network inactive' message

Expected Results:  
a working connection and some useful status information from iwconfig
Comment 1 Sven Vermeulen (RETIRED) gentoo-dev 2013-01-20 16:04:16 UTC
I don't think this is a documentation problem per se, but rather a regression in the kernels or applications?
Comment 2 Sven Vermeulen (RETIRED) gentoo-dev 2013-02-23 17:37:03 UTC
I don't think we tell users that they should use wext (we have one example in the instructions, using madwifi, and with the comment that we definitely need to give the right one). Imo, this isn't a documentation bug, nor something Gentoo related.